FIXED with 3.8.1 - 3.7.3 and 3.8 windows software DOESNT WORK

@Joao_Antonio, I moved this post into this topic because it looks similar to the discussion here.

Is it possible to contact the official Ricoh support in your country? This problem doesn’t occur for everyone, but other people have the same problem that you do.

In this thread, some people have reported success using an older version of the desktop software.

Hi Folks…
sorry but i have to make trouble with the Software-application from the Theta V
i am using a desktop pc with win 7 & 10…
i did my 360° footage with my new theta v…then i downloaded the rico-theta software to stich the footage…and then…everytime when i try to drag the original footage into the application…it shows an error-report with " An error has occurred- failed to load file"
i got the newest version on my desktop & the theta v´s is updated as well…adobe air is also updated…
how can this be? ricoh developing a 360° camera whose footage doesnt work with the original software…??? what the hell?
maybe you can help me…thx

If this is the same problem as below, I will merge this topic. A new version of the desktop app came out yesterday. Please try that. If it doesn’t work, try an older version. See the thread below.

I can’t replicate the problem.

3.7.3 windows software DOESNT WORK

Ricoh Hardware and Software

The same problem for me - new 3.8.0 version didn’t work at all. Hopefully old version was stored - 3.7.0. - it’s working properly. Please solve the problem with new app and auto update.

I’ve merged this topic with the existing topic about 3.7.3 not work. I also changed the title to indicate that people are having problems with 3.8.

Just an FYI, this is an independent community forum, not an official RICOH support site. There’s no direct access to people that can modify the desktop software. What we can do is share usage tips. We also have limited ability to send feedback to Ricoh, but we can’t fix any problems with the software.

Again, no problem asking for help, but just want you to know the situation with this forum so you don’t get frustrated with an expectation that problems with the software can get solved by posting here.

Hope you have a great New Year’s Day.

Hello good day! If it is not the indicated forum, please, if there is someone who can indicate where to make my query.


A few days ago I updated the fimware of my camera RICOH THETA V as indicated above and the process was carried out correctly. The problem is that now when I download the videos and convert them with the RICOH THETA basic application for Windows, it does not convert them.

Below I detail the updates of my current applications:

Basic application RICOH THETA for Windows ® last update 13 Dec 2018 version 3.8.0
Application RICOH THETA Movie Converter version 2.0.1

THETA S application for smartphone last update 12 Dec 2018 version 1.21.0
THETA + app for smartphone last update 12 Dec 2018 version
THETA + Video application for smartphone

The latest firmware version for the RICOH THETA V is from November 8, 2018 "Version 2.50.1".

I would pray if you could help me since I have been trying to solve this great inconvenience and I have not been able to achieve it.

Thank you for your attention.


I don’t have the same problem, so I may not be able to provide any useful info. I just want to confirm a couple of things first:

– You could successfully convert videos before? If so, when did it stop working?
– What happens after you try to convert your videos?
– Are you just viewing the videos on your computer or uploading them to YouTube?


It may be similar to the problem discussed in the topic below:

1 Like

Thanks for pointing that link out

Does it seem like the same problem to you? If so, merge the relevant topic posts.

The problem with the desktop software appears to occur only for certain geographies.

Hello Jesse, good day!

Yes, before the update the videos were converted correctly.
When trying to convert the videos I get the following error:

I watch the videos on the PC.

From what the fellow codetricity has said the problem seems to be with the RICOH THETA desktop app for Windows (R) versions 3.7.3 and 3.8.0. Apparently, with version 3.7.0 the problem disappears.

Know of a reliable place to download the 3.7.0 app.

Another issue, my interest in updating the firmware of the camera to version 2.50.1 and the desktop and smartphone app is to install some plug-ins. With the firmware of the camera updated to version 2.50.1 Is it necessary to have the basic PC desktop app updated to the latest version 3.8.0 ?.

Thank you for your attention.

Hi @Josep,

Just answering one part quickly, as I’m headed off to sleep. :sleepy: Firmware 2.50.1 is great and it probably does NOT require the basic PC desktop app to be the latest version. I believe it will still work just fine.


Hello Craig, good morning!

Yes, the problem is the same.
I have the RICOH THETA desktop app for Windows (R) version 3.3.1

but when I install it it automatically updates me to version 3.8.0. Do you know how I can prevent it from being updated?

Thank you for your attention.

For a one-time use to get video converted, you may be able to disconnect you computer from the network to prevent the update.

The problem seems to only occur on certain language versions of Windows 10. Have you tried contacting the official Ricoh customer support? I imagine that they’ve heard of this problem before and may have a solution.

Hello Craig, good morning!

It’s true, I had not thought about this option. Thank you!

Yes, last day 8 I got in touch with the official service, I’m waiting for an answer. As soon as they respond, I tell you the result.

Do you know if there is any problem in installing plug-ins with the RICOH THETA desktop app installed for Windows ® version 3.3.1?

Thank you for your attention.

The older versions of the desktop app do not have the capability to install plug-ins. The best solution is to get a fix from the official Ricoh customer support. It may just be a configuration file specific to the language support in your area. You can send them the link to this topic to show that there are multiple people with this problem.

I can’t replicate the problem on my computer. I’m only using English on my Windows 10 system.

1 Like

Hi good afternoon!

In the end I was able to convert the videos correctly. It’s very easy, at least it works for me.
As already pointed in some thread, you just have to reconfigure the language in Windows 10. I set it up in English UK, and now I converted the videos well with the desktop application for Windows ® version 3.8.0



This is great news. Thank you for the update.

Very pleased you got it working! Nice sleuthing.


I recently got 5 Theta V camera’s for an educational project.
As recommended I downloaded the 3.7.0 version after the 3.8.0 was unable to load my recorded video files.
I can start the conversion but it always prompts the following:

Anyone here that can help me fix this?