How To: Edit and Stitch RAW DNG Images From RICOH THETA Z1 with Adobe Lightroom Classic CC and THETA Stitcher

Tips on Using Stitcher

Problem: No compatible DNG files

Solution: Check filename and directory

The filename and the directory of the output of Lightroom Classic CC must match the original DNG file location and name.


Click on images to get larger view.



More working examples

Example from Steve Swayne on Facebook.

Having explored some more, I now recommend using TIFF and not JPG as I showed in that screen grab. It seems the stitcher returns the file to Lightroom in the same format it gets, thus an uncompressed TIFF would be the obvious choice to reduce the introduction of additional artefacts and image degradation through another save into JPG format.


Steve, thanks for your help with these tips. This is all new to me and I could use all the advice you’re willing to provide. TIFF at 16 bits/compressed is good?

1 Like

Thanks for this tip, Steve. Really helpful.

TIFF at 16 bits/compressed is good?

Yes, 16 bit TIFF is the right choice. You can also use Zip compression which is lossless but doesn’t gain much on photographic subjects (maybe 10-20%).

1 Like

My initial tests show that going via the DNG workflow results in significantly better results than the out-of-camera JPEGs. Maybe I can post some examples later. Will also compare the Z1 with its grandma S (or is it the grandpa?) …


Here’s a sample image to illustrate my previous statement.

Just to give an overview of the scene, this is the DNG (scaled down):

This was taken with 100 ISO and f2.1.

Then two detail sections from this exposure …

First, from the out-of-camera JPEG (‘OOC JPEG’):

Second, from the DNG, developed in Lightroom (default settings, no tweaks) and stitched in Ricoh’s stitcher (AKA ‘processed DNG’):

Comparing the results shows:

  1. The size of the two images is slightly different:
    OOC JPEG: 6720 x 3360
    processed DNG: 7296 x 3648
  2. The OOC JPEG shows unnaturally saturated colors
  3. The OOC JPEG shows fewer details due to strong noise reduction and sharpening applied

This is all with default settings. The processed DNG can probably be further improved by fine-tuning the development.

Conclusion: If you want the best image quality, use the raw image data in the DNG file and an appropriate workflow!

(NB: What’s not visible from this sample are differences in the dynamic range. But, of course, the DNG is expected to win in this discipline as well …)


Is anyone else seeing issues with files that you have renamed before editing in Lightroom not working when exported to the Theta Stitcher app? From what I am seeing, the stitcher will only work with files using the file naming structure the camera uses (e.g. R0010003.DNG).

I shot some images yesterday and renamed the files to something like this: 2019-06-01-Plane-000001.dng. After editing the image in Lightroom and trying to edit it in the Stitcher, I get an error saying that a DNG must be in the same directory. Simply renaming the file to “R0010003.DNG” an exporting it again works fine.

I tried some other file names (e.g. “plane.DNG”), but the ONLY file format that seems to work is a capital R followed by a series of numbers.

Note: I am doing this on a Mac.

Yes, this is a restriction also documented in the help file for the stitcher. The reason for this is obscure to me.

BTW: I also don’t understand why the suggested workflow (as described above and in the help file) is using the export function of Lightroom. For me, it’s more natural to call the stitcher via ‘Edit In’ as illustrated in this screen shot:

My configuration for this is:

Using the export function would make sense for batch processing a set of images. But unfortunately, the stitcher currently only accepts a single image.

A UI-less batch mode stitching with default parameters or even specifying parameters on the command line should be on the list of possible improvements!

1 Like

Hi, i try to use this plug’in but when i validate my settings in the plug’in and i clic on OK, i have this error

“Les images n’ont pas pu être traitées 0x00010505”

Translation of that
“Images could not be processed : 0x00010505”

Tkx for your help

Please post a screenshot of your Lightroom Classic CC settings with filename filled in

Hi, there is my setting

and my workflow

Thanks for posting this detailed information. I think the settings look okay.

Please post:

  • version of MacOS
  • Version of Lightroom Classic CC
  • amount of RAM in computer (needs to be 16GB or higher)

Hi, thanks for your Help.

Lighroom 8.1
Windows 10 64bit 2019
Intel HD graphics 4600 Open GL ???
but i only have 8gb of memory :confused:

I juste add 8GB of memory to reach 16gb and i still have this problem.

I do not have this problem, so I can’t test it. However, it might be worth updating your Intel graphics drivers.

What version of Windows 10?

Type “System Information” in searchbox in taskbar

Free Intel HD Graphics Control Panel

Hi, Thanks for your Help, but sadly, updating driver doesn’t help.

And your right, this error code is in Readme PDF of the Stitcher, and:

The images could not be processed successfully: 0x00010505 -> there is insufficient memory.

But now i have 16gb on my computer :confounded:

Have you tried to contact the official RICOH customer support? They likely have a bigger database with support queries. I think you have a good set of information to report. It seems like your configuration and versions are up to date.

This THETA Stitcher is new and a bit tricky to use.

Have you tried using the trial version of PTGui as a test? I realize that PTGui is a bit pricey, but it may help you to experiment with the DNG images while you sort out the stitching. Information on PTGui is here.

This is likely unrelated, but the Windows machine I used for testing does have an external NVIDIA graphics card and I’m using the NVIDIA drivers. The machine used in the test only has 16GB of memory, same as your machine.

While it’s surely always a good idea to check the specified prerequisites, I doubt that non-conformance is causing the problem in this case. Especially, as 16 GB is plenty of memory. I run Lightroom and the stitcher with 8 GB without any problems.

Perhaps the error message is misleading due to lazy programming. Typically, processing may fail during one of three stages:

  1. reading the input file
  2. processing the image (stitching) in memory
  3. writing the output file

As the image is previewed in the stitcher’s GUI, stage 1 and 2 seem to be OK. But what may fail at stage 3? Some guesses:

  1. Disk full
  2. Disk/folder/file write protected or write permission missing
  3. Special characters in the path that the OS or application can’t handle
  4. Path too long to be handled by the OS or application (Windows is prone to this)

I have already ask to the official support, waiting for an solution, but right here there is a loot of specialist :grinning: