HowTo: RICOH THETA V 4K Live Streaming With "UVC 4K" Driver For Windows 10



has anyone tried to stream with a third-party mobile app? There’s probably more apps out there than there were for the THETA S. The THETA V outputs equirectangular video, which makes it easy for mobile app developers to build apps for the stream. The main issue is that the THETAV V is new and the resolution is higher, so maybe the mobile app developers need to adjust their apps.

Past articles on these types of apps.


I also would like to try the UVC 4K app! I have a similar issue as someone else mentioned, I cannot get it to recognize in OBS.



I just sent the link by DM. Are you running OBS on Windows 10?


Yup, Win10. But I am using Win10 Studio, not sure if that makes any difference. Trying the driver now, thanks!


On Windows 10, there’s a known problem getting the RICOH THETA V driver to be recognized. Hopefully, it should work with UVC 4K. Ricoh indicates that Windows 10 at 1703 or higher should work.

Audio doesn’t work from the camera, though you can mix it on OBS though a microphone plugged into your computer.

Cool that you have Windows 10 Studio. It looks amazing.


Yup it works now! :slight_smile: Thanks!


Still no sign of release the 4k driver. I only managed to make it work on MPC-HC. Can you send me the link for beta version
I got the UVC 4K driver. I see the 4k in OBS but it display error 0x800705AA


That error occurs when the computer is not finding the camera.

  • reboot the camera and try it again
  • unplug the USB cable and then plug it back in, try it again
  • disconnect all other webcams and then reboot your Windows 10 machine, try it again
  • confirm that the camera is in live streaming mode

Is your “Live” LED on your camera flashing like this?

Do you have an old version of a driver installed from another camera like the THETA S?

Other possibilities:

  • change the USB cable
  • make sure the THETA V is fully charged (or at least charged at 50%)
  • update the firmware of the THETA V with the desktop application


I’m having some troubles streaming my THETA V on a Windows 10 laptop. I haven’t quite figured it out yet, but based on @codetricity’s info here, I’m noticing that in Device Manager, RICOH THETA V is listed under Other Devices but that it says “The drivers for this device are not installed. (Code 28)”. I’m going to try reinstalling the UVC 4K driver and see if that changes things.

EDIT: I’m not sure this matters. I uninstalled and reinstalled the UVC 4K driver. And I now have streaming using OBS. When I check the Device Manager, it has the same information under RICOH THETA V Properties.



I would be very appreciative if you can DM me the link for the 4K driver :slight_smile:

Edit: i am using Windows 10 x64




It’s good that you got it working again.


Did it start streaming on the Mac again too? Or, does it only work on Windows? Was the driver the only problem?


It was some camera issue. It went frozen after trying to take photo. On andoroid app there was a msg that its still processing photo for about 30min, after that i managed to do turn off the camera using shuter and power button combination (before that even the power button didnt worked no metter how long i was holding it). After that restart everything worked fine.


Just saw this FAQ. RICOH is putting the driver out on their public site.


Live video is not displayed on a Computer

  • Windows10 (version1703) or later
  • macOS Sierra (version 10.12.4) or later

If live video is not displayed with OBS in Windows 10 (version 1703) or later, please try the following applications. Please be aware that there is no guarantee they will work.

  1. Click here if you are using a 64-bit OS
  2. Click here if you are using a 32-bit OS


Thanks for the usage report. I think there’s a few issues people are seeing with the THETA V that can be helped with this type of sharing of information in a community:

  • firmware is new and there may be a few glitches, such as the camera locking or acting weird under certain usage conditions.
  • official user documentation is a bit sparse and doesn’t obviously state things like this, which gives a tip to press the power button and wireless button together for 6 seconds
  • Unlike the THETA S, the THETA V has a sleep mode. A single short press on the power button puts the camera to sleep, it does not reboot the camera. To reboot the camera, you need to press and hold the power button. I think this could be clarified in the documentation

From everything we can tell, the camera is a solid piece of equipment with great functionality and a good path toward free upgrades with firmware, plug-ins, mobile apps, and desktop apps and utilities. there’s also a path for third-party paid upgrades for apps, plug-ins and accessories.

As the documentation is online, Ricoh can update it regularly. I’m seeing new updates to the documentation every week. Also, Ricoh seems willing to work with the community. Considering that they are a massive multi-billion dollar company, I think they are quite good with things like releasing software and utility updates and communicating what the limitations are.


Hi @codetricity,
I tried it in windows7 and it’s not worked at all.
In Mac book pro case, it seem like cannot connect my Theta V, even I used the Parallel in Mac book and run OBS, it cannot detect Theta V as below image shown.


Thank you for the testing report. I don’t think that you’ll be able to stream on Windows 7, at least not with the UVC 4K driver. On Mac, assuming you’re using 10.12.4 or later, your wiring and camera mode looks good. Try pressing the power and WiFi buttons on the camera down for 6 seconds, then connect the USB cable to your Mac again.

Your camera should reboot.

@jcasman as you had this same problem, can you test the streaming again on a Mac?


Just got my Theta today, and yup I’m having the same streaming with OBS issue. Could I get a DL link for this magic software?

Thanks in advance! (^_^)


UVC 4K is now available on the Ricoh site. Here’s the direct link to the original Ricoh article as well as the direct download links for the driver.



I’ve grabbed the UVC4K, but still can’t get the UVC app to actually register a theta V on Win10.