No Longer Working: THETA V with Ethernet

Oh, this could be very cool! Very curious to hear what you find out.

1 Like

Whoa duh, why didnt i think of this. This is a big deal if it works! Given the USB spec just has a power rail, I see no reason why it wouldnt.


I am surprised no one else has looked into this,
I myself am very in to otg connectors since they showed up.
I’m glad they decided on Type-C for the Z1, that means more then 1 device can be connected throught a adaptor like this with not much loss of transfer speed, also would allow for gigabit ethernet, and a connected local storage device, and any usb that would also work.

Also the y cable is charging And on the network.

OH yes the last magic trick up my sleve…
You could use a ethernet poe, so that it sends on one side and receives on the other the ethernet line and usb power… Making this a 1 cable solution. Or use a micro USB extension… Witch I’ll test once I find my connector.

1 Like

Thanks again for your work. We know that not all of the adapters work to supply power. Your link to the actual adapter is useful to the community. It’s great that you’re sharing your experience.

1 Like

Yow, gigabit ethernet and POE could be really useful!

Just a update, to verify the charge state


Cool that you’re using your Electron app as a type of dashboard. Nice. :theta::thetadev:

1 Like

It is, just now I have to make a multi address connection window, so that you can easily use a custom addresses to connect to the app when the app opens.

1 Like

Nice job with the mult-address connection window. Do you assign a static IP address to the THETA V from your Ethernet DHCP router?

How do you get the list of IP addresses that you have in the drop-down menu that shows in the picture?

It’s just a simple drop down with many addresses up to 255, I haven’t looked into if node js can fetch a IP address from a device Hostname yet, that would simplify this for the user

1 Like

In your streaming project, how does the user know what IP address is assigned to the THETA V? Do you assign the same IP address to the THETA V from your router all the time?

Currently I just look connected devices on my router,
I haven’t fully added the feature yet, using node js to find the Hostname “THETAXXXXXXXXXXX” then get the IP address would be ideal, I just have not got into trying to code yet, Above image was just a simple layout.

1 Like

Great job with what you have. It looks usable right now. There’s a real need for a desktop application to control the THETA.

I haven’t tried this, but you can probably use client-mode with digest authentication to access the THETA V when it is connected with Ethernet. Here’s an example with Python to find the IP

I personally like Electron and feel this is a good path forward. I was thinking of working on a similar project and I get excited every time I see your updates. :slight_smile: :thetadev::theta_s:

1 Like

Thanks for the help, I’ll look into this more this weekend, currently getting a Nas to setup a easyer way for me to work on projects like this, and stay on task a little more.

I should also make my own thread for posting updates…


Also, I am using a gigabit to usb3 adaptor…(based off my switch I am getting full 1gigabit speed)
The micro USB on the theta would have speeds up to 60MB/s max(USB 2.0 speeds) ,
and gigabit ethernet has a max around 100MB/s,
conpaired to a regular 10/100M ethernet witch max is10MB/s

So based on this if the usb2.0 connect is the only bottle neck i would be getting a max transfer speed of 60Mb/s if I’m correct… Further testing would be needed.

Update* only getting 27Mb/s on chrome

And on edge, starts at 128Mb/s gradually down to 33Mb/s… :thinking:


I have tried to do the OTG without success, i use Ubuntu 16.04 with DHCP server and have assigned
a static IP to the OTG device (Ugreen model, not same as the mentioned ones) based on its MAC address, but still cannot see the camera image when i retrieve it through this IP (with the same method that i retrieve it when in hotspot connection mode to my linux machine, after green wireless icon in camera is stable).

I can ping the address, but cant get it show an IPv4 in avahi-discover command for example.

Any insight on this matter would be greatly appreciated, is there any specific mode i
should enable to make the streaming work or should try again with a different OTG device perhaps ?

Thank you in advance.

Athanasios Tsoukalas

1 Like

On your Linux DHCP server, can you see the MAC address of the USB OTG Ethernet adapter to verify that the correct device is getting an IP address?

Are the LEDs on the USB OTG adapter lit?

Turn off the Wi-Fi on your THETA V with the side button

If you are just checking connectivity, the Wi-Fi LED will be off

Do any of the client mode scripts here work. You will need to edit the script and insert the IP address assigned to the THETA from your Linux DHCP server. You will also need to use Digest Authentication for the client-mode commands and change the username and password for digest authentication. If that’s too much of a hassle, there’s a test script to find the IP address of the THETA. Make sure Wi-Fi is turned off.

1 Like


I managed to get the camera feed by adjusting further my DHCP settings in the Ubuntu DHCP server.

Thank you very much for the insight and help on the issue.

Athanasios Tsoukalas


Thanks for the update.

Do you have any tips for people that want to use the THETA with Ethernet using an IP address assigned for a Linux DHCP server?

Thanks to @Kev091190 work in getting the THETA V to work with both power and Ethernet, this brings up a lot of potentially interesting use.

Currently trying to make it a little easyer to find your theta on the network…
I’m trying to setup a loop code that looks for any devices up to a current text limit and display them in a list.
Using node. Js and dns.lookup

Example of Google ip address:

Hopefully it will be a good tool for this forum, listing all of your connected theta devices on your ethernet hub.

This current method will not work, theta will not show up.
I’ll have to try to find the device by searching…
Http and request a responce