Main Virtual Tours SC2 Linux

Theta desktop app - error converting video

My THETA desktop app updated to latest 3.13.3 (since last use in sept 2019) and now it won’t convert videos. Dragging a video onto the app shows and error message telling me to perform the operation again.

The exact text is:
An error has occured.
Sorry, please perform the operation again from the start.

Either drag-n-drop or File->Open yields same result.
It seems I am no longer able to convert any video, past or present, including videos (original files) converted in the past.

Since last I used the app my system has not been changed, nor updated. Only the THETA app automatically updated.

Uninstalling and reinstalling the app won’t help.
I even tried uninstalling and installing THETA version 3.6 (the first version I used with my THETA SC) which I know it used to work in the past, now even that won’t work.

I have read some info on the net about not being able to convert but only some talk about Adobe Air (which can’t apply).

Not sure, but from the installation directory, dualfishblender.exe if run separately yields “has stopped working”. (both from 3.6 and 3.13.3). Tried calling it with the movie filename. Not sure if tried it right, but it seemed odd to me that it gives error.
metaprobe.exe for example returns a JSON response.

Has anyone encountered such a video conversion inability and solved it?

Thank you.