Main Virtual Tours SC2 Linux

Theta Refuses to live stream via USB - Error "Theta UVC Blender Status:0x800705AA"

another question if you have any guidance, the latency going through the UVC blender is pretty high, about 3-4 seconds. Do you know if there’s any way to cut that down? maybe encode at a lower resolution or frame rate?

Awesome! So glad you got it working. The main thing is to have fun and keep learning. Everyone has the same problems of not pressing a button or not checking a box, or some configuration setting. I hope that by documenting problems and solutions here and making it publicly available, it will help more people.

I think it is common for people to not press the buttons for live streaming. Thank you for sharing your thought.

Press “mode button” - keep pressing - and press “power button” → camera goes to the LiveVideoStreamig mode.

Connect a usb cable with S and laptop (MAC or PC).

The THETA S can be used as a web cam. You can use web cam software such as Skype to see live video streaming with the THETA S.

I have the same latency of 3-4 seconds on my test system with YouTube.

If you’re trying to do an immersive experience, you may need to bypass youtube for machine to machine streaming.

Here’s an example:

I will try your suggestion but I’m not sure how it will help. The delay is caused by the UVC Blender, for the most part. If you open up Graph Edit in Windows, it gives you a direct path to the DirectShow element and when I render it I can see the delay. This is OS/Application delay, not YouTube. I suspect it’s doing a few things… first, the camera has to take the raw frames and encoded into motion JPEG, which adds a little bit of latency. Then it hits the OS and gets decoded, which adds more latency… then the UVC Blender has to take it and stitch the whole thing together in realtime, which I suspects adds the bulk of the delay. I have a pretty fast machine but I figure the application itself isn’t particularly optimized. You can measure this by timing the difference between the direct ‘2 sphere’ capture and the UVC Blender… they’re about 2 seconds apart. I’ll be able to live with the latency, I just wish it was lower.

The webRTC application doesn’t use UVC blender. It uses JavaScript code in
the browser to handle the stitching. The video stream going to the browser
over the network is a dual-fisheye stream. I’m not sure if it will help.
However, just wanted to let you know what your options area. It’s only in
a test phase too, so not as established as YouTube.

You may still have the delay with the browser stitching the stream instead
of UVC Blender. I have not tested it extensively.

thanks. it’s good to know that they’re doing it in JS… that gives me hope.

The code is here:

Poke around

FANTASTIC! I suspect this will help a lot. Chrome has tons of graphics optimizations so I suspect it will perform much better than the implementation in the blender. Thank you so much!

I had problems with Mozilla Firefox. Please use a new version of Google
Chrome for your tests. It may help.

i’m having the same problem, but the live mode is on

1 Like

Do you have firmware 1.82 installed on your camera? if not, use the desktop app.

Does it work with Skype or Google Hangout using the THETA S driver, not UVC Blender? if so, it’s a problem with the USB connection, the physical wire, the USB port of your camera, or the computer.

The firmware may be the problem.

Updating firmware (1.82) is OK for me.

1 Like

Thank you for your success report. I made an error. As you correctly indicated, 1.82 is the version that supports UVC FullHD Blender.

I’ll update my post above to reflect this. Appreciate your information contribution to the community.

Hi there, I had done all the things you said were, the camera is in live mode, I had changed the cable, registed the camera with the blender, installed obs and everything is ok.
The fact is "THETA UVC Blender Status:0x800705AA message is appering insted the image, also switched between normal pc webcam to UVC HD Blender and nothing appears.
There is a red light when on live mode (power button).

Can you help me?

What version of firmware do you have on the THETA?

You need 01.82 with the newest application

Did you read through this guide about the new upgrade?

Please confirm you are using a THETA S and not THETA SC. The camera should be black.

Lights should look like this:

A bit more information that may help.

The error above occurs when the THETA camera is not communicating with OBS. You can replicate this error by completely unplugging the THETA from the USB cable and you’ll see the same error.

The problem probably is one of these areas:

  • camera firmware (current is 01.82)
  • UVC Blender driver (new one released last month. Now called UVC FullHD Blender)
  • USB cable physical connection. sometimes changing cable or USB port helps

Also try:

  • reboot your computer
  • restart OBS
  • test it with other webcam software like Google HangOuts to isolate a problem with OBS
  • test it with THETA S (dual-fisheye view) to rule out the USB physical cable problem

I’ve tried everything mentioned above. I am able to access the photos and videos taken previously (meaning that the cable is working), but am unable to get the live streaming to work. I have tried MPC Classic, and the same problem occurs. I’m thinking why is the Theta camera not communicating with my computer in Live Streaming, but is able to communicate as a data storage to transfer data to my computer.

I have the same problem with the threadstarter. But I have already tried everything as well as switch to Live streaming mode. The error still remains. I’ve tried using OBS studio, and can’t seem to see the Live streaming video.

Can anyone help?

Please confirm that you are using the newest firmware on your THETA V or THETA S.

List the versions for:

  • firmware in the camera
  • Windows version (build number)
  • UVC Blender version (the one you downloaded from the RICOH site)

The Windows build is 17134.648. The UVC Blender Register version is v2.0.0.

As for the firmware, I’ve used the Ricoh Theta app version 3.9.1 to try to do the firmware directed me to

When I used it do the firmware update, everything seems to run smoothly, but the firmware remains at 1.5. I’ve tried this many times. At first, I thought I had already updated it but when I check again to confirm, I realised that it remains at 1.5.

How do I update the firmware?


1 Like