Theta refuses to register on Theta UVC register


#13

Thank you all for your replies.
I connected the camera to a PC instead of my mac and it started working.


#14

Thank you for the update. It helps us all to learn.


#15

I’m having the same problem, registration fails (error E02).

I’m using the supplied cable, have the Theta S updated to last firmware, and last version of Adobe AIR.

I have tried on two different MAC computers (have no access to a Windows one).

This is truly annoying and degrading my user experience of the device.

Is there any fix, assistance or anything that can be given?


#16

@ CaptainsVoyage stupid question are the THETA turned of when you connect it ?
Regards
Svendus


#17

@Svendus No worries!

Yes, the Theta S is off when I connect it to the computer (red power light comes on).


#19

I don’t have a Mac, but just to confirm where you are. If you start the camera in live streaming mode and use the normal webcam driver (not UVC Blender), can you view the video stream in dual-fisheye mode like this?

@jcasman does the Mac have the same driver registration process as Windows?


#20

[quote=“codetricity, post:19, topic:543”][/quote]

Thank you for your quick reply. Yes, when I turn on LIVE function of the Theta, and select the camera in for example Skype 7 for MAC, I get the same dual fisheye mode images like you do.


#21

Hi @CaptainsVoyage - I was not able to fix the problem with 3 different macs but as soon as I connected the camera to a windows pc it worked.
I would suggest you to try to get someone who can borrow you a windows computer.


#22

Thanks, it appears as I might have to do that. Sadly, none of my friends uses Windows any longer.

Silly question perhaps, but if I register it via a Windows computer, will it still work for Live view in a MAC computer afterwards? Is this UVC register program, just a program to register the Theta S, or does it install something on the Theta S also?


#23

I just used Windows to “activate” it, afterwards I’ve been able to use it on different MAC computers


#24

What version of Mac OS X are you using? I want to try and get someone to test it with the same version. @jcasman did you upgrade your mac to the latest OS update? Does live streaming still work?

He’s having problems with the device registration…


#25

Wow, this is new and important information. I didn’t realize this. thanks.


#26

@CaptainsVoyage
try to unzip attached folder and run the Theta UVC register app
from the RICOH folderRICOH.zip (232.9 KB)
it is v1.04 for Mac
if it runs it is do to installation trouble
Regards
Svendus

or waite for to morrow
What do you think @codetricity :slight_smile:


#27

Windows Blender - VLC are chrashing here
VLC media player
2.2.4 Weatherwax
have send them a report
got the ansver
There was an error while transferring the data to the FTP server.
Thanks a lot for the help.

16-9 RICOH THETA S are running


#28

VLC on OSX are running but it eats up the ram+swap (16 G)

VLC media player 2.2.4 Weatherwax


#29

Hi @Svendus I’ve followed the installations instructions to the “T”, but I can’t seem to get the “Register” button to enable. Help?!

I’m using a macbook pro and have the the below:

Installed the latest RICOH THETA app
Installed the latest RICOH THETA UVC app
Restarted my computer
Launch the UVC app
Plugged the (Switched off) RICOH THETA camera
(nothing happens)
repeated the above several times… no luck
*Checked to ensure the latest firmware
*I’m running as an Admin on my MB pro


#30

Do you have a THETA S or a THETA V?

Does the MacBook Pro have a standard USB port or are you using an adapter to convert the USB cable that came with the THETA to connect to your Mac? If so, try a different adapter.


#31

@Bronson_Chan Hi be sure you have the latest Adobe Air installed
Regards Svendus

we are running Mac os High Sieera


#32

good point. that is probably the problem. thanks for the tip. :slight_smile:


#33

if You for some reason have Adobe blocked in the firewall on a mac or PC it will not install automatically
when installing the RICOH THETA app :wink: