THETA USB Live Streaming Now in Full 1080 HD - Free Upgrade


here VLC media player
2.2.4 Weatherwax are Crashing what so ever

vlc-3.0.0-git are running upside down :grinning:
to set 16:9 or16:9 in advanced options do not function here

standard are 4:3 but it it is possible to change format in the right click menu


Does this have any navigation? Or, is it streaming an equirectangular video? The THETA R announcement indicates that the new camera will stream equirectangular format directly from the camera. There’s going to be source code for the controller that ships with the THETA R, but I wanted to find some software that I can use locally to view and navigate a 360 video stream.


I can replicate this problem. Should I submit a bug report to the VLC development team?

Thanks for testing this.


Well I think we should observe this and the color profile is also a bit strange :stuck_out_tongue_winking_eye:
the image are also mirror left and right

sorry should have been
to set 16:9 or 16:10 in advanced options do not function here!


I have the same problem with the color. I am thinking about submitting a bug report to help the development team.

this is the link on how to submit a bug.

If I submit a search term with 360, it doesn’t appear that this has been filed yet.

It might be a way to help them.

Here’s what I’m thinking:

Subject: 360 video stream problems
When using the RICOH THETA S with a 360 video stream people in the community are encountering these problems:

  • color profile is off
  • image is upside down
  • no way to navigate the 360 video stream

Let me know if you have any thoughts.


Advanced Options do not funktion with 360 input !

that is not clear to me please tell ?


I want to be able to click on the screen and rotate the video stream, similar to how people can do this on YouTube or with a video file. Can you move around the video on your computer in VLC 3.0.0 nightly build?



All Right :disappointed: no only by mowing the camera


Thank you for your help with testing. Appreciate it. I believe that these issues will be resolved in 2017. At a bare minimum, we’ll see open source code from RICOH for taking the equirectangular stream and moving the video around. According to their announcement.


it is running correctly with normal color profile on the VLC 2.2.4 Weatherwax (Intel64bit) on macOS Sirra version 10.12.2


Gentlemen, I have tried in every way to transmit using the HDMI output.
I have not been able to succeed because the image is circular when I do not use AVC Blender.
-I am using the USB input to charge 1.5A with a wall charger.
-I am using UltraStudio Mini Recorder to capture HDMI image.
-Mac OSX 10.10.5 (YOSEMITE).
I tested the Wirecast and the OBS, but in both software the image arrives bi-circular.
Do you know of any encoder program to transmit that converts the image to panoramic? Thank you


You need a cloud encoder or a software to perform stitching.



RICOH R Dev Kit will output equirectangular from the HDMI. It was used with LiveShell with HDMI at CES.

Also, @paulgailey is working with a company that has some stitching technology using Unity.

Suggest you try the free trial of mimoLive and see if it meets your requirements.

also, what prevents you from using UVC FullHD Blender with the UltraStudio Mini Recorder? Did you try it and the Mac couldn’t convert the stream? I thought that the UltraStudio appeared as a USB input into the Mac? Maybe not… mimoLive will probably work.


This post by community member dakami on the official forum touches on some possible issues with live streaming. Most importantly, dakami seems to feel that the THETA UVC 1.50 ( the USB Video) support is pretty basic. I suspect this is one reason we may be having some issues with certain applications.

Re: Controling H.264 encoder via UVC 1.5
Postby dakami » 26 Jan 2017, 14:44

Right now, the UVC 1.50 support is pretty raw. Forget controlling capture parameters, it only barely gets any sort of stream out at all.

There’s some twisty path wherein they sort of have in working in Windows, it seems, but it’s not like it just shows up as another codec and resolution pair. I’m diving into the driver trying to fix it (I managed to get the PS3 camera working much nicer). I randomly found out recently that Wireshark has super nice USB sniffing now on Windows, so if I can get it up there (and thus far, I haven’t really) I can force whatever parameters are needed.

Ah, it’s never easy. At least 720p15 works without too much drama.


Windows 7 Max Resolution 1280x720

This has been brought up before, but thought I would emphasize that the max resolution and framerate on Windows 7 is 1280 x 720 and 15fps.

See the official specifications.



On my computer does not appear the option UVC FullHD Blender.

1-OBS Version 0.16.2 (mac)> 1280x720
2-Wirecast Version 7.0.1 (mac)> 1280x640 - 15QPS

See the photos above.

My installed settings:

-Ricoh Firmware: 01.82
· UVC 1.5 is now supported, so live streaming can be output in full HD 30 fps.

Ricoh for Mac Application Version: 2.3.3

-Theta UVC Register (THETA UVC Blender v.1.0.2)

-Adobe AIR:

OSX El Capitan version 10.11.6


go for THETA UVC 1.50

if this do not work go for the latest system upgrade on your Mac

Regards Svendus


Did you download and update the live-streaming app after Nov 16th? Please try and download it again, reinstall and then reboot your Mac.


Now yes! Perfect! Thank you master!


This was contributed by community member Petr Ewsr. I have not tested it.

I found with this error the following fixed it:
Have the Ricoh camera plugged in and in Live Mode
Open device manager. (Right Click on My Computer and click on Manager)
You should see, under Universal Serial Bus controllers, a USB Composite Device whose icon has a yellow triangle with an exclamation mark in it.
Right click this and click Disable.
Right click it again and click Uninstall, check the box that says Delete the driver software for this device.
Click OK.
Scroll to the very top of device manager and right click on your computer name.
Click Scan for Hardware Changes.

You computer should then detect the Ricoh camera as an imaging device. You can check by expanding the imaging section in device manager.

Hope this helps