THETA X - Turn Off Client Mode Authentication

I have a ricoh theta x running in client mode.

Whenever I send a request to get the current state, take a picture etc… I need to provide the default credentials or else I get a 401. As soon as I add the creds in, the requests work fine.

Is there a way to turn this off and make a request without the credentials?

I’m assuming you want to stay in client mode.

Have you tried this option?

_authentication

I have not tested it. If it resolves the problem, please mark the solution as solved. Otherwise, please post again with the error message and I will try and replicate it.

I have executed the following command.

POST

{
    "name": "camera.setOptions",
    "parameters": {
        "options": {
            "_authentication": "none"
        }
    }
}

And I get the following 403 response.

{
    "error": {
        "code": "disabledCommand",
        "message": "Command executed is currently disabled."
    },
    "name": "camera.setOptions",
    "state": "error"
}

Just to confirm that you are running the command above in Access Point mode, right? After you set it to _authentication: “none”, then you go to client mode, right?

X Test with firmware 1.10.1

I’m using X firmware 1.101…

"firmwareVersion":"1.10.1","manufacturer":"Ricoh Company, Ltd.","model":"RICOH THETA X",

Set _cameraControlSource to “app” prior to setting _authentication.

Set _authentication to none

Verify _authentication

Z1 Test for Comparison

Result: Z1 works as expected

"firmwareVersion":"2.01.0""manufacturer":"RICOH","model":"RICOH THETA Z1"


Testing THETA X with no authentication.

Result: I can’t get the X to work with no authentication at the moment.

Testing THETA Z1 with no authentication

Result: THETA Z1 takes picture in client mode with no authentication.

curl -H "Content-Type: application/json" -X POST "http://192.168.2.200/osc/commands/execute" -d $'{"name": "camera.takePicture"}'

update May 12, 2022

This may be a limitation of the THETA X right now.
We hope that this will be improved in the future.

1 Like

@Evan_Lalo RICOH has confirmed that it’s a limitation of the current firmware of the X. You need to do the digest authentication on each command.

retest with firmware 1.20.0

image

set authentication

get authentication

appears to be set to “none”

client mode with “none” authentication works

image

@Evan_Lalo , can you confirm that the client mode works with no authentication with firmware 1.20.0?