360 Video Conferencing with the RICOH THETA S



This is my entire config.js file with the keys cut off for security reasons:

const CONFIG = {
  clientId: 'KDPZL3tJdVSK5xm',
  clientSecret: 'frlv24a8nUH1hA',

const USER = {
  userId: '',
  userPass: '',

Can you post the contents of your config.js with line numbers. just cut off the keys to protect your security.

const CONFIG = {
  clientId: '3y-stuff-Xh',
  clientSecret: 'tx-stuff-es',

const USER = {
  userId: '',
  userPass: '',


When I use chrome browser inspect panel to look at resources and select config.js, the contents matches ./index.html. Chrome does not show the contents of my config.js file with the Ricoh IDs.



No, it’s in the directory samples

aming-sample-app/samples$ ls
common              gulpfile.js   npm-debug.log     package.json
config.js           LICENSE       oneway-broadcast  twoway
config_template.js  node_modules  oneway-watch      webpack.config.js


My samples directory looks the same as yours.


If you want to direct message me your config.js file, I can try it on my system and see if it works. At least that will eliminate one possible problem. Click on my username for the direct message option

– Craig


Can confirm with the credentials we shared with you @someotherbob that I have the WebRTC live streaming up and working. It’s not an issue with the credentials.


You’re running it on both Ubuntu 15.10 and Mac OSX, right? with Node 6.3? Firefox browser, right?


Sorry for not providing those details. Yes, correct. Ubuntu 15.10 and MacOS
X and node v6.3.0. Works with both Chrome and Netscape.


You mean Firefox, right? Any other tips?


I’m on Win7, Chrome browser.


If you’re open to using OpenTok as a streaming provider, you can check out how we did client-side stitching in one of my posts: http://lists.theta360.guide/t/making-theta-360-work-with-opentoks-client-side-webrtc-livestreaming-mobile-stitching-google-cardboard-view/986


Wonderful. Thank you for this contribution. :slight_smile: :theta: