Getting apk from the official store

I put together the video below to help other people use the tip from @Utopiah

In my test, I had to use Vysor to set the permissions of the plugin before I could use it. Also, we might need to use the official mobile app or WebAPI or USB API to set the plug-in that will boot.

RICOH THETA Plugin Install from Linux: Dev Workflow Tip


Since all plugins are moved to github, is there a way to download apk. Currently there is no way to install plugin on Theta X.

I can’t figure out how to download it. Perhaps someone else can figure it out?

Do you plan to install the plugins for adb?

ADB is the only way to install the apk for Theta X, right?

I’m not sure if the plugins will install on the X. I was just wondering what your plans were.

Have you installed these plugins?

Thanks for searching, the issue is you can not click install button on the page, either on desktop(tested on Mac and Ubuntu) or mobile browser. There is no way to install plugins.

Found possible apk, and trying Release v1.2.3 · ricohapi/theta-wireless-live-streaming-plugin · GitHub

Tried “adb devices” on both ubuntu 22 and Mac, none device found on both.
Theta X is on live mode connect by usb.
For ubuntu libuvc-theta and libuvc-theta-example tried. ./gst_viewer said “Theta Not Found”.
lsusb printed THeta X correctly.

Any clue?

Oh, I see the problem now. The link to the desktop app is not on the new software download page. There used to be a link to a desktop app to install the plugins.

@jcasman can you find the desktop app on the RICOH site? I think people need the app to install plugins.

to stream to linux, this document may help.

For the device not found error, do you have two cameras on your computer? If there is only a single webcam, they change line 190 to /dev/video0

Thanks for your information, found the basic app for Theta X, it is here:

But can not connect to my apple silicon macbook. Will try a different laptop.

I eventually managed to install plugin on my Theta x. And figured out, device should be on CL mode, note live mode.
Now can wirelessly stream to my local rtmp server by ffmpeg, although it is slower than youtube…
RTSP plugin is not working on X, need to try a different way to get live stream on low latency.

Thanks for sharing the link. I see it now.

How did you find the download link?

When I click on the icon below,

It goes to this link

Which does not list the desktop app.

The link you provided does list the desktop app. I’m wondering how people find that link.

In the office we use the desktop app with Apple silicon. I used it with an M1 MacBook Air.

The RTSP plug-in source code is here:

You may be able to recompile it for the X using Android Studio.

If you connect the X to a small computer (like a Jetson Nano) with a USB cable, you can use ffmeg on the small computer to get the stream to your local RTMP server.

For example:

 ffmpeg -f lavfi -i anullsrc -f v4l2 -s 1920x960 -r 10 -i /dev/video2 \
-vcodec libx264 -pix_fmt yuv420p \
 -b:v 2500k \
-codec:a libmp3lame -ar 44100 -b:a 11025 -bufsize 512k \
-f flv rtmp://$SECRET_KEY

A few years ago, we used this to improve performance.

Paul Gullet saw a doubling of the framerate.

On your screenshot, there is a firmware link, click to firmware version list page Download - Firmware | RICOH THETA X
On this page there is a link to the basic app page


Thank you. That link is a little difficult to find. I hope other people find it.

I’ll raise this with some people that I know at RICOH. Thanks for your help tracking the link down.

Another issue is when I connect Theta X to my computer, I can not find device by adb devices. But I can see stream on my Mac with vlc. On ubuntu, lsusb can see the Theta X, but ./gst_viewer return error “Theta Not Found”. Do I need to set it to develop mode?

The THETA X does not need to be in developer mode. Are you running Ubuntu on x86 or something like an NVIDIA Jetson?

Do you have the THETA X mounted as a filesystem? Make sure it is not mounted.

@craig ,to be able to use adb on theta x I thought it’s required to put it into developer mode first…otherwise can’t install plugin via adb. Are you saying it works now without developer mode on theta x?

It needs to be in developer mode. The original poster indicated he applied for the dev program

thanks for decoding my question, it was full with typo’s, I could barely read it.