Main Virtual Tours SC2 Linux

Is it possible to connect to the network while connected to a pc?

Hello, I have a plugin that sends via web socket the live preview of the cámera.
This cámera, ideally, has to be connected to a robot (mostly due to battery length). Is there any way for the camera to have network access while connected to the robot? Or do I have to unplug it?

Please provide more information on your setup to help us understand the problem.

If you want to connect an external device (like the robot) to your plug-in, you can run a web server inside the plug-in, such as nanohttpd or build your own server with Java.

If your question is how to connect the camera to a Wi-Fi network while it is in plug-in mode, then you just set the camera to connect to wi-fi router as a client. In this case, both the robot and the camera are connected to the same router.

If you are trying to connect your camera to the robot with Ethernet, then you need a y-splitter on the USB OTG adapter to power the camera when it is connected to the robot with Ethernet.

What I meant was that I need the camera to be connected to the robot via USB (the robot has a pc inside). The camera has a plugin running that requires internet connection. However, when I connect the camera to the PC/robot the wifi turns off. Is there any way for the camera to remain connected?

Thank you

1 Like

Are you running USB API commands over the USB cable? Or, is the USB cable only for 5V power to the camera?

If you don’t need the USB API commands, you can use this small device.


BTW, the technique below may also work, but the document is quite old and out of date.

https://theta360developers.github.io/plugin-guide/workflow/#enable-wi-fi-when-using-adb

On my camera, the Wi-Fi does not shut off when I plug the camera into my computer.

1 Like

On my camera, the Wi-Fi does not shut off when I plug the camera into my computer.

Hmm that’s weird, when I connect mine to the pc it disconnects from the network. Do you have any idea on what the reason might be?

1 Like

did you follow the document and try this:

adb shell settings put global usb_debug true
2 Likes