Wireless Live Streaming Plug-in Source Code Updated for THETA X

I just noticed on the RICOH GitHub repo that v1.2.1 of the Wireless Live Streaming Plug-in supports the THETA X. Please try it and report back. I still need to try it myself.


In AndroidManifest.xml

NOTE: I have not tried this yet. If someone has time, please try it and report back.


Great news! Thanks for sharing! I will download ASAP and look into.

Do you know how to use Vysor with the X to set the settings of the permissions for the X plug-ins?

How are you setting the permissions of the plug-in with the X?

When I use Vysor, I see this:

Hi, Craig! I don’t, I didn’t find yet a tweak to use vysor with X. For plug-in it wasn’t required for me to set permissions… I was able to get cam work. But at the end it may be the issue that I had no permission to use that new java camera class? Not sure yet… Exactly what you see, with vysor I was able to see only app preview directly and couldn’t get to OS settings, etc.

1 Like

I can install the plug-in, but am unable to use it.

I am stuck at this screen.

Ive an idea. Install first the same plugin from store after you verify its up and working you can try to run from android studio the soirce code. This way you may overcome the challenge to allow permissions if thats the issue there…

Can you reach it through ip in desktop browser? The webui?

@craig, @jcasman ,
I found a way to use Vysor with the new camera, I think Craig you were facing the issue with Ricohs Wireless Live Streaming plugin to grant permission using Vysor:

After I grant all permissions plugin worked fine for me, only for ~4minutes because of heat issue and it shut down, but we know this can change with firmware upgrades/improvements in time:

Using adb command in terminal: adb shell am start -a android.settings.SETTINGS

I hope it will help you too!

1 Like

Thanks for the tip!

How did you set the settings for the YouTube server and key?

I have it connected to my mobile phone. I am still unable to use the office network for live streaming from the camera.


@craig ,
you have to follow the same process for this plugin, you should connect your camera to WiFi router and get it’s ip adress. When you run this plugin there will be that tiny web server up and running, so you should be able to reach the settings page like: , of course you need to replace the IP address. You can join the same WiFi router by a desktop pc or mobile phone browser and open that address. Make sure that you hit “FIX SETTINGS” button on the page after you enter required RTMP data, etc. After that you should be able to start streaming.

Why can’t you use office network for live streaming? Did you get to try my plugin too and it failed?


1 Like

plug-in is stopping with 3 short beeps.

The office network has an additional login screen. :frowning: I’m doing these tests with my mobile phone.

@craig , after you fill out server URL and key, did you click “fix settings” before starting to stream? On the first shot I see that server URL and stream name/key is empty. Even if you copy over the values, you need to “fix streaming settings” first. In theory if you start the plugin with Android Studio, should see the logcat and search for error message there.

thanks. I clicked on fix settings.

I’m going to try the same stream key from OBS to test it.

I’m still planning to test your plug-in.

I needed to test the RICOH plug-in first since I have other questions about the RICOH open source code for their plug-in.

hi, @craig , Thanks in advance! I will upload a new version for you before you proceed as Toyo had some issues with streaming, I may missed some configuration setting in code or on flow.tours and will come back to you once it’s there with another link for you to download.

1 Like

thanks for letting me know about this. I’m still battling with the security of our office network, but I’m going to go forward with my mobile phone.

The good news is that from OBS using my Windows laptop, I can connect to YouTube and stream with an “excellent” connection using a USB cable. At least the stream key and the rtmp information are correct.

1 Like