Theta X PTP session will not connect

Hello there

I have been successfully using a Z1 connected via GPhoto 2 over usbApi to a raspberry pi4.

I have a Theta X which I am trying to connect to a Pi 4 with PTP cam as recommended.
However, it keeps saying it could not connect to session, I’ve attempted to add the dev number with a command and it tries to perform a command and then continues to say it could not connect to session. do you have any suggestions or fixes for this?

thank you in advance

Make sure it is not mounted as a media device on the RPi4.

In the video, theta is ptpcam

Can you post more information about your setup? Screenshots might help. Version of OS on the Pi.

I’m using the THETA X a fair bit with the USB API and cannot replicate any problems.

Dear Craig, firstly thank you for all you do on here. I updated the firmware and that seemed to fix it.

I now have a new problem.

The camera draws energy more quickly than the Pi4 charges, so it gradually goes flat( a problem I did not have on the Z1)

I see that you do not have this issue.

What settings on the Theta X do you use?

Many thanks in advance


1 Like

Turn off the Wi-Fi and the LCD panel of the X.

I need to go through the USB API more fully to find the appropriate setting.

With the WiFi API, the setting to turn off the LCD is this:

If the USB API does not appear to have the settings, I can report back to RICOH and ideally get help finding the setting in the USB API docs.

It looks like the WiFi can be disabled with this:

You may need to use a powered hub.


I suspect that the RPi can provide enough power if you are not streaming the camera. The Wi-Fi and the LCD will drain the battery quickly.

As the X is new, the reality is that we do not have actual test results of the X running with USB from an Raspberry Pi for days. I need to test this myself.

Hi Craig

Thank you very much for this.

I will have a look today at the API too

When you have had a look at the USB pointers you can give would be most helpful and thank you for offering to put a request into the USB API team if needed.

I am currently using a powered USB power strip (Belkin)

Best Wishes


Dear Craig

I clicked on the link you provided and I get a ‘404’

I have manually turned off the WiFi on the X and it has slowed down the battery decline but not sufficiently, so the LCD does need to be switched off.

What I have established from going through the docs Theta web API 2.1 is that the command I will need to turn the LCD off may/will be slightly different for gPhoto 2 which I am running the project through (see an attached screenshot which illustrates that the command for capture is different)

Dear Craig, a little update. I have found the code that you listed way back in May to shut down the LCD on the X.
As you can see from the screenshots when entering this code through gPhoto2 the command is not recognised.

Any thoughts/

Best wishes


With the battery at 92%, the camera is pulling 0.7Amps. I’m assuming the RPi can output 0.5Amps.

This is with the camera plugged into a wall outlet.

I’m going to try a RPi 4 later in the day. I need to free up a monitor and keyboard for the RPi test.

Hi Craig

Thank you for looking into this, I really do appreciate it.

Let me know how it goes



Are you running THETA X firmware 1.20.0 released July 20, 2022? The camera is increasing in charge in my test with the Raspberry Pi 4.

screen is on.


What commands are you running on the camera and how often? For example, if it is still image, how often are you taking the still image and is it 5.5K or 11K?


Hi Craig

Thank you for going to the trouble of running these detailed tests

All seems to be identical in set up, latest firmware, Pi4 and it is running on a belkin power strip but somehow I am getting a power drop so I wonder what I am doing wrong? I need to run though everything carefully.

Would gPhoto2 have an impact?

What USB setting do you have set on the X ?

Best wishes


100% charge after three hours of being connected to RPi 4.

I have a MacBook Air USB C power supply powering the USB C port of the Raspberry Pi 4.

bluetooth, gps, wifi all off.

screen brightness Auto. Maybe set it to low?


Please advise on the commands you are running for your test. If you’re taking video, it will consume more power. If you’re taking still images, the frequency of the image taking will affect the power consumption.

Hi Craig

Once again thank you very much for taking the time and trouble to run the tests with your set up, it helped me with my issue.

I was aware that the Pi4 can have power issues so after reading that you were successful I systematically went through my set up which has a coupes of fans in there and one by one disconnected each component to see if it affected the power drop off and anything I did made no difference at all, still not enough power reaching the X.

Then I had a thought.

What about the USB-C cable I was using?

I switched it out for a shorter cable (the stubby that ships with camera) and hey presto problem fixed! It added charge.

When considering issues it is worthwhile considering something as ‘simple’ but fundamentally important as the USB cable can be the ‘culprit’

I hope this helps others in the community too.

Warm Regards



Congratulations on your success! Thank you for posting your report.

I like Raspberry Pi computers, but I’ve had a range of challenges using the USB ports to power peripherals on robots.

I used a short 8" cable in my test. However, I didn’t think the USB cable length would be the source of the problem in this case. I’ve found that cheap inline current meters (under $15) are very useful in isolating the source of the problem with camera charging.

BTW, the THETA X can operate without a battery if the power source supplies sufficient voltage and current. Depending on your application, it might help the camera to run cooler or allow the camera to auto-power-on when current is applied to the USB C port.

Hi Craig

I thought I was losing my mind to be honest and it was one literally my last port of call.

The ‘bad’ USB cable was over a meter long and I need to pick up an inline current meter (a great tip btw, thanks again) to detect any other ‘bad cables’

I completely agree with you regarding Pi voltage it is such a shame-would a Jetson of some kind overcome this?

Really great the battery can be removed, Ricoh have listened and it is paying off for them.

I will run ‘battery less’ tests when I get time.

Once again thank your for all you help with this

Warm Regards


I have it running without the battery at 4:53 RICOH THETA X Ethernet - Best Ever - YouTube

For supplying power to the camera, the Jetson and the RPi are similar in my tests. Both appear to be limited to 500mA and I think that the power output may vary slightly depending on what else is plugged into the USB peripheral ports.

I’ve mainly noticed the problems when the single board computer and camera were both powered from a robot. However, that’s also likely the main scenario where I have the peripherals powered directly from the SBC. I don’t have a very good power supply on my robot. My experience might be completely different if I spent more money on a decent battery power supply system.

BTW, can you mark the topic as solved?