Theta X Web API request timeouts


We have 2 Theta X cameras which can be successfully communicated with over the web api, however, the response is very intermittent and we either get a response almost instantly or it times out. Has anyone else seen this?

We have tried using Postman, ThunderClient in VSCode, the cli test app (great tool!) and our own software which we have been using with every model since the m-15, to communicate with the camera. OS is Win 11.

We see the same behaviour on both cameras, for /state, /get/set options and takePicture commands.

The camera is located 10cm from the pc for testing and we have tried both 2.4 and 5ghz bands.

It does work after a random number of tries, but obviously that is a horrible user experience.

Any advice or suggestions greatly appreciated!

Many thanks


I have seen this behavior on a Dell XPS 13. I believe it is related to a wifi chipset compatibility issue between the AX-1650w chipset in the dell and the THETA X chipset.

When the computer and the X are connection, do an ipconfig on Windows or a route or ifconfig to see if the computer loses the IP route assigned from the X.

I have attempted to lock the Wi-Fi on the computer to 2.4GHz and it does not even detect the THETA X.

As I don’t normally use the Dell XPS 13, I don’t test it regularly.

Please post the following:

  • computer model and OS you are using to connect to THETA X and ideally the Wi-Fi chipset in the computer
  • THETA X firmware you are using

This is the normal connection on Windows 11 ASUS Zephyrus (no problems). I have the WiFi adapter locked to IP v4, not sure if it makes a difference.

from Dell XPS

initial connection


after 5 seconds (approx)

This happens consistently with both 2.4GHz and 5GHz.

Wifi on the computer.


It may be possible to tweak the configuration from switching between 2.4Ghz and 5GHz.


However, I don’t normally use the Dell XPS.

next steps

Please post your development hardware info
If possible, try with a different computer so that we can rule out some potential problems.

Hi Craig,

Thanks for your prompt and detailed response.

Our test pc is a Windows 11 intel NUC with an Intel AX201 but we have also tested with a generic usb adapter (b/g/n only):

We see the same behaviour on both adapters and have also seen it on 2 customer sites, both using nuc’s of varying age, win10 & 11 and using the usb adapters.

I’ll try a couple of things with the adapters, like you have and report back.

Thanks again


Sorry, forgot to mention that we have seen this on f/w versions 1.00, 1.20, 1.40 and 1.41.

Update 1
I’ve just tried the ipconfig refreshes and can see it losing and regaining its dhcp details constantly, I’ll see if I can set anything to stabilise that.

Update 2
Setting a static IP for that connection resolves the issue, but that isn’t a solution we can realistically use.

I have seen the same behavior with the firmware versions you mention. I have only been able to replicate it on one Dell XPS computer and that computer is @jcasman 's computer, not the one I normally use.

We’ve tried 2 external USB connectors on the Dell XPS and they have shown the same behavior. I’m suspecting that the computer is toggling between 5GHz and 2.4GHz and dropping connection when it goes to 2.4GHz. When I lock the X at 2.4GHz, it does not appear on the list of hotspots.

Did you set the static IP in the Windows configuration? Something like

Thank you for posting your information, before I saw your post, I thought the problem I was experiencing was isolated to the Dell XPS that @jcasman was using.

I’m going to look into this more closely in the next few days. The Dell XPS is in the office and I’m working from home today.

I’m hoping there is a workaround with the Windows 11/10 WiFi adapter configuration, but it may take time to experiment with the different settings.

Hi Craig,

Yes, we set the static ip to as this was what we were getting from the camera via dhcp.

Not sure about the 2.4/5ghz toggling as our usb adapter isn’t capable of 5ghz and it wasn’t detected when we set the camera to 5ghz. When it was set to 5 on the AX adapter we had the same issue.

Really appreciate you looking into this and I too am glad someone else can see the issue.

Many thanks


I’ve been testing the dell xps 13 with a static IP address and it is stable. I have not been able to solve the problem where the Windows 11 computer received the IP address configuration from the THETA X. When connected to the THETA X with DHCP assigned configuration, the Windows 11 laptop will consistently lose the network configuration after less then a minute.

I can repeat this with ipconfig /renew and then check with ipconfig. It will work fine with the network configuration for a few tens of seconds, then stop working.

As an interim solution, can you put two Wi-Fi interfaces on the Intel NUC and use a static IP to the THETA on one WiFi interface and use DHCP on the other wifi to get your Internet access?

In my tests, same computer will connect to the Z1 with no problem.

I’m going to keep looking into this, but I have not been able to identify a workaround.

Thanks for spending the time testing this Craig.

Our standard PC config has a wired connection and a wifi one, so we will employ the static ip workaround now for affected sites. However, this does then prohibit them from connecting the wifi to anything else, so I’m hoping for a more permanent solution in a future firmware release. Not all of our locations have the facility for a wired lan, so this wouldn’t be possible for them.

Did you test other camera models with the same Windows 10/11 NUC configuration? For example, did you test the SC2?

In my tests, the Z1 works with the network configuration (Z1 is access point and assigns the Windows computer IP with DHCP). However, the X fails to assign the dynamic IP address to the same Windows PC effectively.

Yes, our default camera is the SC2 and that has worked perfectly on the PCs where we have seen the X issues.

Do you think that there is a difference in how the THETA X DHCP server is operating? What’s your best guess as to the source of the problem?

Here’s what we know so far.

computer model THETA X SC2 Z1
Intel NUC with AX201 WiFi loses network IP and route. not usable works as expected not tested
Dell XPS 13 with AX1650w loses network IP and route. not usable with DHCP. works with static IP and is stable works works
ASUS Zephyrus with AX200 WiFi works works works

There may be additional information we can get from the logs.

This article has information on using both the Event logs as well as Wireshark. Comparing the logs on the working SC2 DHCP server connection and the failing X DHCP server connection may yield more information.

It certainly seems to point that way, we have also tested it using a tp-link TL-WN822N usb wifi adapter and have seen the same behaviour (works with SC2, not with X)

In our tests, the ipconfig drops out very rapidly (<10s) so we can’t even chain requests together (status, takepicture, progress) as we rarely get it to keep alive long enough to complete a full connect-capture-download sequence.

We have been using the Theta in our application since the m-15 and have used every model since (including Z1). The X is the first model we have had connectivity problems with and because of that our software has changed very little (other than api 2.1 and ‘session’ requirement changes).

I’ll see if the event logs show anything interesting, thanks for the link.

@Mark_Longson , can you test this again with FW2.20.1 (July 25, 2023)?