We can't connect RICOH THETA V and Raspberry Pi 2

We have been unable to use ptpcam --capture after we installed it according to the video. Here is the video’s link: RICOH THETA USB API on Raspberry Pi - Setup and Use
And this is our problem:

Have you ever encountered this problem and solved it?
Thank you!

Are you using the code from here:

Yes. But we can not use ptpcam --capture. It always shows us PTP: Device Busy.
And we can not find /dev/video0 in our Rpi.

Theta camera does not appear as a /dev/video device except if you use a special driver.
Check if the camera appears with lsusb and wi-fi switch to off for the theta.

I think I had to remove ‘GVfs’ (GNOME virtual file system) in order to use ptpcam or gphoto2

sudo chmod -x /usr/lib/gvfs/gvfs-gphoto2-volume-monitor
sudo chmod -x /usr/lib/gvfs/gvfsd-gphoto2
restart Pi

This should work


We follow your advice and reboot Rpi.
It is still not working.
We try every mode of Theta V, it shows us like this:
Camera mode: Events receiving error. Capture status unknow.
Video mode: PTP: access denied. Error: Could not capture.
Live mode: PTP: Device busy. Error: Could not capture.
:sob: :sob: :sob: :sob: :sob: :sob: :sob: :sob: :sob: :sob: :sob:

We change our Rpi. Now it is Raspberry Pi 4(raspbian os 64-bits) and ricoh theta V. It is still not working.
Is it caused by the USB cable or the OS in Rpi?

I don’t have any problem with Rpi3B+ or Rpi4B+, with theta V or Z1. I’m using gphoto2 instead of ptpcam.

I don’t use graphical interface with Rpi but only command line.

Is your theta mounted ? Try to unmount the drive.


Is the THETA V mounted as a local storage device? You need to unmount it.


You may need to remove gvfs-backends

sudo apt remove gvfs-backends

Try killing the gvfs processes that are mounting your camera as a filesystem

We use sudo apt remove gvfs-backends and it still not work for us. :sob:
And we noticed that you use theta instead of ptpcam.
We want to use the command like yours(theta --info, theta --capture).
What should we download?


The theta is my example is the same as ptpcam. I renamed it after I modified ptpcam so that I could test the original ptpcam and the modified version for comparison.

You’re welcome to try my exact code base here

It is just a fork of the repo from nickel110

Thanks for your help!!!
We finally finished it.
We referenced the following URL and debugged it.
(URL:Raspberry Pi4 + RICOH THETA V でライブストリーミング) Note: The steps in the URL may not be complete, but only some installation packages are missing.
And, your advices are really helpful for us. Thank you a lot.

Sorry for our poor English.

1 Like

Congratulations on your success! Thank you for posting again.

In the original post, you had a problem with ptpcam. In the most recent post, you link to an article on libuvc-theta.

Did you isolate the problem with ptpcam? Did you have to install libusb-dev and rebuild libptp2 from source?

Did you have to install libusb-compat-0.1?

I’m trying to figure out if we need to provide additional documentation for people with a rasbperry pi.