How To: Edit and Stitch RAW DNG Images From RICOH THETA Z1 with Adobe Lightroom Classic CC and THETA Stitcher

Is anyone else seeing issues with files that you have renamed before editing in Lightroom not working when exported to the Theta Stitcher app? From what I am seeing, the stitcher will only work with files using the file naming structure the camera uses (e.g. R0010003.DNG).

I shot some images yesterday and renamed the files to something like this: 2019-06-01-Plane-000001.dng. After editing the image in Lightroom and trying to edit it in the Stitcher, I get an error saying that a DNG must be in the same directory. Simply renaming the file to “R0010003.DNG” an exporting it again works fine.

I tried some other file names (e.g. “plane.DNG”), but the ONLY file format that seems to work is a capital R followed by a series of numbers.

Note: I am doing this on a Mac.

Yes, this is a restriction also documented in the help file for the stitcher. The reason for this is obscure to me.

BTW: I also don’t understand why the suggested workflow (as described above and in the help file) is using the export function of Lightroom. For me, it’s more natural to call the stitcher via ‘Edit In’ as illustrated in this screen shot:

My configuration for this is:

Using the export function would make sense for batch processing a set of images. But unfortunately, the stitcher currently only accepts a single image.

A UI-less batch mode stitching with default parameters or even specifying parameters on the command line should be on the list of possible improvements!

1 Like

Hi, i try to use this plug’in but when i validate my settings in the plug’in and i clic on OK, i have this error

“Les images n’ont pas pu être traitées 0x00010505”

Translation of that
“Images could not be processed : 0x00010505”

Tkx for your help

Please post a screenshot of your Lightroom Classic CC settings with filename filled in

Hi, there is my setting

and my workflow

Thanks for posting this detailed information. I think the settings look okay.

Please post:

  • version of MacOS
  • Version of Lightroom Classic CC
  • amount of RAM in computer (needs to be 16GB or higher)

Hi, thanks for your Help.

Lighroom 8.1
Windows 10 64bit 2019
Intel HD graphics 4600 Open GL ???
but i only have 8gb of memory :confused:

I juste add 8GB of memory to reach 16gb and i still have this problem.

I do not have this problem, so I can’t test it. However, it might be worth updating your Intel graphics drivers.

What version of Windows 10?

Type “System Information” in searchbox in taskbar

Free Intel HD Graphics Control Panel

Hi, Thanks for your Help, but sadly, updating driver doesn’t help.

And your right, this error code is in Readme PDF of the Stitcher, and:

The images could not be processed successfully: 0x00010505 → there is insufficient memory.

But now i have 16gb on my computer :confounded:

Have you tried to contact the official RICOH customer support? They likely have a bigger database with support queries. I think you have a good set of information to report. It seems like your configuration and versions are up to date.

This THETA Stitcher is new and a bit tricky to use.

Have you tried using the trial version of PTGui as a test? I realize that PTGui is a bit pricey, but it may help you to experiment with the DNG images while you sort out the stitching. Information on PTGui is here.

This is likely unrelated, but the Windows machine I used for testing does have an external NVIDIA graphics card and I’m using the NVIDIA drivers. The machine used in the test only has 16GB of memory, same as your machine.

While it’s surely always a good idea to check the specified prerequisites, I doubt that non-conformance is causing the problem in this case. Especially, as 16 GB is plenty of memory. I run Lightroom and the stitcher with 8 GB without any problems.

Perhaps the error message is misleading due to lazy programming. Typically, processing may fail during one of three stages:

  1. reading the input file
  2. processing the image (stitching) in memory
  3. writing the output file

As the image is previewed in the stitcher’s GUI, stage 1 and 2 seem to be OK. But what may fail at stage 3? Some guesses:

  1. Disk full
  2. Disk/folder/file write protected or write permission missing
  3. Special characters in the path that the OS or application can’t handle
  4. Path too long to be handled by the OS or application (Windows is prone to this)

I have already ask to the official support, waiting for an solution, but right here there is a loot of specialist :grinning:

It’s work this the ptgui, but isn’t free.

1 Like

I agree with you.

Light room is able to create the .Tiff on the side of the original dng. Something I have this error just on moving some cursor on the Ricoh stitcher, so maybe an issue to create an temp file or read the memory.

1 Like

A remark on my configuration shown above: Using Adobe RGB for the color space as input to the stitcher results in unnatural flat colors. Seems that the stitcher is not correctly doing color management. So use sRGB instead. This restriction should also be documented in the manual. Or even better, it should be fixed! Working in a Lightroom/Photoshop environment without supporting color management is a no-go!

BTW: The THETA desktop app also handles colors poorly so don’t depend on it for color proofing. For quick previews after exporting the equirectangular image from Lightroom, I use mostly use FSPViewer which handles ICC profiles correctly.


Did you get a response and hopefully a solution from the support?

I’ve just installed my setup on a new hardware and get the same error! :frowning_face:

Same Windows, Lightroom, stitcher versions and configuration as before.

In the stitcher’s preview window, everything is fine, but after exiting it by selecting ‘OK’ to start the actual stitching, the error message is given.

Hi, the only response I get it’s I need to contact the French support, and I don’t want because it’s not provide by Ricoh or Pentax company but by a third company… And I’m pretty sure they don’t care…

Unfortunately, my experience with Ricoh’s support has been very bad as well. Reported a problem with the THETA S via international and national (German) support channels without getting any response, except of the ticket being closed after some time. With the THETA Z1 now targeting the professional market, I hope an adequate professional support will be established.

Regarding this stitcher issue: I’m willing to help tracking it down, e.g. by providing log or trace files. Unfortunately, the Windows event logs contain no entries, and in the filesystem I can’t find any logs as well.

Does anyone know how to turn on debug-level logging or tracing?

I am a beta tester for a new version of the RICOH Stitcher. I just sent a link to the updated beta version to @Yoann_Tronique. I don’t know if it will solve the problem as I can’t replicate it. If other people have a similar problem, I can help them to find the beta version (Windows only).