HowTo: RICOH THETA V and Z1 4K Live Streaming Driver For Windows 10

Hi, Please can you send me the direct link to test the 4k Live stream. You can send to my email…

Thanks as i await this

@Habib_Michael, I just sent you a DM on this system which should go to the email you registered with the system. You can delete your email from the note above so random spammers don’t find your public email.

Hello. Please send me the link where I can download the software :+1: thanks


Sent by DM. Be aware that sound from camera does not work with this driver for live streaming. The driver is still in beta, but the video seems fine and stable.

If I need a driver for Win10, I’d love to have the link.
As I read here for MAC OS it is not necessary can anybody tell, what I am doing wrong?
OSX 10.10. OBS 20.0.1 but I cannot select the ThetaV as a source…

Sent Win 10 driver link by DM. Will test OS X again after breakfast and then post more technical details on my configuration.

I actually do need to run an errand, so I’ll just do a quick post.

I’ll put more tests at the link below.

Are you not seeing any stream or are you not getting 4K streaming (you can get the stream, but the resolution is lower than what you expected?)

Update. I posted a screenshot of my setting at the link above.

Ideas for troubleshooting on the Mac:

  • test with QuickTime. Does it work?
  • reboot camera
  • reboot computer


thanks for testing. My Problem is simple but durable: it have no Theta UVC 4K in the box to select as a source.
no possibility to select it with QuickTime, nor does rebooting change anything…
Wich OSX do you use?

Please confirm that the camera is in live streaming mode. There needs to be a blue word called, “Live” on the front of the camera.

On the THETA S, it looks like this, green circle. Please confirm it is in Live mode.

Also, on the Mac, the driver is RICOH THETA V (on Windows it is different)

Well, I switched it on, nothing changed.
In Quicktime I can now choose the microphone of the ThetaV as a source…
If I hold the mode button for a long time Status LED change to white and WLAN blinking green… but does not help either…

Can you live stream on Windows 10?

Is it possible that your camera can’t live stream? If so, you should verify with Ricoh customer support as it is probably still under Warranty.

Ok, just freakin awesome. Thank you for the great info! Can you please give me access/link to the Beta driver for THETA UVC 4K? I’d really like to try it out.

Hi @codetricity Can you please share the 4K UVC links with me? I need . Thanks a lot!

Dear @codetricity,

Could you share the RICOH THETA UVC 4K for my test?

I tried to live streaming with Theta V and MPC-HC in windows 7 yesterday, first time MPC-HC cannot select analog or digital in option -> playback -> capture even I was connecting Theta V, after that I installed Ricoh Theta UVC Blender which was a old version for Theta S, in MPC-HC option -> playback -> capture, it just can show Ricoh Theta UVC Blender, the streaming live was not working on MPC-HC.

Sent UVC 4K to @Dan @WenSongLee and @skyiver by DM. If you don’t get the DM, let me know as I’m sending it out by hand and I could make an error in the DM.

Note that the driver will not work on Windows 7 as far as I know. It requires Windows 10 1703 or higher. Both 64bit and 32bit should work.

Audio does not work with streaming. Use the microphone on your laptop.

Mac OS X does not require this driver. Use RICOH THETA V webcam on Mac OS X.

I believe this driver is still in beta and thus people can’t get official support from Ricoh with it. Community support only right now. Community has had fairly good results with it so far (except for the audio).

If you learn anything new, please post your test result or experience.

1 Like

Dear @codetricity,

Thanks your reminder regarding UVC is not support on windows7.
I am using MacOS Sierra 10.12.6 toconnect the Ricoh Theta V with usb cable, and try to connect with OBS, it seem not work. Did I do something wrong? Thanks.

Best regards,


I’m using macOS 10.12.5.

I don’t know if the version matters.

The camera needs to be connected with USB in order to get into live streaming mode.

When you first boot a THETA V, it will look like this:

When it’s plugged in with USB for live streaming, it will look like this:

Do you see that Live word? The word Live is flashing. Is it flashing on your camera? It’s it not flashing, it’s not in use (I think). It’s flashing on my camera now.

On the Device section of OBS, the RICOH THETA V device is automatically populated on my system.

The Mic works on the Mac.

OBS 20.0.1.

By blinking, I mean this:

As I believe RICOH THETA V live streaming is supported on a Mac by Ricoh official support, maybe try and give them a call and see if they can help?

Toll Free: (800) 877-0155

Monday - Friday
8:00 a.m. - 5:00 p.m., Eastern Standard Time

You can also contact us by using our Customer Service Web Form. You’ll find the link below. Once you submit the form, we’ll usually get back to you via email within three business days.

Contact Customer Service Webform

If you fix the problem, please report back as to the source of the problem so that other people can benefit.

@skyiver One thing I just remembered is that I was at my friend’s office testing his super cool MacBook Pro with that boss slider bar. It’s a beautiful machine. Anyway, live streaming was not working. We traced the problem to the adapter he was using in his Thunderbolt 3 port. Although the adapter worked with other USB peripherals like mice and keyboards, it wouldn’t work with live streaming from the THETA V. We verified this by switching to a different Thunderbolt 3 adapter from a different vendor. He had another adapter in his bag.

Well, I don’t know if that problem was with the RICOH THETA V Mac driver, the Thunderbolt 3 adapter, or the Mac OS. However, I do know that once we changed the adapter, the streaming started to work and we were all happier.

I’m just going by memory, but I believe that I could see the RICOH THETA V driver in the list of cameras on his Mac. So, this problem may be unrelated to the problem you were having.

Hope you get it working.

Just got the camera yesterday, would love to have the download link to test it!

@slamdisques just sent the link by DM. Let us know how the test works.

you only need it for Windows 10. You need to have 1703 or higher. Tests work great with OBS and MPC-HC. No audio from camera. Use your laptop microphone and mix it.

RICOH THETA is not recognized even when the camera unit and computer are connected with a USB cable.

The camera may have frozen.
Push and hold the power button and wireless button simultaneously (for 6 seconds or longer) on the camera. After the camera has reset, push the power button again.
With a Mac, changing the USB port may solve the problem.