Problem charging Theta S

I have the following problem. I put my camera Ricoh Theta S to load and it loads up off the red LED. Once charging ends I turn on the camera and works normally. When I try to turn it ON on the next day. It does not have battery anymore.

Does anyone know what can it be??

What is the amperage of the wall charger you are using? Are you using the same cable that came with your camera? A lot of the mobile phone charges for newer smartphones have a current output of 1.5amps. Try that with the cord that came with the camera.

Check the charge and make sure it is charged.

Look at the bottom of the mobile app

The battery charges 100 % and works one hour or less.

Have you tried contacting RICOH support about a warranty claim? My camera lasts several hours. I think @jcasman also had a battery issue, but I think it lasted more than an hour. I’ve used two of these and both got more than an hour.

Are you taking video continuously for an hour and then it dies?

Just a quick follow up, not adding a lot of specific information. The RICOH THETA S that I use appears to last about 2 hours total in a “normal level” of on and off picture taking, video taking type setup. This is after charging to full. I will try to test it more fully over the next week and see how much time it really lasts.

1 Like

I spoke to my father about this. He used to be a professional troubleshooter for US government high-end computers. He’s also still very much a hardware hacker, having just replaced a battery in a closed GPS unit he uses for golfing. He has a bunch of professional test equipment for electronics in his workshop. Anyway, his theory is that the battery construction is much thinner now days to save weight and a small number of units will have bad batteries due to the OEM battery supplier, which is often in another country. His recommendation was to change the battery if it is already out of warranty. Personally, I wouldn’t change it. However, he’s the type of guy to take apart anything. He told me to share information on replacing the battery, but to me this is a mixed bag since some people may break the camera. It seems best to get the battery replaced under warranty.

I have same problem ,I don’t know should have to buy a new battery or new camera……

I try two different way to test thebattery.

first time I’ve been recharge to full and keep the battery in the camera,after a night ,it can not be open again.

second time ,when I charge full,I pull out the battery ,keep it out for one day,it was still at 3.90v,mean it still full ,and put it back in the camera,it can work. but if don’t pull it out,the battery will dead after one night……

I think it’s not only the battery problem,maybe something wrong with the camera,so I’m not going to buy the new one yet.


I have thets s suddenly stop working, i have to open it i romove the battry and plugins again, its now work but the issue that if i fully charge the camera and i turn it off, after an hour the battery is empty, I purchase new battery same issue.

Any suggestions!!

Is your problem solved ?
I have some problem too.

First, I would make sure that the battery is fully charged. Charge status is available within the Theta app. I have had situations where the battery appeared to be charging and was not. When charging, the power button will glow a dim red (not flashing). When charging is complete, the light will go out.


I have same problem ,I don’t know should have to buy a new battery or new camera……

Get something like this and post the charging rate:

You can get cheaper units as well. In the US, this is $12 with free shipping.

The battery reported by community members is $9. If cash is tight, you can just try the $9 battery and see if it works. If you have the USB power charging monitor, it will help to see if the battery is charging or not. If the battery is charging, but cannot hold the charge, you can gamble on the replacement. If there’s no current going to the battery, might be the camera main board, which is not replaceable.

Also, can you check the battery charge of your camera to make sure it was fully charged? You can either use windows (right-click on camera icon) or the mobile app.

Are you sure the camera is turning off? Press the power button for 15 seconds and make sure it is off. It should take more than 12 seconds to restart when it is off.

When it is in sleep mode, the camera comes on quickly. Maybe the camera is in sleep mode and something is causing it to come out of sleep mode?

yes,I keep press the power button over 20sec,but theta s have no respond with any light flash or change color something.

I buy a cheap battery (only $7)and almost same like DB-110,I just begin to test it from tonight.

Hopefully, this will solve your problem.

I found some issues they talk about TF-card or SD-card can make smartphone quick lose battery,when they format the card can stop this,I will try it.

I found these word for “MediaServer battery drain issues and gain back the battery life in your Android device”,maybe it was something like my thetaS

I got new idea for this issue!

last week I was try to use my DJI phantom 4 take some pictures,but the remote control is not working,it has some battery issue to,I found many video of this problems on YouTube,they are just use hot-fan-gun to heating all the cheeps on board,I just do the same way and fix my problems.

So I think that maybe same problems for my THETA S,and I doing this again ,and it seems like works,my THETA S can take hundred pictures and still have two gird battery life .

I will test it more time to make sure for this.


Wow, this is a great fix. Amazing. Thanks for posting it.