Theta s not charging


#1

hi i try to charge my theta s but the red lines turns on for a moment and then goes off


#2

Saverio,

How long have you had your THETA? Was it properly charging before? Are you plugging into a wall socket or a computer USB port?

If you do a search for “charging” on this site, you’ll get multiple helpful responses:

http://lists.theta360.guide/search?q=charging

Jesse


#3

HI James,
sure i ve tried all the options of charging (wall, usb) .
It was charging correctly and then one day with out no evident reason it
stoped.
Now wen I plug the usb it gives me a few red light signals and then stops.
I-ve tryied to reset the theta but nothing. The camera is not recognaized
by the computer.
Since the guaranty expired can I just try to change the battery_ of yes
were can i find a new battery_
please consider that i live in milan italy.
thanks
Save


#4

Save,

Just one more idea: Did you try pressing and holding the power button for 8 seconds to reset? And then restarting?

https://theta360.com/en/support/faq/c_01_s/8/

Jesse


#5

Ues i ve done that too

Saverio Schiano


#6

Ok, probably you need to contact RICOH THETA official support: https://theta360.com/en/support/contact/ I have seen people mention that taking it to the distributor you bought it from gets quicker responses, but I don’t know. Good luck!


#7

There is any way to have a contact non us?

Saverio Schiano


#8

I was getting exactly the same symptom - red light coming on, then off, then flashing briefly, then off for good. I tried all the tips I found on this site. None worked until I eventually combined two of them. Success!
Try holding down the power button as if you were doing a reset, then while holding it down, plug in the usb cable, continuing to hold down the power button. (Alternatively, have the cable plugged in, but turned off, while you have the power button depressed, then switch on the usb charger - again whilst depressing the power button.)
When I did this, the red charging light came on, and stayed on. After a few seconds, you can of course release the power button.
Hope it works for you too.