PTP device busy how to reset remotely?

I have a camera operating remotely via PTP cam and the schedule to take photos has stalled. I can normally reset the camera remotely but for some reason the camera ‘thinks’ it is doing something else and I cannot reset the camera remotely (by turning off USB port) and it give the message at the end of this script ‘PTP device busy. Does anyone know how I can overcome this?

Are you unable to power down the device?

theta-api-specs/ at main · ricohapi/theta-api-specs · GitHub

turn on:

Camera - RICOH THETA Development on Linux

Thank you for that. Do you have any info on the power down command on Gphoto2?

I don’t suggest you do this unless you have physical access to the device. You need to run a script to turn the camera back on. If something goes wrong, you may need physical access during the setup.

I have do not know how to use gphoto2 that well and have not tried the command below:

gphoto2 --set-config=/main/actions/opcode=0x1013

Note that to turn the camera back on, I’m resetting the USB ports of the Raspberry Pi.

Thank you Craig! Will bear that in mind

Sorry, I typed the wrong number previously. I just edited my previous post.

I tested the command below to power off the camera. It worked.

gphoto2 --set-config=/main/actions/opcode=0x1013

Thank you Craig, greatly appreciated. This does work


There is a community hack to turn on the camera from a power off state using a technique to reset the Raspberry Pi USB ports. This technique will also temporarily power down any other sensors attached to the USB ports.