SC2 discharged when off overnight

My SC2 has let me down a few times now. Sequence of events is something like -

  1. Charge up to 100% battery
  2. Disconnect cable
  3. Turn on and try test picture - works
  4. Turn off … nothing is on the display
  5. Leave overnight
  6. SC2 fails to turn on the next day ( usually when I’m away and can’t try a charge )

I’m assuming the SC2 discharges itself overnight … but hard to tell. A further charge “fixes” the issue.

Anyone know if this is a known issue. Anything I can do to avoid the issue ?


I don’t test the SC2 as much as the Z1 and X, but I believe the SC2 has two power modes, sleep and power off.

You you turn off the SC2, make sure you press the power button for about 4 seconds.

I actually just took out my SC2 from the case and tried to use it, but the battery was dead. I’ll try to run some tests after I charge it.

Oh … I didn’t know that ( although the manual only says “Press the power button again to turn off the power.” ).

But that would be consistent with what I’m seeing.

The API for most of the THETA models indicates separate properties for the sleep and off delay. I’m assuming the SC2 is the same. If there are separate properties for sleep and off, I’m assuming the behavior is different. I’m also assuming that the power button can be used for sleep and off.

For the THETA V, this video shows the behavior. The SC2 may be different.

The SC2 is using a different internal OS than the V, X, Z1. However, the functionality with sleep may be similar.

I saw the same problem over the weekend ( when taking picture for SGP sgp2023 - uMap ).

One thing I noticed, though, when the SC2 wouldn’t turn on in the morning, only a short charge ( maybe 10mins ) brought it to life with a full battery charge displayed. So maybe something else is stopping it waking up. I tried short presee, 4 second press and 10 second+ press and nothing worked until after the short “charge”.

Are there any on-device logs or similar to look at ?

State has a property for error.

Hopefully, you don’t have a main board connection problem inside the camera.