THETA S Possible Battery Replacement in Community

This is unverified.

If someone VOIDS THEIR WARRANTY and does the swap, please confirm that the battery size is the same. This is obviously not authorized by RICOH and you may brick your camera. Completely not recommended unless you’re a hardware hacker and want the challenge.

HonbanGaan said


above all are the battery equal to DB-110, except capacity.

where to get db-110?

This is unverified. Please confirm or report back if any of these batteries work.

HonbanGaan said


above all are the battery equal to DB-110, except capacity.

This $7.99 battery MAY NOT WORK.

You will void your warranty if you take apart your camera. Your best option is to call RICOH support or go back to the store where you bought the camera from in the first place. The RICOH battery is not supposed to be changed by the end-user, only professional support centers.

If you attempt this, suggest you read this post first.

BTW, this article on the m15 shows that the DB-100 was used in the previous version of the camera.

Several people on this forum have taken the camera apart and put it back together again. No one that I know of has changed the battery.

If you get it working, please report back. I don’t recommend this unless this is a hobby for you or you are unable to take the camera back to the store.

Saw this on Facebook.

Thanks to community member Iamme Accho for contributing this information. NOTE: the battery is not recommended right now.

Sleeping Beauty Revised with a replacement battery. No Ricoh DB-110 3.7V 1350mAh battery available. This is a Olympus Li-50b (3.7V 945mAh) compatible battery (3.7V 1800mAh). Don’t do it yet if you have a dead Theta. THIS BATTERY FEELS WARM powered off, hot powered on. May be the camera’s problem - exactly how it was before bricked. I will test it until battery depleted, then try a cautious recharge. I have another Li-50b compatible battery coming.

IMPORTANT: Battery got too hot and the test DID NOT WORK

IMPORTANT: Battery got too hot and the test DID NOT WORK

IMPORTANT: Battery got too hot and the test DID NOT WORK

Community member then tried this:


Waiting to see if it worked.

1 Like

Original post

I replaced 2 brands of Olympus Li-50B compatible batteries to my Theta S. They were 1650 and 1800mAh 3.7V and good fit into the Theta chamber. Both could power up yhe Theta and take pictures. In this regard I would say they worked. One problem is the situation compelled us to replace the DB-110 battery is likely to be a battery failure. In my case, the Theta became very hot and then could not be recharged- the camera just got frying hot. Upon installed the new battery, in both occasions, the new battery warmed up soon before power button was pressed. And after some time, it cooled down (battery discharging until exhausted). Trying to recharge it only caused it to heat up without charging progress. I would guess my Theta has burnt the chips or the insolation somewhere. To verify, a healthy Theta camera is required. But who will do such silly thing if it is working?

It’s still unknown if it will work on a healthy camera. In this case, the camera may have a problem that caused the battery to die.

Warning You used a 3.7V battery instead of original 3.6V (and no branded battery…)
I’ve find now an original OLYMPUS battery model LI-92B on ebay (cost around 20euros).
It is exactly as original Theta S battery 3.6V 1350mAh 4.9Wh, and have same code printed on it ( 1INP9/35/39). This Olympus battery is made from Sony Electronics (Wuxi)Co.Ltd.
Into next hours I do a replacement and test it.
Stay tuned

1 Like

@Franco_Melechi Thanks for this community report. We haven’t had a good confirmation of a battery replacement yet. You could be the first person to document this if your test it successful. :slight_smile:

Nothing to do. Don’t replace ThetaS battery with OLYMPUS LI-92B battery !!!
Theta S now won’t charge more ! :frowning: even with its original battery!.
It took only a moment to go out of use the microchip intended for recharging!
Also I used the original usb cable!.
I’ve done digital measurement before I replace and all value they were very similar!
Now Theta S work well without cable etc. normal use, but when you place in charge it don’t charge more.
What solution can we find @codetricity ?

@codetricity Strange results now.:roll_eyes:
I left the USB cable connected to the charger, and I unplugged the input cable 220V of the charger. Wait a moment and then connected the 220V energy. Theta is back to load, charging now with 0.4A, red LED on. But inside I put back the original battery…test continue…

Thanks for this update.

I haven’t heard of anyone successfully replacing the battery yet. It would seem like it should be possible, but for some reason, minor differences in the batteries appear to cause problems.

For example now I connect theta to usb 3.0 PC ports and Red led is on. This led have two different power light emission, depends of condition of use (theta on while charge, or in off state). Now seem it is in charge, nothing become hot.
Honestly I take the risk because theta battery discharged immediately after about 15 minutes of intensive use.
I’ve found a little liquid on the bottom of the battery compartment, but I assume it is not coming from the battery.
Test continues

1 Like

Ok, after a long test all night with digital measurement, I am proud to tell that the battery replacement for RICOH THETA S is the OLYMPUS LI-92B (original, not clone or similar).
The problem I have before is in the power adapter (in fact in any work other not).
Digital pass-trought USB measurement (I have picture to share) tell me that usb voltage >5V Theta have a problem to recharge battery, while with usb power adapter with output voltage little below 5V the battery is charged regularly. Current charge stable at 0.450mAh.
That’s all for now, I can share picture after I’m back from work, no problem.
@codetricity Please share this infromation to community, thanks.


  • first image show battery
  • second image show syncro chargment battery with original cable (please ignore big digital measurement tester), and look to the small usb pass-throught digital measurement, it show absorbition ov 0.82 now;
  • third image show ilepo usb power adapter (not good to charge Theta!)
    -fourth image show original and Olympus battery near (dimension are same!);
    -fifth image show in details the moment of picture n.2
    I have more picture but are over 3Mb file and website don’t allow me to upload, need to resize image
    -Sixth image show absorbition in the night of the original during the night charge with Olympus battery (note that I use only original Ricoh usb cable from digital measurement to Ricoh Theta S);
    -Seventh image show the adapter I use in that moment (it’s an original iPad Apple 10W power adapter, no clone no cina no other in this test but I have hundred of charge to test. You can check if it’s original seeing into usb port there is serial number, clone don’t have)

Battery bought from:


Thank you for this report. Please share the pictures when you have a moment. I will share this out to the community on social media.

Here’s a couple of links on the Olympus LI-92B that I found online.


NOTE TO COMMUNITY: Suggest waiting until we get more verification of this working. If you’re stuck with a dead battery, do at your own risk. Please read the community reports carefully.

It would be awesome if you can provide additional usage tests and pictures so that we can verify that the battery still works after a few weeks of use.

thank you.

I can confirm that third-party LI-90B/LI-92B batteries work in the Theta V. The brand I had success with was “PowerExtra” 1500mAh, I bought them new on eBay for $5 each.

1 Like

Wow, great contribution. Congratulations on your success. Was the process of taking apart the THETA V the same as for the THETA S described in this thread? Did you take any pictures of the steps?

This is the battery, you’re using, right?


This Theta (my 2nd V and 4th Theta overall) came to me already disassembled, roughly :frowning: I bought it “as-is” on eBay for cheap, with a scratched lens and a missing battery. It looks like somebody scratched the lens then pried the case apart with a big screwdriver to harvest the battery before selling. I added the battery then carefully reassembled, and it works great now, no excessive heat nor any other issues :slight_smile:

I think disassembly would be easy, remove the bottom sticker, take out the 4 little screws, then pry apart the case.

Those are the batteries, yes.


This is great. What a nice story that you took a chance to buy an used camera on eBay and were successful in getting it working again.

You now have a $400 camera at an incredible bargain. :smile:


Really cool that you worked with it “as-is” and it’s working well for you now. Fantastic!