USB SDK CPP Windows 1.1.0 does not detect THETA SC2

I have downloaded the Windows C++ SDK (v 1.1.0) and tried running the command line example, cli.exe. I have a new Theta SC2 connected by USB cable to a Windows 10 machine. The program never detects the camera.

I tried using both the provided executable and one that was build with Visual Studio 2017. In both cases it did not work.

The USB connection allows me to see the the camera as a device and to access the stored photos, so the basic USB connection is not the problem.

I downloaded the DotNet SDK just to compare. The C# sample program ConsoleSampleApplication.exe did work as expected.

The C++ code in the cli example seems pretty straightforward. Does anyone have any ideas why it is not working?

that’s the wrong SDK.

See this discussion.

I have read through that post multiple times, but I still don’t understand why you say I have the wrong SDK. It is the only SDK listed that is for Windows. All the discussion in the tread you mention is about 3rd party libraries that use PTP/MTP. If that is the wrong SDK then it would appear that Ricoh does not supply and SDK for use with Windows.

The C++ SDK you are using is for a different camera series, not the RICOH THETA. There is no SDK for the RICOH THETA that provides C++ examples.

Several other people on this forum downloaded the same SDK you are using. However, it doesn’t appear to work with the THETA.

See this thread:

You can of course attempt your own experiments, but wanted to give you a heads up that other people have tried that SDK and eventually moved to libptp2

If you want to build a Windows Kiosk or are using Windows for some type of monitoring console, this may help:

Run it through Google Translate.

I have not tried the above.

@Craig, thanks for your reply and clarifying the issue.

I am working in a Windows environment, so the Linux libraries are probably not going to help. Sometimes it is possible to get library code working on Windows, but sometimes it is too much trouble. I am planning on using the Microsoft WPD SDK to start with. I was able to build some sample code that connected to the Theta. I think I understand how to modify the commands to insert the operation and property values from the Theta API reference. If I get it working I will post back with results.

1 Like