Use Wireless Live Streaming Plug-in on Local Network?

I’m trying to test the Wireless Live Streaming Plug-in at 4K to document potential heating problems.

Has anyone been able to run a local server?

I’ve tried these:

In addition to the solutions above, it seems like gstreamer or ffmpeg would work, but I can’t figure it out at the moment.

I have access to both Windows 10 and Ubuntu 20.04.

hi, Craig!

About 2 years back (or even more) tried ant media server: https://antmedia.io/ there is also a community edition which may be sufficient for testing. It runs on Ubuntu too, not sure about your version of ubuntu, but it should work. I had issues with transcoding quality there, but you may not need transcoding for testing, also there were lot of updates applied since that time. It’s easy to setup, it provides web UI too to manage.

Regards,
Laszlo

1 Like

@biviel , thanks. I will try this later today.

Just an FYI, I did make a report to my contacts at RICOH about the heating issue you have with the Z1 plug-in you are developing. They indicated that they know of unofficial tests with the Wireless Streaming Plug-in at 4K for 24 hours. There is no publication of these tests and no information on the conditions. Though, I imagine that it was indoor in an air-conditioned room with no fan on the Z1.

I am trying to test the situation myself.

Using Z1 with 1.60.1

  • RTSP plug-in shows video frame degradation at 4K, but is fine at 2K. Using VLC as the viewer on Ubuntu 20.04. Tested at 2.4Ghz Wi-Fi with an old router. It’s possible that my Wi-Fi setup is causing the frame degradation. However, as I am trying to isolate heating problems, I did not pursue a solution and decided to test the Wireless Live Streaming plugin
  • I can’t test the Wireless Live Streaming Plug-in at 4K to YouTube or Facebook as I have slow upstream bandwidth in my house and my daughter is doing Zoom online classes all day much of the night (for other types of classes). The plug-in works fine at lower resolutions, but this is expected as it is likely having heating issues only at 4K.
  • I’m trying to run the Z1 at 4K live streaming on my local network with Wi-Fi to control the variables and document the test conditions more precisely

Additional notes

  • I do not think it is possible to use Ethernet indefinitely with the Z1. The battery will drain. I’ve tried different types of splitters. I do not think it will work.
  • If people power the Z1 from their computer, Wi-Fi will turn off. If you want to power the camera from your computer and use Wi-Fi, one cheap method is to use a data blocker (physical $7 device). More info.

When you release your plug-in for testing, you may want to have some scenarios for local on-premise testing, especially for functionality such as endurance.

Hello @craig!

As part of my thesis I have come across all the servers you mentioned above. I also have found this RTSP-Server by revmischa to whom I passed an RTMP stream from MonaServer converted with ffmpeg.

Sad story is that I used them with simple streams and not 360 streams like those from my ThetaV. Specifically, when I tried the Wireless Live Streaming Plug-in with MonaServer, it complained with the message bellow

FlashMainStream.cpp[68] Client RTMP not compatible with AMF3, few complex object can be not supported

I proceeded and left behind the Local Network servers using RTMP, but I hope to deal with them again in the future. If you have any progress with this local RTMP streaming method I will be happy to hear about it.

Best regards,
Dimitris

1 Like