Can't access UVC FullHD

Hi everyone,

I’m trying to access the FullHD Stream from the Ricoh Theta, but it doesn’t show up, even in OBS(newest Version)
I have installed the newest UVCBlender 64 Bit file and my Ricoh Theta S has the newest Update too, but I still can’t access UVC FullHD Blender. I’m using Windows 10.

When I use OBS Studio 32Bit it works. Is there anyway to access it in 64Bit OBS ?

it works with 64 bit OBS on 64 bit Windows 10 on my computer. I’ll try it again to make sure.

Can you explain the problem a bit more? Is it not showing up under the drop-down menu of OBS?

it doesn’t show up in the drop-down menu and it doesn’t show up in Unity(64 bit) when reading out all attached webcams.(I did the hack and even double checked if I did it the right way) When I build a 32bit version of my application in Unity I can access “Theta UVC FullHD Blender”. I could live with a 32 bit version for now, if there wouldn’t be a problem with the Oculus Avatar I am using(making a VR application by the way). It’s library only runs in 64 bit. I’m using Windows 10 Pro(newest Build) 64 bit and I installed “UVCBlender_setup64_de.exe”.

Thanks for the fast response, I really appricate it.

We roled back our Windows Latest build
to the earlier version and paused the updates.
Several Aplications did not run on the latest
Tips : Press windows-logo +R
type winver press Enter and post the version number here !

Regards Svendus

I also had problems getting a stable configuration with OBS. The video stream was fine, but sometimes the driver didn’t appear. it works now for my config, but I understand that it’s a bit tricky sometimes.

Also, just tested Unity with the configuration above. (fresh test from a minute ago)

If you have Unity code snippets, please post it. I am not a Unity developer myself and only tested a few features. Also, I am curious about how you’re using the registry hack. Are you using this in a private application for internal use? Here’s the test script I’m using to output the device name to the console.

        WebCamDevice[] devices = WebCamTexture.devices;
        Debug.Log("Number of web cams connected: " + devices.Length);

        for (int i=0; i < devices.Length; i++)
            Debug.Log(i + " " + devices[i].name);

        Renderer rend = this.GetComponentInChildren<Renderer>();

        WebCamTexture mycam = new WebCamTexture();
        string camName = devices[2].name;
        Debug.Log("The webcam name is " + camName);
        mycam.deviceName = camName;
        rend.material.mainTexture = mycam;


I was just thinking that you may want to uninstall UVC FullHD Blender, reboot computer, download a fresh copy from the RICOH site, then install it again.

Hi everyone,

sorry for my late reply.
thanks for all the replys had no time to work with the Ricoh Theta S (college work and stuff). I will try Thursday to get the FullHD stream working, posting more details then.

Thanks for the update. Curious to learn what your application is.

megan has it run with SteamVR Unity.

There’s a bunch of other people using it for robotic telepresence. Like this:

Here’s another test by the go using the robotic interface.

Hi codetricity,

I looked at the tutorial, but it only concentrates on the Dual Fish Eye Stream, I got that already up running. What I would like to do is to access the FullHD Stream with Unity using the reg hack. I already did the hack and for the normal HD Stream it works great. But I cant access the Full HD Stream with a 64 Bit application, even in OBS Studio it doesnt work for the 64 Bit version.

I tried uninstalling UVC FullHDBlender, heck I even uninstalled everything relatet to the Ricoh Theta, did a fresh install today and redid the reg hack, still the same problem as before.

In your pictures, you can clearly see it works in Unity 64 Bit and OBS Studio 64Bit, so I have no idea where the problem is.

Here are some picture I can provide for more detail.

ignore the fact that the Ricoh Theta S doesn’t show up in the dropdown menu in the OBS Screens, it wasn’t connected at that time, when its connected its the same plus the addition of the “Ricoh Theta S” Dual Fish Eye stream. J1455 is an other camera connected.

This is a bit new to me and I’ll try to do more tests today.

In this blog, there is a note about 64 bit OS with 32 bit application

Maybe you need to check the registry key again?

The registry key is located under HKLM, SOFTWARE\Classes\CLSID{860BB310-5D01-11d0-BD3B-00A0C911CE86}\Instance (note it’s SOFTWARE\Classes\Wow6432Node\CLSID… in 64-bit OS for 32-bit app space), where every subkey corresponds to a registered device (find yours there). Note that CLSID above is actually CLSID_VideoInputDeviceCategory.

I’m running 64 bit Windows 10 with 64 bit OBS and UVC FullHD Blender

Keep in mind that I am not an experienced videographer and have limited experience using live streaming in professional environments. I am just sharing my settings because it appears to be working in the situation that you want to use the THETA in.

Here’s my OBS log file:

08:10:08.967: CPU Name: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
08:10:08.967: CPU Speed: 3999MHz
08:10:08.967: Physical Cores: 4, Logical Cores: 8
08:10:08.967: Physical Memory: 16335MB Total, 11764MB Free
08:10:08.967: Windows Version: 10.0 Build 15063 (revision: 296; 64-bit)
08:10:08.967: Running as administrator: false
08:10:08.967: Aero is Enabled (Aero is always on for windows 8 and above)
08:10:08.967: Portable mode: false
08:10:08.977: OBS 18.0.1 (64bit, windows)
08:10:08.977: ---------------------------------
08:10:08.977: ---------------------------------
08:10:08.977: audio settings reset:
08:10:08.977: 	samples per sec: 44100
08:10:08.977: 	speakers:        2
08:10:09.047: ---------------------------------
08:10:09.047: Initializing D3D11..
08:10:09.047: Available Video Adapters: 
08:10:09.051: 	Adapter 1: NVIDIA GeForce GTX 750 Ti
08:10:09.051: 	  Dedicated VRAM: 2114650112
08:10:09.051: 	  Shared VRAM:    4269447168
08:10:09.051: 	  output 1: pos={0, 0}, size={1680, 1050}, attached=true
08:10:09.051: 	  output 2: pos={-1920, 0}, size={1920, 1080}, attached=true
08:10:09.056: Loading up D3D11 on adapter NVIDIA GeForce GTX 750 Ti (0)
08:10:09.083: D3D11 loaded sucessfully, feature level used: 45056
08:10:09.660: ---------------------------------
08:10:09.660: video settings reset:
08:10:09.660: 	base resolution:   1920x1080
08:10:09.660: 	output resolution: 1920x1080
08:10:09.660: 	downscale filter:  Bilinear
08:10:09.660: 	fps:               30/1
08:10:09.660: 	format:            NV12
08:10:09.661: Audio monitoring device:
08:10:09.661: 	name: Default
08:10:09.661: 	id: default

08:12:20.118: [DShow Device: 'UVC Blender Test'] settings updated: 
08:12:20.118: 	video device: THETA UVC FullHD Blender
08:12:20.118: 	video path: foo:bar
08:12:20.118: 	resolution: 1920x960
08:12:20.118: 	fps: 30.00 (interval: 333333)
08:12:20.118: 	format: XRGB
08:12:20.119: DShow: HDevice::ConnectPins: failed to connect pins (0x80040207): The owner SID on a per-user subscription doesn't exist

This is what I see:

On Unity:

Maybe check the registry again?

BTW, by setting the scale to 16 and changing the rotation of the sphere, I am able to use this as a surveillance camera with user control.

I’m going to attempt an upgrade to Unity 5.6.1, 64 bit. I think you need the 64 bit version for some graphics support.

I saw the note about 64bit OS, and checked already twice, but sadly still no diffrence. The weird thing is that even OBS Studio doesnt recognize the FullHD stream and that should work even without the reg hack. My Ricoh Theta S has the newest update by the way, maybe I find some time to test everything on an other system, when that works I can atleast exclute the Ricoh theta and my apllication as the problem. I will reply as soon as I get to this. Thanks for the help.

Sorry to hear that you’re still having problems. In OBS, this is what the log says:

08:12:20.118: [DShow Device: ‘UVC Blender Test’] settings updated:
08:12:20.118: video device: THETA UVC FullHD Blender
08:12:20.118: video path: foo:bar

Note that after I applied the registry hack, OBS is getting the adjusted device info. Thus, it’s possible that there’s a typo in your registry hack that is affecting both OBS and Unity.

Once you get it working, I produced two video tutorials to show how to get the 360 video stream working on a sphere, both on the outside of the sphere as well as the inside.

This shows projection on the outside of the sphere using WebCamTexture()

This shows projection on the inside of the sphere using the same technique

There’s another confirmed use of the hack below.

Please check that you’ve edited the proper registry value. Maybe you edited the wrong one?