Compressing theta z1 live stream in jetson

I have connected a theta z1 to the jetson via USB cable. Using instructions here

I can see the live stream. But I need to access the live stream through ROS. I tried with the gscam but I got the error “could not get gstreamer sample”. I need to see it through ROS because I aim to compress the stream using image-transport package and send it to unity.
I would appreciate it if you could help me with this issue.

Try this:

Report back on what happens.

Hi Craig,

thank you for your reply. I try that and I got the error " can’t open /dev/bus/usb/001/021: Not supported (-12)".
I also tried this

but this also gives me the error " gst_buffer_resize_range: assertion ‘bufmax >= bufoffs + offset + size’ failed.
I have no idea what happened when I installed the theta_driver that now the gst_viewer from libuvc_theta_sample also gives me error “can’t open THETA”.
I also tried usb_cam that doesn’t work neither. Ros deep learning nodes are also no good. Could you help me with any of these ways?

When you’re using the Z1 in live streaming mode plugged into your linux machine, do: lsusb

For the Z1, I think it is will be 2715 (not sure). But, it should say, RICOH THETA Z1.

With gst_viewer -l, you should see the theta.

You should then be able to run gst_viewer.

Update 6/15

@afsoon92 did you get it working?

If not, please post model of Jetson and JetPack you are using.

Are you using an NVIDIA Jetson NX Xavier or a Jetson Nano?