How To: Edit and Stitch RAW DNG Images From RICOH THETA Z1 with Adobe Lightroom Classic CC and THETA Stitcher

Have you tried to contact the official RICOH customer support? They likely have a bigger database with support queries. I think you have a good set of information to report. It seems like your configuration and versions are up to date.

This THETA Stitcher is new and a bit tricky to use.

Have you tried using the trial version of PTGui as a test? I realize that PTGui is a bit pricey, but it may help you to experiment with the DNG images while you sort out the stitching. Information on PTGui is here.

This is likely unrelated, but the Windows machine I used for testing does have an external NVIDIA graphics card and I’m using the NVIDIA drivers. The machine used in the test only has 16GB of memory, same as your machine.

While it’s surely always a good idea to check the specified prerequisites, I doubt that non-conformance is causing the problem in this case. Especially, as 16 GB is plenty of memory. I run Lightroom and the stitcher with 8 GB without any problems.

Perhaps the error message is misleading due to lazy programming. Typically, processing may fail during one of three stages:

  1. reading the input file
  2. processing the image (stitching) in memory
  3. writing the output file

As the image is previewed in the stitcher’s GUI, stage 1 and 2 seem to be OK. But what may fail at stage 3? Some guesses:

  1. Disk full
  2. Disk/folder/file write protected or write permission missing
  3. Special characters in the path that the OS or application can’t handle
  4. Path too long to be handled by the OS or application (Windows is prone to this)

I have already ask to the official support, waiting for an solution, but right here there is a loot of specialist :grinning:

It’s work this the ptgui, but isn’t free.

1 Like

I agree with you.

Light room is able to create the .Tiff on the side of the original dng. Something I have this error just on moving some cursor on the Ricoh stitcher, so maybe an issue to create an temp file or read the memory.

1 Like

A remark on my configuration shown above: Using Adobe RGB for the color space as input to the stitcher results in unnatural flat colors. Seems that the stitcher is not correctly doing color management. So use sRGB instead. This restriction should also be documented in the manual. Or even better, it should be fixed! Working in a Lightroom/Photoshop environment without supporting color management is a no-go!

BTW: The THETA desktop app also handles colors poorly so don’t depend on it for color proofing. For quick previews after exporting the equirectangular image from Lightroom, I use mostly use FSPViewer which handles ICC profiles correctly.


Did you get a response and hopefully a solution from the support?

I’ve just installed my setup on a new hardware and get the same error! :frowning_face:

Same Windows, Lightroom, stitcher versions and configuration as before.

In the stitcher’s preview window, everything is fine, but after exiting it by selecting ‘OK’ to start the actual stitching, the error message is given.

Hi, the only response I get it’s I need to contact the French support, and I don’t want because it’s not provide by Ricoh or Pentax company but by a third company… And I’m pretty sure they don’t care…

Unfortunately, my experience with Ricoh’s support has been very bad as well. Reported a problem with the THETA S via international and national (German) support channels without getting any response, except of the ticket being closed after some time. With the THETA Z1 now targeting the professional market, I hope an adequate professional support will be established.

Regarding this stitcher issue: I’m willing to help tracking it down, e.g. by providing log or trace files. Unfortunately, the Windows event logs contain no entries, and in the filesystem I can’t find any logs as well.

Does anyone know how to turn on debug-level logging or tracing?

I am a beta tester for a new version of the RICOH Stitcher. I just sent a link to the updated beta version to @Yoann_Tronique. I don’t know if it will solve the problem as I can’t replicate it. If other people have a similar problem, I can help them to find the beta version (Windows only).

Thanks a lot for let me test this beta, unfortunatly, no changes, i have the same error : 0x00010505.

1 Like

Thank you for beta testing this update. I will report back the results.

Thanks to you codetricy :hugs:

I can’t get Stitcher to work in Lightroom on a Mac run Mojave. I have followed the instructions in the manual and also followed all the three on line video tutorials, but the stitcher window never comes up in Lightroom, Instead a get a warning saying a DNG File is required for the (Export Location) of the JPEG/TIFF file. Refer to the help instructions" which I have done. The action also creates a Tiff file but no stitcher window Spent hours on the phone with Adobe support and they won’t help because it is not their program,

Please post your settings similar to the screenshot below. In particular, the file name of the stitched JPG or TIFF must follow the same naming convention of the original DNG file. Take a screenshot of your settings and post the image. You can copy and paste it into the window you’re typing in.


Thus, something like R0010098-1.tif or R0010098-customname.tif will work. However, something like customname.tiff alone will not work.

Export to Same folder as original photo


Here is my export page:


Is the original DNG file still something like R000132.DNG?

When you saved the edits from Lightroom, maybe you changed the name of the DNG? The stitcher needs to find the R000132.DNG (or equivalent) in the same directory.

I don’t know how to use Lightroom or edit DNG files that well, but I’ve seen this type of problem before that was related to either the location or the name of the file you’re trying to stitch.

Can you try it on a structure that looks like this first before you do the edits and change the filename?


I used the Theta exporter to copy files from the camera to my hard drive. Then I picked one of the dng files to try things out.

Here are my files…

On my system, the “Example” file in Lightroom is always R0010XXX-extension.JPG


In your example filename, the file is 20190706.


I’m not sure what the exact problem is, but you may need to get the example to be in the R0010XXX-extension.JPG format.

I’ll put more screenshots of my settings below in the hope that maybe something will help.