HowTo: RICOH THETA V and Z1 4K Live Streaming Driver For Windows 10

I’ve tried everything, OBS, MCP, a Mac (no screenshots of that tho). Everything should be in order (I know the blender drivers are for the S. They’re there because I wanted to see if it would make a difference, but the camera continues to crash no matter what) Thanks, again in advanced :slight_smile: also, Windows 1909, but it didn’t work on a windows 8.1 or 10 1709 (have not tried 1703 with the alternative drivers tho)

On Media Player Classic (MPC), try the RICOH THETA V driver (Windows or Mac).
image

On OBS, using RICOH THETA V 4K as indicated in your screenshot.

Have you tried different USB cables?

You mentioned something about “crashing”. Does the camera lock or does your computer crash?

Aside from the problem with live streaming, does your THETA V work for taking pictures and video?

do you see the screen below on OBS, or do you see nothing?

image

Hi, thanks for getting back again. Still crashing on Theta V. I have also played with changing the audio tab (leaving it as default, forcing it to the device audio, and changing it to a different mic altogether). In OBS I have tried both as well and I get that image with the logo and the status code. I tried many cables and different ports on my pc (my main cable of choice is an Xbox One charge and play cable as it has a filter for better flow and is a nice length as well).

By crashing, I mean the camera. It tries to do what it needs to when the computer asks for the video feed, then the camera stays on, red dot appears (still with video and live lit up in blue), beeps 5 times quickly, then all lights turn off except for the red (recording) light and the power light (also in red) and it slow blinks (I think) 5 times then turns off.

Everything else works great on the camera. Still takes pictures and videos as expected, still updates, connects to my phones (iphone 11 pro and samsung note 8 (snapdragon)) with video feed. I tried the wireless live plugin and I have issues with that, but I think those issues might be with my phone instead. I do at times have difficulty getting my Theta to connect to my home network but will connect to my hotspot perfectly every time. Not sure if that is related or not, but I am really after the cable streaming method.

Thanks again :slightly_smiling_face:

Do you know if the theta V supports HML and/or if someone is working on a plugin for that or similar? I know HML is hardware based, so if it doesn’t have it a plugin won’t actually do anything. I’m just curious 'cause I couldn’t find it and being Android based thought it might.

This is unusual hardware behavior. There may be a physical or electrical problem with the camera, such as an intermittent short in the USB connection circuit. If this were the case, the problem wold only show up when you’re actively using the USB connection.

The status code on OBS (black with white numbers plus the logo) indicates that OBS can find the driver, but is not receiving a video feed.

I’m not familiar with HML. I haven’t heard of any support of that format.

Hi, I’m trying to setup live streaming on OBS but seem to be getting an 0x800705AA error. I’ve tried installing UVC4K_setupx64 but that still gives same results. Is the executable the next step for troubleshooting this or could you recommend something else? Thanks

That error indicates you do not have camera to computer connection.

Have you watched this video?

The driver was updated.
image

If you’re still having problems, post a screenshot of the dropdown menu of your drivers from OBS.

It would also help if you took a screenshot or post the specs of your Windows system info. in particular, your Windows system needs to be 64 bit.

image

Thanks Craig, I appreciate the help with this. I have watched these videos and frustratingly it seems to just work when you guys do it, and I just can’t spot what is wrong with my set-up.

The drives in OBS are:

The windows system info is:

Any help will be greatly appreciated.

Thanks again

Fairly easy to try:

  • Do you have anti-virus software on your system? If so, temporarily disable it for the test.
  • change the USB cable and the port. There are variances in cable manufacturers which might affect the stream
  • if the USB cable is on a hub or an adapter, try to plug it directly into the computer
  • if you are using a desktop computer, try the rear USB port, not the front panel port
  • reboot the computer
  • verify that the camera is in live streaming mode. Can you see the word “LIVE” on the front of the camera body
  • with the camera in “LIVE” mode, reboot the computer again

Can you try device default ?

image

Working

Tested today

working with these settings

image

NOTE About Test

When I first tested the camera, I was not able to stream with my Win 10 system. I needed to reboot my computer with the camera plugged into the system. When I rebooted the computer, the camera was in live streaming mode already and it came up immediately in OBS, which I had previously configured.

more difficult

Is it possible to upgrade your Windows 10?

image

Someone else had this same problem.

Hi Craig,

Thanks so much for your suggestions.

As I’m using a work laptop, I was unable to turn off the anti-virus. However, having eliminated all other options. I went onto one of my kids laptops installed all the software and found that I could access the camera fine.

So I’ve concluded that it was the security settings on the work laptop that were blocking the connection between the laptop and the camera.

Looking to see how I can get around that now. Otherwise, I’ll be borrowing my daughters laptop in future.

All the best!

@muddyoldengineer, congratulations and thanks for the update. I have a teenage daughter and understand the difficulties in borrowing electronic devices from teenagers. A quick test is easy, but longer-term use would cause a revolt. :slight_smile:

I have heard of other people with live streaming problems due to the anti-virus software on computers. I am not sure if this is the situation in your case.

Just want to let you know that this process is frustrating for many people. I think we’ve all been there where there’s a driver conflict, the cable is wonky, the camera is not in “live” mode. We’ve all be stuck for hours or days and realized that there was a simple fix like toggling the device selection or disabling anti-virus.

Realistically, the software and camera provide very minimal debugging information, so we have to try different things.

One of the great things about my experience with this forum is that I’ve realized that brilliant people have the same problems that I have and that beginners can sometimes solve problems that brilliant people are stuck on.

Thanks for sharing your experience.