Problems setting up LAN Client Mode


#1

Hi

Just got my Theta V about a week ago and having been playing around with it since. I have today tried to set it up for Wireless LAN client mode but I am having problems. When I create an access point as soon as I set the security to WPA/WPA2 PSK the OK button gets disabled and greyed out and does not get re-enabled when I enter the password - so how do I put it into LAN client mode?

Phone is a Galaxy S8 running version 1.19.2 of the Theta software. Theta V is running firmware 2.40.2.

Any help much appreciated.

Thanks

Pete
Theta newby


#2

If you have control of your router, can you set the password to longer than 8 characters, preferably over 12? I’ve heard of problems when the password was too short.

How many characters is your password?

OK Button Gray and Blue

The blue OK does not come on until the character count of the password reaches a threshold. I’m not sure what the threshold is.

it appears that the app is testing a few things before the OK button turns blue.

image


#3

Thanks for the response. Indirectly you have solved the problem…

My password is currently 17 characters long as this is longer than most I would hope that is sufficient. The SSID is 12 characters if that is relevant

I’ve left the settings dialog open for ten minutes now and the OK button was still grey.

I should have also said I have two access points, one running 802.11 b/g/n on 2.4 Ghz and the other running 802.11 a/n/ac on 5Ghz - I’ve tried connecting to both with the same problem on both.

But with connecting to my router to check the specs of the access points I remembered that it has a WPS function that is disabled by default, I had earlier seen you article about connecting using WPS so tried that and it worked.

So problem solved but not in the way I expected.

Thanks for you help with this - in both threads :grinning:


#4

@Pete thank you for your detailed report back on the problem and your solution.

It’s great that WPS worked.

Update 8/22/2018 I verifed that the password WPA-PSK password length can be 8 to 63 characters. Are you still unable to input the password into the Ricoh mobile app? If so, can you advice on the Android version you are running and possibly post a screenshot? We can’t replicate the problem.