Theta S Wi-Fi error

thetas
#1

My Theta S’s Wi-Fi suddenly stopped working with the Android app.
It has been working fine but, out of the blue, the app says that it “cannot connect to the camera, check the wi-fi settings”.

I tried on my cellphone and a tablet. Both say that they are connected to the camera. However, when I try to connect the app to the camera using that little button on the lower right screen corner it gives me the error message above.

I already tried resetting the wi-fi to no avail. Camera has the latest firmware.

Camera did not drop or got wet. Any hints?

#2

Just confirming, latest firmware is 2.50.1? What model phone are you using?

#3

Correct on the firmware. I used the Windows desktop to update the firmware on the camera, per manual instructions.

Phone is a Samsung S7 Active running Android 8.0.0

Tablet is a Samsung Galaxy Tab 2 running Android 4.2.2

Both were connecting fine a bit more than one month ago.

Camera was stored and when I tried to use it this past weekend it had the wi-fi problem.

#4

I don’t have this problem myself, so I don’t know specifically. But trying to be helpful.

My best guess is firmware, but it seems like you’ve got that covered.

Have you tried pressing and holding the power button for longer than 8 seconds? Here’s a post with details:

#5

Howdy! Sorry for taking so long. I’ve been cracking my head trying to find a solution for the problem.

I read to try putting the phone in airplane mode and use only Wi-Fi. It worked again!

Here are the steps I took that finally made it work:

  1. Put phone in airplane mode and enable only Wi-Fi. It connects normally and very fast.

  2. Restore phone’s normal connectivity (reconnect to cell service). Phone does not connect to camera. The app shows a spinning donut and never connects.
    a) If I connect the phone to the camera using the phone’s settings app it says it’s connected but it does not have Internet connectivity, which is expected and has always been the case.
    b) If I try to connect to the camera even with the phone saying it’s already connected, the app still says it’s not connected and asks to connect.

  3. Put it back into airplane mode with only Wi-Fi and it connects again.

So, it appears that something when the phone is in normal connectivity mode is blocking the camera’s connection to the phone. It seems to be something in the Ricoh’s app, since the phone does not complain about connecting to the camera directly, even with the cell service enabled.

This problem started after Ricoh started supporting the new camera models with the same app. I wonder if it’s something related about how the new cameras connect?

Confirming my camera and phone setups:

  1. Camera: Ricoh Theta S, Firmware version 01.90
  2. Phone: Samsung Active S7, Android Version 8.0.0
  3. App version: 1.22.2

Any thoughts of anything else to try?

Thanks much!

1 Like
#6

@Rossi, I’m also suffering from this annoying connectivity issue!
Interestingly, my camera and phone models as well as firmware and app versions are the same (except for using a standard S7, not the ‘active’ model).
Not sure whether this issue was introduced by an app version, an Android version or a combination of both.
My guess is that the connectivity is established on the Wifi level (AKA OSI level 2 data link) as indicated by the corresponding LED but fails on the TCP/IP level (AKA OSI level 3 network and above). Probably the IP routing is screwed so that the HTTP request from the app is routed to the wrong IP network resulting in a timeout.
Previously, the app could connect in parallel to the camera via Wifi and to the Internet via mobile data, enabling the upload of images just taken. This is no longer possible.
I really hope that the new Z1 will benefit from an improved software quality assurance …

#7

OK, well glad there’s a work around so you can use it in the meantime. I don’t have a similar Samsung phone, so I can’t test this directly. May try uninstalling and reinstalling the app?