Ricoh Theta V 4k low Hz in Unity

Hey all!

I am using Unity and the Ricoh tutorial with the Mothra sphere to provide 360 vision for my teleoperation project. While I get real-time and high FPS results with the FullHD driver, I get sub-par results with the 4K. I have upgraded the camera’s firmware to the latest and I am using Unity 2018.3.9f1. I benchmarked the results using AVPRO Live Camera Free trial:

I would really love to use the 4K if possible, so any help is welcome :slight_smile:

This issue also happens to me. I post this issue in Unity forum. But it still not resolved.

I think TouchDesigner or MPC-HC is faster than Unity.

But I don’t know how to make it faster in Unity… :thinking:

RicoB had more success with the script above.

See if it makes a differences.

You’re using the driver from the RICOH site, right? Not, the registry hack?

I’ve tried the same method as RicoB, and I’ve also used driver on the Ricoh website.

However, I can only get about 5-10 fps at 4K in Unity.

And the CPU Performance is close to 100%.

TouchDesigner and MPC-HC give a different result. I guess this is due to Unity’s WebCamTexture.

Multiple people on this forum had the exact same problem you are having. However, I was not able to replicate the problem. I do not recall a solution posted. Is it possible to run a test on a different system so that we can try and isolate the problem?

See the post below from @FirepadCN using cpu i7,gpu 970.

You could also try to DM @Tsikinator and @FirepadCN and ask them if they solved the problem.

FYI, the Mac version of Unity doesn’t need the driver.

I’ve already tested it on about 4 Windows PCs and I’m experiencing the same symptoms.

However, I was not able to replicate the problem.

Do you mean you can get 30fps on 4K Live Streaming + Unity?

If so, I’d like to ask you a question about your environment.

yes, we’re getting close to 30fps on 4K with Unity.

This driver

Primary machine

Second machine


Other people have the same problem you are referring to.

@jcasman demoed the setup in the RICOH booth at a few shows and several meetups. It ran fine for up to 6 hours.

This is the laptop we used for the demos.

Also, can you test it on a Mac? You don’t need the special driver from RICOH on the Macs.

I’m not sure what the actual source of the problem is.

Mmm, Thank you.

I tesed on MacBookPro(15-inc,2017). It got 20-30fps.

I want to keep 30fps…

I wasn’t getting 30fps all the time. The fps would vary based on CPU load.

You may be able to contact the people at TwinCamGo to ask about their experience. They are using a relay to get the video to Unity. In their setup, the camera is not plugged into the same computer that is controlling the headset signal.

For your Windows setup, the driver from RICOH may not be working properly on your system. As you tried it on 4 systems, the problem could be related to either the Japanese version of Windows 10 or the Japanese version of Unity. Occasionally, some string in a program causes problems.

We have not been able to identify the source of the problem.