SOLVED: Compass calibration on Z1 - figure 8 motions, reboots NOT WORKING

Editors Note

Based on this discussion, we created a video of the motion needed to calibrate the compass. It seems to work for people in the discussion.

Original Post

I have a two-month old Z1. The compass calibration error is on, and I’ve followed every guide I can find online to resolve it to no avail.

I went to Florida from Minnesota two weeks ago, and, although I can’t say for sure it happened then, it seems that the travel may have played a part in it, as I first saw the error while in Florida.

Now, back in Minnesota, I can’t resolve it.

Is there a hard reset or something that might help?

I just want an even horizon all (or most) of the time. I know it will still work, but I like it to work properly.


1 Like

Did you go through this thread?

Did you see the last post?

Try those first before trying a reset that will wipe your settings.

1 Like

Yes! This thread is where I started. Haven’t found really any other options. I’ve connected to the phone and app a jillion times with no change. Figure 8s of all sizes, orientations, speeds, and directions.

Does this plug-in (which will delete your settings) work with the Z1?

BTW, it’s a large figure 8, about 1 meter wide.

SOLVED. I was doing the figure 8 in front of me, on a horizontal plane, with no luck. Been trying many days, man, many times each day. Tonight I just grabbed the dang thing, started swinging it like a child whipping a doll around by its hair, literally flailing it in a VERTICAL figure 8…and in three seconds it was done. WHAT IN THE HECK.

1 Like

Solved the compass calibration issue and got in some exercise. Sounds like a win-win to me!

@jthorstad, thank you for reporting back on this. The information will help other people.

Although, I’m glad that you were able to reset the internal compass, it is unusual that you had to use large, rapid flailing motions. Hopefully, this overwrote an existing setting that was causing the problem. Most people can reset the compass with slower movements.

I suggest you keep monitoring the situation.

Unfortunately there’s no easy way to make the camera compass lose orientation.

The Z1 is an Android device. We may be able to look at Android information to help with this type of problem.

In the examples below, imagine that the Z1 is the phone. Inside the Z1, it runs Android on a Qualcomm smartphone hardware platform.


1 Like

This video shows how to recalibrate the Z1 compass. The compass recalibration section is at the end.

I thought I had tried everything - but I hadn’t tried THAT exactly. And that’s exactly what worked. That short clip at the end should be used to answer the official FAQ on this topic. When people say ‘a picture’s worth a thousand words,’ they’re really talking about a video like this. The illustrations just don’t do it. The verbal explanations didn’t help me either. One short video clip? Done! Wish I’d seen this earlier, but it was kind of buried. All’s well that ends well :wink:
Thanks, Craig.


First, thank you for the feedback that the eCompass calibration clip was useful. Our main goal is to provide useful tips. It’s great to hear what people found useful.

Also, thank you for the tip that we should pull out that tip into a separate video. I will do it now and repost here.

Happy New Year!


Just in case anyone else has this problem, I made a shorter video with just the eCompass calibration tip.

1 Like