Theta refuses to register on Theta UVC register

Thanks, it appears as I might have to do that. Sadly, none of my friends uses Windows any longer.

Silly question perhaps, but if I register it via a Windows computer, will it still work for Live view in a MAC computer afterwards? Is this UVC register program, just a program to register the Theta S, or does it install something on the Theta S also?

I just used Windows to “activate” it, afterwards I’ve been able to use it on different MAC computers

1 Like

What version of Mac OS X are you using? I want to try and get someone to test it with the same version. @jcasman did you upgrade your mac to the latest OS update? Does live streaming still work?

He’s having problems with the device registration…

Wow, this is new and important information. I didn’t realize this. thanks.

try to unzip attached folder and run the Theta UVC register app
from the RICOH (232.9 KB)
it is v1.04 for Mac
if it runs it is do to installation trouble

or waite for to morrow
What do you think @codetricity :slight_smile:

Windows Blender - VLC are chrashing here
VLC media player
2.2.4 Weatherwax
have send them a report
got the ansver
There was an error while transferring the data to the FTP server.
Thanks a lot for the help.

16-9 RICOH THETA S are running

VLC on OSX are running but it eats up the ram+swap (16 G)

VLC media player 2.2.4 Weatherwax

Hi @Svendus I’ve followed the installations instructions to the “T”, but I can’t seem to get the “Register” button to enable. Help?!

I’m using a macbook pro and have the the below:

Installed the latest RICOH THETA app
Installed the latest RICOH THETA UVC app
Restarted my computer
Launch the UVC app
Plugged the (Switched off) RICOH THETA camera
(nothing happens)
repeated the above several times… no luck
*Checked to ensure the latest firmware
*I’m running as an Admin on my MB pro

Do you have a THETA S or a THETA V?

Does the MacBook Pro have a standard USB port or are you using an adapter to convert the USB cable that came with the THETA to connect to your Mac? If so, try a different adapter.

@Bronson_Chan Hi be sure you have the latest Adobe Air installed
Regards Svendus

we are running Mac os High Sieera

1 Like

good point. that is probably the problem. thanks for the tip. :slight_smile:

if You for some reason have Adobe blocked in the firewall on a mac or PC it will not install automatically
when installing the RICOH THETA app :wink:

It’s a THETA S.

I’m not using any sort of adaptor to connect. It is connected through using
the cable that came with the camera. I

  • note that it detects the camera when connected (the power button will
    have a green light lit)

Do you know what version of Mac OS X you are running and what version of Adobe Air?

This article has information on determining your Adobe Air version

OS X El Captain version 10.11.6

I downloaded and installed Adobe air just yesterday so it should be running
the latest version (27.0 I believe)

Just doubled checked in the directory

I just recently bought a Theta V and also am having this kind of trouble, I did all the workarounds stated in this thread and also tried registering it on another PC and it still doesnt work :frowning:

Thanks for the extra info. It’s a little difficult for me to test this as I don’t have a normal Mac. I have a dual-boot Windows 10 machine that can also boot into Mac OS X. @jcasman has access to a normal Mac and I’ll try and see if he can run more tests.

Note that the THETA V and the THETA S use different drivers. For @Florendo_Holgado, the driver is the “THETA V” driver. For @Bronson_Chan, he needs to use UVC Blender with the THETA S. This is because the THETA V outputs the live stream in equirectangular and the THETA S outputs the stream in dual-fisheye.

The problems with the THETA V and the THETA S on a Mac may not be related.

I tried updating to the latest driver for Theta V and is now currently on 1.10.1, along with that I also downloaded the latest Adobe Air. Still to no avail, it’s very frustrating… I really need to use the live stream feature on our upcoming event :frowning: I hope someone who has a Theta V and has encountered this issue and gained a resolution can help out.

I think if you upgrade Your System to Yosemite, Sierra or Even High Sierra
you solve the problem.
All right the new look :eyes: in OSX migth be frigtening if you love the clacic look on El Capitain, but leaving all the bugs upgrading makes it easy to get uset to the new environment in the new better system :heart_eyes:

Regards Svendus