When turning on theta S, quadruple sound followed by red flashing light


My ricoh theta was working perfectly, but today, when pushing power button (charged ok at 100%), I ear a quadruple sound followed by red flashing light near the shutter button, and a few seconds after, all off.
If I plug it to the mac, no detection, power button do the same than unpluggued.

I tryed power button holded 10s > same thing
I tryed shutting button + wifi button holded, then power button > frontal camera/wifi/video flashing, red flahing near shutting button and no shutdown this time (keeps flashing). Sutting button doesn’t do anything. I can connect by wifi from the app, see pictures that are inside the theta, download them, but when trying to make a picture from mobile, i see the spinner capturing screen, but it stays like that without ending.

I have also tryed to restore theta with 8s power button > not solved the problem

I have also tryed to mount it as a unit on the mac, erase everyting (DCIM) and reinstall the firmware (firmwared correctly reinstalled) > same problem when turning on theta.

And I also tryed “erase” the unit with mac disk utility, and reinstall firmware. Now when turning on the theta, I have 2x a quadruple sound.

¿What can I do?

I bought it in may 2016, so it’s still under guaranty.

Hi @Yul0577
you are sure the theta is not set to interval shooting it might be the Shutter sound you hear?
sound volume can be changed and even shot off

Regards Svendus

The best course of action might be to call customer support and start down the path to a possible replacement. The main board in the THETA sometimes goes bad. As it’s still under warranty, this might be the best thing. The firmware on the board could also become corrupt or the filesystem on the internal SD card might have gotten damaged. The internal SD card is not desinged to be replaceable by the end-user.

Hi, thanks to both.

I’ve talked with support, and they confirm I tried all the possible, and the last way is to send it to their repair department, without knowing yet if it goes under guaranty.
Amazon, where I bought it, will send me a new item. Incredible service! :smiley: :slight_smile:


Nice to hear that about Amazon. Very cool.

Hi people, i try everything writing here but nothing.:disappointed_relieved: see my video https://www.youtube.com/watch?v=qiQQJgAYYDk&t=9s

How do you know it’s fully charged?

When you right click on the RICOH THETA S icon, what is the charge level?


yes, fully. last firmware update.