YouTube Spatial Audio Support Now Available

Thanks a lot for your valuable input Dr @Angelo_Farina I recently got my hands on the theta-V and the external microphone. I did a bunch of recordings and was never able to use the B-format audio for any of my audio research work. Without the specifications from Ricoh regarding the audio format they are using, it is kind of impossible for newbies like us to decode it. Appreciate your inputs here and I am a great fan of your research work in spatial audio.

Also thank you @codetricity great support so far, hope the concerned people push out the updates soon.


Blockquote This could be the possibility to record an MP4 or MOV file with the
4-channels soundtrack already available, and with proper metadata injection
for Youtube, without the need of the additional passage through the Movie
Converter app, which looks to me as a temporary solution.

It would be great to have the Theta desktop application stitch a “ready to go” file for uploading to YouTube with the spatial audio intact and in a format most NLEs can recognize. Batch stitching is already possible with the Theta desktop app, but having to manually drag each individual clip to the Theta movie converter is less than ideal.

I am not so worried about having to drag-and-drop each MP4 file into the Movie COnverter app for having it converted to a.MOV file with 4-channels spatial audio. What concerns me is that the resulting MOV file has wrong chsnnel order and wrong gains (as I have explained above), hence the file is not “ready to go” for Youtube, it requires to be adjusted employing Audacity and then FFMPEG for packing back the corrected soundtrack with the vidoe track. A long, tedious work, where it is easy to mess up the soundtrack!
I would be content if Ricoh just fixes the Movie Converter app, so that the resulting .MOV file is correctly channel-ordered and gain-scaled.
Of course, if this functionaity will be already included inside the main Ricoh Theta S stitching app it would be even better, but not so essential…
Correctenss rules over intergration. A correc workflow in two passes is preferable to a wrong workflow in one pass!
So please, first fix the problem of channel ordering and gains, and only when this is fixed you should worry about integrating the Movie Converter app inside the main Theta S app.
Then there is the problem that both the main Theta S stitching app and the driver for live USB streaming do not work with Windows 7 64 bit, with currently is still the OS employed in the vast majority of prefessional and research environments…
And finally there is the problem that during USB stremaing only a mono soundtrack is captured, whilst of curse one would expect to get the complete 4 channels of spatial audio also during realtime streaming over USB…

1 Like

It’s been a month since this has been reported and still no update from Ricoh.

I feel sad at all the “wrong” videos being posted on YouTube and all the extra effort to manually fix the problem.

Any hope we see a fix before the end of the year?

Ricoh just announced plans to improve spatial audio in a firmware update this month. Thank you to @Angelo_Farina for providing so much great information on how to improve spatial audio. Also, thanks to Ricoh for taking the valuable feedback and making an improvement that everyone can benefit from.

The following issue have been reported using “360°spatial audio”

  • The effect of 360°spatial audio weakens when using 3D microphone, TA-1
  • When the 360°4K video using a movie converted app, “RICOH THETA Movie Converter”, for YouTube, is posted,
    the effect of 360°spatial audio might become weak in some cases.
    The problem is to be solved with the firmware and application update which is scheduled at the end of December.
    We apologize for any inconvenience caused and thank you for your understanding with this matter.

The firmware update 1.20.1 and Movie Converter 2.0 is now live!


Thanks for posting, you’re quick!


Thanks to people from the community like you and @Angelo_Farina, we were able to pass some great test information to Ricoh. I’m glad that the Ricoh engineering team were able to work with the community to improve the camera for everyone.

Please let me know how your tests go. :slight_smile:

I have a TA-1 and I’ll test the camera with and without the microphone as well.

1 Like

I did one short clip using the Theta Movie Converter 2.0 and it worked great.
This morning, I tried it on a 5.58 gig file (about 13 minutes long) shot with the latest firmware update and it throws a “unsupported file” message when attempting to convert it.

I guess the size of this clip is causing problems with the Theta Movie Converter. After much frustration, I stitched 2 versions with Theta desktop app, one 4K version and one 1080 version. The 1080 HD version worked with the Theta Movie Converter. I am going to combine the audio from the 1080p version with the 4K video track.

Thanks for this test. I’m going to try and replicate this myself as well as ask a guy I know at Ricoh if he’s heard of this problem before.

Appreciate the help with the testing.

1 Like

I wonder if this has anything do with FAT32 file sizes etc.? (I’m using a Mac running 10.13 High Sierra so it shouldn’t matter?). I just tried it with a clip that was 4gb in size and the Movie Converter 2.0 processed it with no issues.

Since most of my recordings never get beyond much past 4 gigs I have never encountered this issue in the past.

I’'m gong to restitch the problem file with the new Theta Desktop app 3.2.2 and see if it makes any difference. Update: Nope. Anything larger than 4gigs seems to flummox the Movie Converter.

Did you use the Mac File transfer app for files over 4GB?

Yes, I did use that File Transfer app. Weird since I normally copy over directly using the Image Capture app in Mac OS X.

That large file needed to be transferred with that app so the Theta Desktop app will accept it for stitching.

So I have the latest firmware: 1.20.1
Latest Theta Desktop App: 3.2.2
and using the Theta Movie Converter 2.0

I stitched the video clips with the desktop app and then tried to convert with Movie Converter 2.0

Files that are 4 gigs in size convert correctly with no issues.

The files that are 5.6 gigs in size or so will not be accepted in Movie Converter 2.0 (Unsupported File)

If I downscale to video file to 1080, then the Movie Converter will work as the size is much smaller.

I’m running Mac 10.13.3 High Sierra
on Mac Pro 5,1.


The firmware update is glorious though. My wife video’d kids school concert and the sound of built in mics is superb. (This is 13 minute file where I had to extract audio from the 1080 version and matched with the original 4K video.)

Hi I’m trying to edit my videos in MAGIX Movie Edit Pro Premium Version number then put the spatial audio back in using RICOH THETA Movie Converter Version number 2.0. I export as a 360 mp4 but in setting it only option is stereo. and then i put it RICOH THETA Movie Converter and then its crashes. i’m on windows 7. can anyone help me with this.

Tim Harding

Hi Tim,

I would first convert the clips in the Ricoh Theta Movie Converter before importing it into your NLE for editing.


Hi John
Thank you for your reply. I have tried using the Ricoh software before the Magix software and vice versa. But I either get 360 mp4 video in Stereo Only, or I get a Flat M2T (not 360) video with “surround” sound, which is not Spatial Audio. Please can you tell me what NLE is, and any further information on what I am doing wrong?

Thanks Tim

I use Final Cut Pro X and it will see the 4 channel audio tracks in my project after the converting the clips with the Ricoh Theta Movie Converter.
Final Cut Pro X doesn’t currently export or share a movie file with the spatial audio tracks to YouTube.
I have to manually export the video track, plus each audio channel track.
I then use Audacity to combine the 4 tracks into one multichannel AIFF file.
I then combine the Video Track and the new multichannel AIFF track with FFMPEG.
The combined movie file will now need to have metadata injected using the Google Spatial Media Metadata Injector Tool before uploading to YouTube.
Here is my workflow (more or less)

Hi John
Thank you for the video in your reply. but for some reason Magix still only seeing 2 channel, photos of Magix properties attached I tried contenting Magix about this before and didn’t do anything, is there any other way for the spatial audio to work.


What is your workflow?

I copy the clips straight off the camera and then stitch the raw clips using the Theta Desktop app. Once that is done, I use the Theta Movie Converter to convert the clips.

If you look at the properties of the converted clip before importing into your editing program what does it say?
The object properties above screenshot you have? Is that Windows? Or is that inside Magix?

Does Magix support multi-channel audio? Does your project properties need to specify that you are working with a multi channel - tracks?

That was on Magix. but here the windows properties.

I look at my properties the spatial audio file from RTMC does not have info but the RTB has???
I tried a 2D video with 5.1 output and that work in multi-channel audio.