FIXED: THETA iOS (iPhone) App 2.12.0 is not working - upgrade to 2.12.1

Moderator Note: Scroll to the end of this topic. You need to upgrade to mobile app version 2.12.1

On the current IOS on apple XR, the newest Theta app will not work. It opens to the Theta splash screen then freezes and then crashes.

This is crippling us as we use this to create VR tours and without the app, we cannot control the camera remotely.

1 Like

App worked the first time I opened it, then stopped working with no changes to the phone. Tried to delete then upload the app a few times. Tried shutting the phone off and on a few times. Tried resetting the phone to factory specs. The app opens with only a black screen and the Theta logo and “Theta” written under it. No lower controls.

Are you running the most recent camera firmware?

I have exact same problem on iPhone X.
It simply stopped working yesterday. Tried everything…no success. It start loading up and just shut down.
Did you fix it?

I am having the exact same problem. Iphone se. Turned on theta and app just shows logo on black for a while then closes. The phone and camera both say they are connected and I used them recently and have made no changes to either. I upgraded the firmware this did not help. I am totally stuck and am supposed to be using it tomorrow for work. Help!

Just to confirm, you’re using the new mobile app that just came out yesterday?

Just to clarify the limits of this forum for new users. This is a community forum and not managed by RICOH. We don’t work for RICOH, but we do receive some sponsorship for this site.

I borrowed my wife’s phone and was able to test iOS 13.4.1 with RICOH THETA app version 2.12.0 with a RICOH THETA SC2. The app is running normally in my tests.

I suggest that people try and contact RICOH official customer support and report the problem as there may be a bug in the mobile app that the team at RICOH doesn’t know about.

Personal Tests

I was using Theta app successfully for weeks with Z2.
Suddenly app can not be opened…

I rebooted the iPhone X, I have deleted the app and reinstall it again and it still does not open.

I also upgraded OS from 12 to current one and still no success.

Also camera has the latest software, but this has nothing to do with the app.

Can you help me out please?


1 Like

I don’t have an iPhone, but I know someone that does. I’m assuming you’re running iOS 13.4.1? This is the newest one that Apple put out in the last few weeks

The problem started before I upgraded to the latest OS.

I consolidated three topics into this one topic to make it easier for people to share information.

Here’s a summary of points:

  • @jcasman and I don’t work for RICOH. If you need official help, the best source is RICOH Imaging Customer Care
  • I can’t replicate the problem with iOS 13.4.1 and the official RICOH mobile app version 2.12.0.
  • I don’t own an iPhone and borrowed my wife’s phone. I think it is an iPhone 7

There were a bunch of settings that came up as pop-up windows when I started the app. There was a popup menu to give the app permissions to “photos”. Maybe the app needs permission to “Photos” to run?

Same Problem… black screen with Theta Logo… After a few seconds App crashed.

The Theta app won’t launch for me either.

iPhone X
Latest iOS 13.4.1
Latest Theta 2.12.0

I have tried re-installing the app and rebooting the phone.

It will launch, show the splash screen, ask for bluetooth and location permissions and then after a short delay will crash. Same behaviour whether I am connected to the camera via wifi or not.

Yes on IOS 13.4.1

Yes the newest Theta app is installed.

Reset phone.

Removed and reinstalled theta app.

set all permissions on app for location, photo access etc…

uninstalled ALL other apps to make sure no conflicts

nothing is allowing theta app to work. So frustrating when I need this to complete a paid assignment.

Sent theta support messages and no reply in 3 days.

i now own a £900 paperweight, updated all the latest firmware from Ricoh for the Theta Z1 and the latest iOS update a few days ago, Z1 can connect to iPhone as it should , the Theta App (latest version) starts and shows a logo/black screen then shuts down after a minute, no control no ability to use the camera…
Have emailed Support but by the looks of this it’s a bug in the software,

1 Like

Same problem here - Iphone X running 13.3.1 IOS, Theta V with the most up to day firmware. Worked until today, freaking out because I have to 360 tours to shoot tomorrow!

A friend called Theta and got this response:

Yes!.. So i actually calles theta and these are the two fixes

  1. Turn the theta on, connect it to the wifi on your phone, BEFORE** starting the app.

  2. Turn theta on. Turn GPS on. DONT connect wifi. Start the app and then turn om the wifi.

Number 2 works for me everytime. Good luck!


Thank you for posting the solution you’re using. Hope it helps others in the community!

1 Like

Hi, folks.
It perfectly works on my THETA Z1(firmware version: 1.40.1)

THETA Basic app for iOS ver.2.12.0 running on iPhoneXR(MT002J/A) iOS13.4.1.

Also works Dualfisheye Remote app.

Remote app for Android ver.1.3.1 running on Android Phone SH-M12(9 Pie/01.00.05 build).
Dualfisheye Plug-in ver. 2.6.1

Hope this helps.

1 Like

Not helping here. Thanks for the tip. Perhaps it will work for some.

All smart devices have been updated to 13.4.1.
Theta app firmware is v 3.30.1.

After about 10 seconds, the app crashes; on iPad and iPhone.