Theta Z1 & Theta V Live Streaming Issue on MacOS Monterey

Hi All.
I have just upgraded my MacBook Pro to OS Monterey. I have a Theta V And Z1 both are up to date with firmware. I use them both for live streaming. I am familiar with both camera and have reset them both. They have been working perfectly until I upgraded to this new operating system.
The camera source on both cameras are no longer showing up in either Wirecast YouTube or Vimeo Live?! Before the upgrade both cameras did show up. The thing is that the audio source from both cameras are showing up, yet the video source is not on all mentioned software and web sites.
Has anybody else had issues with this and can anyone help me to resolve this issue that I am having.
Ive added 2 screen shots and as you can see the audio source show up yet the video source does not yet all my other cameras are.


Does the THETA show up as a device in Quicktime?

Hi Craig. Thanks for your reply. I just tried it and the camera source does not show up in QuickTime as well as all previously mentioned, yet the audio source does?! (screenshot attached) All my other cameras are working fine.

Failure of Streaming with MacOS 12.0.1 (Monterey)

Test Environment

  • 2020 MacBook Air with Apple M1 chip
  • MacOS 12.0.1
  • Z1 with firmware 2.01.0
  • direct connect between USB-C port on Z1 and MacBook
  • Z1 is in live streaming mode
  • used both QuickTime and VLC for the test

Procedure Notes

  • rebooted Mac
  • unplugged and plugged in USB cable
  • switched mode on Z1

Results

Z1 does not appear on Mac as video device

image

image

image

Same problem after rebooting Mac.

Must need a firmware update?!

I think I’m running the newest firmware. I’ll collecting the info to report back to RICOH.

@jcasman , can you test the Z1 live streaming on a Mac?

Windows 10 Testing for Comparison

I tested on Windows 10 for comparison with the same camera. Live streaming works.

Possible Workarounds

@biviel , Does your plug-in work to stream to YouTube? is there still an audio issue?

I’m also facing the same issue after upgrading to macOS Monterey. I have a 2019 Macbook Pro 16’’. I tested the Theta Z1 with direct USB-C 3.0 cable plugged into the laptop and setting Theta Z1 in live streaming mode. Theta Z1 is not showing up in the system information panel as a camera and all software I used for testing cannot detect the camera.

The Theta Z1 is running the latest firmware and I’ve tested 3 Z1s so far and all having the same issue. Softwares I tested include OBS, Facetime, and OpenCV.

This post might be related: UVC cameras not working on M1 Pro … | Apple Developer Forums

Thanks for posting that. It seems that all UVC cameras may have problems with MacOS Monterey. On your system with the 2019 Macbook Pro, have you tried it with a standard UVC 1.5 camera like a Logitech C920 (most newer cameras are UVC 1.5)?

UVC cameras not working on M1 Pro … | Apple Developer Forums

I just tried a Logitech Brio camera with direct USB-C 3.0 cable connect to my 2019 Macbook Pro and it worked well. It shows up in the system information panel as a camera device and Facetime, Zoom, OpenCV can all detect and open it.

Thanks for testing this. I’ll ask @jcasman to test the Z1 live streaming on a different Mac.

hi, Craig,
I’m working on the update of plugin, it will support live streaming to Youtube , Facebook, any RTMP and RTSP server. And audio will also work fine with youtube. Will release the updated plugin soon, hope next few days will send to Ricoh the update.

Also it will solve majority of heating issues too… or at least triple streaming length in warm room temperature.

This is the plugin that I will update soon:

1 Like

You managed to fix the audio problem?

There was a long discussion of the problem here:

Wireless Live Streaming Plug-in Audio Problems

The Wireless Live Streaming plug-in from RICOH still has this audio problem, right?

Yes, Craig. It will produce good audio, I’m still doing some optimizations, but for sure will be able to stream to youtube, facebook with RTMP too fine. Also h265 streaming to any RTPS server will work and I improved streaming length/heat issue, actually it should be able to stream more than an hour from a warm room. In RTSP even longer, for hours without any cooler.

Only issue is now that FPS is slightly below 20, around ~16/17FPS when streaming to these platforms with in camera stitching.

1 Like

Amazing progress. Congratulations!

Thanks, Craig! Will let you know once it’s sent to Ricoh to update the plugin.

2 Likes

OK. In the meantime, @jcasman and I will report the problem streaming over a USB cable with MacOS Monterey to RICOH.

Thanks and please let me know when a fix for this arises.

  1. i have added this to an agenda for a meeting @jcasman and I are having with a RICOH manager tomorrow (Tue 12/7)
  2. I checked on the news site for theta360.com and there doesn’t seem to be a new firmware. Likely, any fix will be posted there and made available
  3. I’m going to try and test MacOS Monterey with different webcams

Well Craig. I can let you know now that all other cameras that I have works with Monterey and that includes Logitech Brio, Logitech 920, Sony A7111, Canon D80, I also have a Mevo wireless camera and a Panasonic video camera and they all work fine, yet my Theta V and Theta Z1 are the only ones that do not. I have 2 MacBooks 2017 and 2019 running Monterey and I have tried the Theta V and Z1 on both and I only get audio and no video source on YouTube Vimeo Live QuickTime Player and Wirecast. I don’t use social media so have not tried them there. From my understanding I believe they both urgently need a firmware update. As both cameras are non functional at the minute. I bought these cameras for the spherical live view as I specialise in live streaming Dj and it gives a good effect.I really do appreciate your help and time in trying to help resolve this and I look forward to a fix ASAP :pray: image|690x318

Thank you for the detailed testing report. I have copied your post into the meeting agenda and have linked to this discussion. Hopefully, @jcasman was able to test the live streaming as well as it will help to explain the problem during our video conference.

@LongmanLuke the sound in the Wireless Live streaming plug-in may have been improved as well.

Notice of RICOH THETA plug-in upgrade | RICOH THETA


After more testing, I think that there may be a new incompatibility between the Z1/V and the MacOS Monterey, including 12.0 and the next version macOS 12.1 (in beta). To me, it does not seem like there is an easy fix that would happen soon.

If I needed streaming on macOS, I would consider a downgrade to Big Sur temporarily. Is this feasible?


This is the official announcement from RICOH.

Problem – Not recognized as a camera under live streaming mode on macOS 12 | RICOH THETA

The following problem has occurred when using a RICOH THETA on Mac.
– It isn’t recognized as a camera when connected by live streaming mode.

macOS 12 RICOH THETA Z1 51GB RICOH THETA Z1 RICOH THETA V

We are currently investigating defects.
We sincerely apologize for any inconvenience this time.

The problem still occurs with MacOS 12.1

1 Like