Have ricoh theta v and when trying to use the movie converter or stitcher it gives error on Windows

I’m struggling trying to use my mp4 files to be converted. I have tried using the latest software for the Theta Stitcher but it gives me an error. Files are in unsupported format, they are mp4. So I tried the theta movie converter dragging the file onto the icon on my desktop and same message they are in unsupported format. I bought subscription for Adobe Lightroom classic but they are still in fish eye format that cannot be used.

Are you using the software here:


The Theta Stitcher is used only for the DNG RAW images from the Z1. The free desktop app can stitch the THETA V video files. You don’t need Adobe Lightroom Classic for the V.

Also, I think you can set the V to stitch the video inside the camera.

You can set this API with the free mobile app from RICOH.


It will stitch the video inside the camera, so you don’t have to use an external software in the future. For your existing video files, use the free desktop app above.

Thank you Craig, the stitcher was not working but so far so good on the download for PC it’s actually working and converting files for me now. Will update if I can use the videos after this.

1 Like