Having issues connecting Ricoh Theta Z1 to file transfer app on Mac Ventura

I cannot connect the Ricoh Theta Z1 to mac for use with large file transfers. Running on Mac Ventura M1 Chip. Any tips or tricks to get this to work


Are you using the File transfer app. I’ve used it on an M1 chip Mac and didn’t encounter problems with the File transfer app

Download | RICOH THETA

I am, it doesn’t even recognize a device attached so what am I missing?

Post the firmware version of the Z1 you are using.

If you cannot update the firmware with the Desktop app, you can try the mobile app.

Use the USB cable that came with the Z1. Try a different USB C to USB adapter. You may have a USB hub attached to MacBook. Try a different hub.

Most current version of firmware, file transfer app and a basic app, updated all of them yesterday! Used both the original usb cable, different usb cables, with hub and without hub. I can use image control and Lightroom to see the files however when importing using those routes all large files seem corrupt and while not open in basic app. Even tried to import through smartphone and airdrop and still no progress. At this point I assume these files are done and am trying to avoid the issue in the future

Is this a new camera? If so, have you tried the RICOH official customer support?


There are also several Facebook Groups for RICOH THETA. You may be able to get additional community help.

Someone here may be able to help.

I normally use Windows and don’t have a Mac with me right now.

No sir about two years old! Never had an issue using smartphone and smaller files, this was a first attempt at large files with extended video record times. I use the camera daily as part of the iGUIDE virtual tour system and separately as well!
File size is 7.1gb and video run time was 17:35 minutes

try using a cable rated for USB 3.0 (5 Gbps) or better speed, most charging cables are only USB 2.0 (480 Mbps) speed which may affect transfer of large files from camera

1 Like

Having the very same issue and it’s driving me nuts. I’m wasting so much time trying to sort and my client is getting impatient to receive his files… Ricoh, really!!

1 Like

Same problem here with a Theta X and large files.
Did you find any solution?

If you are on a Mac just use Apple Photos, it recognizes Z1 and click delete after import.
Mine sometimes doesn´t work either.

1 Like

Same here.

Firmware: 3.10.2

RICOH THETA File Transfer for Mac v1.2.0

macOS Ventura 13.6.1
Apple M1

If you are on a Mac just use Apple Photos, it recognizes Z1 and click delete after import.

This works for me though

Yes. In Germany the App from Apple ist called “Digitale Bilder”. Also works for me with newest MAC and 14.2.1 on the MAC and 3.10.2 on the Z1.

What is really crazy and I don’t know how to fix this is that if im taking longer Videos with my Z1 it shows them also but only with 4,29GB in Apples “Digitale Bilder” (which is “image capture” in English).

People in others forums people said it has to do something with the format of my ssd. Maybe someone has the same issue and got it solved?

At the Filetransfer for Mac App from Ricoh my camera is also not shown.


Upgraded to Sonoma and found Theta File Transfer not working like it always did before. Found this thread to research. Then tried the Image Capture app included in the Mac Sonoma system and it works perfectly, and faster than Theta File Transfer used to, and with larger thumbnails. Works great.

Reboot your computer and launch the app Ricoh Theta File Transfer before anything else, works 100% time for me, i am on a Mac.