HELP! THETA Z1 Error (5x beep + Error Triangle)

Hi, my theta Z1 suddenly won’t boot, it beeps 5x and shows error each time i tried to power it up. The camera always works fine before, never dropped or any single accident ever happen.

Tried holding the power + wifi button to reset it, worked once, the camera turns on and works fine. But a day after, it suddenly shows the same 5x beep and error. Tried to reset it once again, but it just won’t work this time.


  1. This happen after I use matterport for capturing 360 photos, I’m not really sure if the error is related with matterport. Never experience any errors before I use matterport capture.

  2. I’m still able to access the storage if I plug the camera using the usb cable through my computer, the green light stays on.

  3. I’m able to access firmware update menu from the basic app, as well as the plug in menu (can’t do a firmware update, mine uses the latest 1.50).


1 Like

I’m having the same issue, just got this camera yesterday.

Had the camera a week before receiving the error… is there a way to factory reset with key press combos?

Same thing happens to me. Both on Matterport and Zillow. Both on my iPhone and iPad. Both on V and Z cameras. I thought maybe it was an overheating issue. I am shooting a shot about every 11sec, but it happens randomly during the shoot. I look forward to when the company will reply and acknowledge the issue.