Live Streaming - Discover the Sea ROV - Wi-Fi from THETA V

Does it work with a normal router that is not your mobile phone?

For example, can you use Client Mode from the router in your house and your mobile phone finds the correct camera when your mobile phone is connected to the router in your house?

Did you configure the password for the camera as just the digits of the serial number?

I think that you are missing a step in the client mode setup.

If you can connect it to the router in your house, you can at least verify that you are using client mode correctly.

Once you connect the camera to the router in your house and you know it is working, then try it again with your mobile phone.

Can you take a picture of the camera body with the Wi-Fi icon on the camera as solid green and post it? If it is not solid green, then you are not in client mode.

Is it solid GREEN like this?

image

NOTE: This is not a solid BLUE Wi-Fi icon. It needs to be solid GREEN.

Good morning Craig, thanks for your follow-up … really, thank you very much … no, it is not fixed … I am going to test with the home router to see if it connects in client mode … it stays blinking in green but or it manages to pair … after a few seconds it reconnects through normal wifi … it stops being green to be blue, it blinks and it connects to the camera’s wifi and it remains solid blue. Yes, I use the camera password, the serial number without the letters … 00244255 … but it does not connect, it tells me that it does not recognize any camera and reminds me that only some of them can use the client mode via lan.
I’m going to test my home router to see if it pairs. By the way I have two thetaVs and I have tested it on both and the result is the same, that rules out any camera problems.
Thank you again and I will inform you of how the test with the home router has gone in a while … greetings

as soon as I solve this problem, I will tell you about the project that we are in now … we work with ROVs in an environmental project called Discover the Sea. We have already used the camera for underwater dives and the result is very good but now we are trying to go a step further … use the theta directly with the ROV, that is, that the camera is transmitting directly to the ROV control and it is the one that provides us with the direct view … we try to make the connection with a rapsberry … but that after solving the client mode … let’s see if we can do it today … thanks and best regards

What firmware version of the THETA V are you using?

Have you connected to the THETA V in AP mode first to configure the Client Mode settings?

image

Go through this guide and post the screenshots from your own configuration so we can try and spot an area we can help.

If you have a Raspberry Pi controller on the ROV, you may want to use the Raspberry Pi for streaming.

This article may be interesting.

Especially, the reference to fulldepth.

Example 1 - FullDepth using Raspberry Pi to live stream from underwater


Example 2 Hugues Perret FOX Sewer Rover

image

Low latency (0.4s) H.264 livestreaming from Theta V WiFi to html5 clients with RTSP plug-in, ffmpeg and Janus Gateway on raspberry Pi

image


Example 3 - Lockheed Martin Amelia Drone

Successful Theta V stream from drone to VR headset 0.25 miles away

Neat that you’re looking to use it in an ROV! I’m actually planning on building a rig to use mine as an underwater camera at some point - not on an ROV but just one that hangs by a wire for scoping out fishing grounds. My plan is to pick up a dive case and then 3D print (and sand and seal) an enclosure that will replace the end cap of the housing. I’m planning on using USB as wifi underwater can be tricky! Going to either use a Pi4 or a Jetson underwater (with additional sensors for direction, depth, water temp, and possibly in the future dissolved oxygen content), then ethernet over powerline to the surface (so the tether can provide both data and 12v over a pair of wires), with another Pi4 or Jetson (or just a laptop to start) to record, decode and display the signal topside. Hoping for under 1s end to end latency, but we’ll see.

Do you know that wifi will work for your planned use? Might be worth considering usb; it means that you can’t just use the straight dive housing, but guarantees a reliable connection and also lets you power the camera externally…

1 Like

For the wifi client issue – I should also mention that the client mode won’t allow me to enter a wifi password that contains a space, at least with the Android client. If you have a space in your password, try changing it to something else.

1 Like

Hello again … with the router if it has been connected in client mode and I have been able to access the streaming plugin … I have not tried the direct one but the streaming configuration web seems correct. Now we just need to see how to do it with the mobile … I will try to put a longer name in the ssid and the password also to see if any protocol needs more differentiation … I will do another test … to take a second mobile, same model and brand, and I am going to turn it into an access point so that it is not the one used for the connection with the cam to see if it connects in client mode … I will inform you

What you share is fantastic … the idea is to create a module separate from the ROV’s operation but that is integrated so that thetaV is the eyes of the rov … the problem that I have not been able to solve is how to make the union to receive the 360 image on the surface … I suppose to put the plugin on the pi but I still don’t know how to implement it … any ideas? thanks for the contributions and help

I do not have a good experience with the usb … I have made several live shows with that method and always with charging problems, it consumes faster than it loads, and in a live where you have to have everything ready 10 minutes before the usage times … for something fast if it is feasible for something that lasts more than 20 minutes you risk it turning off. I have even tried with lan like the example that Craig did, I can poenr the link, with ethernet cable and usb with load, but the same problem … it consumes faster than it loads. In the rov I have already tried with usb directly and I get an image but without sewing, two spheres
My idea is to do client mode with Wi-Fi at the pi and control the direct from the surface so I leave the port free for continuous charging.

The Z1 can stream indefinitely over USB at 4K with the following conditions:

  • Z1 firmware 1.60.1 (newest)
  • USB port it is plugged into needs Battery Charging 1.2 specification

Using a cheap inline power meter, verify that the USB port is sending 600mA to 900mA to the Z1. It needs to be over 600mA. Most USB ports can only push data and 500mA while the data is in use. The Raspberry Pi needs an inline powered USB hub with BC 1.2 to charge the Z1. This won’t work with the V. It does work with RTSP plug-in and Ethernet and can stream indefinitely from the V. With the Z1, the USB port won’t charge while the USB OTG Ethernet adapter is plugged in.

perfect Craig, a year ago I started with the Ethernet system for streaming with 5 cameras but I could not maintain the indefinite load with the V. Very good contribution on the Z with USB to Pi … I have not used the Z yet … with the V for streaming with external audio input … but it would be a solution to make the connection with USB in the ROV, I will see more deeply the Z

nothing … I have tried in various ways but I manage to do client mode with the mobile access point … I have also tried it with another independent mobile for the open access point but it has not been linked either … to try with another mobile than Xiaomi

Are you using a y-splitter?

http://theta360developers.github.io/community-document/live-streaming.html#_ethernet_rtsp_streaming_direct_to_computer

At 4K, the THETA V overheats. With fan, tested for 10 hours streaming straight. Without fan, tested at 27 hours continuous streaming at LOWER resolution.

Write down bullet points for your test configuration in as much detail as possible:

  • camera model, firmware
  • plug-in name, version
  • mobile phone model, OS version
  • 5GHz or 2.4GHz (can be set on both the camera and the phone)
  • confirm you can connect from your mobile phone to the camera with Access Point mode (the mode where the Wi-Fi icon is blue). This will help to identify if the Wi-Fi channel or frequency is problematic
  • Confirm you are starting the plug-in from the mode button on the physical camera body, NOT from the official mobile app.
  • does the green Wi-Fi LED ever turn solid green?

NOTE: When the phone is the hotspot for the camera, you can’t connect to the camera with the official mobile app that is running on the hotspot. This is a problem with the official mobile app. However, you don’t need to connect with the official mobile app to start the plug-in.

Update 3/10/2021 afternoon

I tested the Z1 with a hotspot and it worked fine with no problems.

  • Z1 with firmware 1.60.1
  • Android - Google Pixel 2 running Android 11
  • Wi-Fi 2GHz

Tip: Do you have the camera in Developer Mode? If so, attach Vysor to the camera and see if there is an error message on connection.

theta V camera latest updated version. Wireless Live Streaming add-on latest version. MI8 Android 10 phone. I have tested with 5ghz and 2.4ghz. If you connect the camera with the mobile with the access point, blue wifi. I have also managed to connect client mode with physical router. When I complete the client mud settings I press the camera button for a few seconds and the Wi-Fi symbol starts to flash green. The mobile loses the connection with the camera. The camera keeps searching for the Wi-Fi connection, it blinks green. I restart the phone application and when I can’t make the connection through the camera, I try to do it from the mobile phone, at that moment I get the message that the camera is not found and that maybe it is not compatible … the blinking of the Green wifi turns off and the blue symbol starts to blink … Yes, I have managed to do client mode through the router and if the green LED was fixed, I could also control the camera from the mobile in client mode. I still have not managed to do the client mode with the mobile

If your phone is the hotspot, you can’t use the mobile app from your phone.

ok I supposed … that’s why I tried another mobile with the same access point and it didn’t work either. furthermore, the camera never connects to the access point … the green led blinks until it turns off …

It seems like you’re doing everything correctly. I can’t replicate the problem with my phone and camera. I can use my phone (Google Pixel 2) as the hotspot. However, it’s possible that it doesn’t work on all phone hotspots.

Although it’s not working, you can at least feel that you really tried the best you could. If you have it working on the Wi-Fi router, it should work on the mobile phone hotspot. We’re stuck at the moment.