No Longer Working: THETA V with Ethernet

The Z1 loses charge with the USB adapter. You can’t stream it 24x7 or maintain it for long periods of time with the WebAPI over Ethernet with the adapter.

The best solution is to connect the Z1 to a small computer like a Raspberry Pi and connect the RPi to Ethernet. If you post more details on your use case, we can provide more opinions on options.

Hi Craig and thanks for the reply. If I used a ‘Y’ splitter cable with a suitable power supply as suggested would the Z1 keep charge? Do you know if USB/Ethernet adapters work on the Z1 at all?

My use case is to install the Z1 in a lab environment and allow developers to remotely access it. For that I’d need it to be accessible 24/7 (though only streaming for a few hours at a time) through the API and Ethernet allows a much easier connection. WiFi would be 2nd choice. Interested in your thoughts.


I have tried 3 different Y splitter cables with the Z1 and the camera loses charge with ethernet. Ethernet did work with earlier firmware. I have not tried with 2.00.1.

Connect the Z1 to a Raspberry Pi or Jetson Nano with a USB cable and allow them to ssh into Raspberry Pi to use the USB API. 11 video playlist on USB API. First video in list will give you an overview.

The Z1 streaming over Wi-Fi is motionjpeg and is limited to 1920x960 @ 8fps or 1024x512 at 30fps.

You cannot control the USB stream with the WebAPI (OSC API)

Please advise:

  1. where is the stream being displayed? Do the developers need to see the stream? Is it being displayed locally on a computer with desktop sharing?
  2. What is important for the requirement: latency, resolution, framerate.
  3. What is the slowest framerate usable? Can you use still images? Or, does it need to be a stream?

If they can use still images, then connect to a Rasbperry Pi and use the WebAPI.

If they need a stream, please post again as there are different considerations.

2 posts were split to a new topic: Question: RICOH Official Support of USB-C Ethernet Adapter in THETA X?


I just wanted to inform you that I tested THETA V with FW 3.81.1, REALTEK USB208B network adapter and RTSP plugin. I don’t have yet the splitter to check the charging state but the lights are on and the camera streams successfully. The latency is terrible, about 2sec,


Thanks you for this report! I wonder if the Z1 works as well too now.

The advantage of the V was that previously, the power supply also worked.

The latency was low before. I will test it again next week after Thanksgiving. I don’t have a V with me right now.

that adapter is a LAN->USB A adapter at the end right? So you just used a USB A to USB C charger cable to attach it to V?

@craig ,
for power supply you had to use an Y cable, could you please share a photo if you have it nearby? Thanks!

RICOH THETA Live Streaming



The THETA V uses microUSB, not USB C.

The Z1 will likely lose charge.

1 Like

thanks for sharing!

A question: that USB 2.0 adapter on the image as an output has micro usb plug, while at the OTG Y cable according to the note, into female micro USB a power is plugged and not the “data” output of the adapter? I’m a bit confused…

I did lot of tests with Z1 and charging while streaming and only an USB 3.0 cable was able to increase battery charge while streaming, with any other cable type the battery level was going slowly but down…

All above accessories should be available with USB C, but it was reported as not working anymore, right?

The Z1 uses USB C and will lose charge. There doesn’t appear to be a way to keep the Z1 charged while connected to a USB device.