Ricoh connectivity issue with electromagnetic interference

Hello Team,

Our customers at the site(Basically big car showroom with lights ,etc) facing issues in connecting the Ricoh device with our app and we could not able to reproduce it in-house setup.

Below link it may due to electromagnetic emission interference. Do we have any other list of devices ,etc which emits more radiation apart from the list and any suggestion to overcome/avoid this please

Please post:


  • RICOH THETA camera model
  • firmware of RICOH THETA camera

mobile device

  • model and OS version
  • is mobile data turned off?
  • is bluetooth turned off?
  • how far away is the camera from the mobile device and is there something like a car door between the camera and mobile phone?

If the problem persists, temporarily turn off mobile data and bluetooth from your phone.

@Babu The connectivity problems occur when using your app, correct? Have you tested the problem using the RICOH THETA mobile app as a comparison?

you would really need to test on site to understand what may be interfering, but tell them to try switching camera wifi to 5ghz and not 2.4ghz, this seems to give a more reliable connection in most situations

Hello @Sam_Rohn I could not see that option when i connect to SC2 device and i can see when connect with Z1 model

1 Like

It’s not easily reproducible locally.its only with customer sites, so can’t able to advise to check on the theta app

Okay , this blog says…Theta SC2 model works with 2.4ghz only

How to Use SC2 Wi-Fi API.

That’s where all the electromagnetic interferences we could suspect

Yes. SC2 is imcompatible with 5Ghz wifi. That’s the reason it’s the budget model.
Try to disable “Private Wi-Fi address” and then it might be stable.



Is this “Private Wi-Fi address” on the mobile phone Wi-Fi settings?

1 Like

Much thanks , on our initial round of testing . It behaves far better than before :slight_smile:

1 Like

@Juantonto Is this the setting you are referring to? It helps to have it set to OFF? In the screenshot here, it is set to ON.

@Babu Are you testing with iPhone? Below screenshot is from my iPhone 12 running iOS 16.1.1.


That’s right. Disabling here making our Ricoh plays better if some interferences around

We might initial connection bad for 1-2 times then it will be alright after disabling this

1 Like

@Babu This is very interesting! Do you think it’s a solution? Can you move forward with using the THETA?

@jcasman it would be good to figure out why disabling the “Private Wi-Fi Address” helps with connection before we recommend this widely. Suggest you ask RICOH why this setting would help connectivity with the official RICOH mobile app.

In parallel, you can use an iPhone with the RICOH official mobile app and document tests with connectivity to a THETA SC2 with and without “Private Wi-Fi Address” enabled. You can then publish your tests here.

Ideally, the test would be replicable and we can show that disabling “Private Wi-Fi Address” consistently improves connection.

As the default from iOS 14 is to have the “Private Wi-Fi Address” to be enabled, I would expect everyone with an iPhone to have this problem.

There may be an additional problem with connectivity.