Theta SC won't connect wirelessly

Just got a brand new SC.

If I go into wifi settings on my iphone, select THETAYJ########.OSC and enter the password, it will connect and the wifi icon will stay lit on the camera. However, that is ALL I can do.

If I try to register the device in the Theta app, it cannot connect at all. (whether it is first connected manually through phone settings or not).

If I connect the camera manually and then go into Google StreetView app, it will not recognize any cameras attached.

I spent all day today searching the internet for possible solutions and nothing has fixed it.
-Updated firmware
-Hard reset with power button
-Hard reset with wifi button.
-Tried connecting with airplane mode on and all other wifi connections deleted.

Do I just have a dud?

Any help is appreciated.

If you have a new camera, you can contact RICOH support. They may be able to help you.


In the last few weeks, some people have reported problems with iOS 13. What mobile phone and OS version are you using?

In the past, I had some problems with Android on certain firmware versions, but I can connect now with no problems. I have a Pixel 2.

Other things to try:
You can try connecting the SC to a laptop Wi-Fi, the same as you would connecting your laptop to a normal Wi-Fi hotspot. You will lose Internet connectivity with this test.


Type this URL into your browser:

This will only test if the camera and laptop are connected. Using Google Chrome, I get this in my browser window. Note that I have a special extension on Chrome to format the output, so you will just see black text on a white window with no formatting.

You can try and borrow a friend’s mobile phone and see if it can connect to the camera.

As the camera is new, the best course of action might be to call RICOH official support.

With my computer and the camera connected with Wi-Fi, I can use ping to verify that a network connection is in place. In the example below, the camera is identified by the number sequence

When you connect to the camera with the blue Wi-Fi icon on, the camera is always


Thank you very much! I figured I would try the easiest suggestion first and try a different device because my iphone is running iOS 13… and it worked! Worked perfectly fine on an older iPad.

The problem seems to be caused by having two network connections and the corresponding IP routes in parallel:

  1. WiFi connection to the THETA
  2. Mobile connection to the Internet

The THETA app seems to take the route via mobile connection to the THETA which of course fails. The workaround is to disable the mobile connection.

In earlier versions of the THETA app & firmware and Android, this setup worked without problems. This allowed to get an image from the THETA and to publish it on an Internet site ( or whatever) in a single step. Unfortunately, this is no longer possible.

1 Like

Thanks for the report back on the iOS 13 problem. I don’t have an iOS 13 device and was not able to test it. I think other people have encountered this problem and expect that RICOH will release a mobile app update in the future.