RICOH THETA Z1 - Calibrate Your Compass

Great Tip!

is there an option in the Ricoh SDK so this information could be pushed on the mobile app screen?

this would be very useful because non pro or “non paying attention” users will never notice this!


RICOH can push notifications to the mobile app. However, I don’t think this is going to justify a broadcast out to all users in-app. Maybe we can push this to social media more widely. I’ll put it out on Twitter and Facebook now.

1 Like

Hi, guys.
Sometimes it doesn’t work well. then, try to reboot Z1. The compass びっくり notification will be gone.

Good luck!


@Juantonto OK, thanks for posting this. I believe I have seen this behavior, too.

I noticed that event if this icon doesn’t show up, the compass can be very wrong.

I try to do the calibration process before each shot : north positions are really average, even very wrong…

i think the compass isn’t reliable at all

anyone has good values on a set of several pictures shot during one session?

best regards

I’m a drone pilot. Drones heavily rely on a number of different sensors, one of them being a compass.

The compass device built into the THETA is probably of a very similar type. Just to give an idea of these, have a look here:

When using a drone, calibrating the compass correctly is critical to flight control. A common mistake is to do the calibration in an environment with ferromagnetic metals, for example on a bridge, near a car or in a building. Even outside on a meadow, there may be stuff in the ground that affects the compass during calibration. In the best case, you get an error during calibration, in the worst case the calibration is done with incorrect data and the drone performs a fly-away afterwards …

And even if the calibration is correct, you won’t get correct data from the compass if used in an environment with ferromagnetic metals. For a drone, this is usually only relevant during start (e.g. from the roof of a car) because in the air the drone is typically away from steel constructions, power lines, etc. But a camera will usually be very near to lots of stuff that may affect the compass, especially when used indoors.

1 Like

Also a drone pilot and I totally agree. I find that the compass will show the error the second I add a taller post to my camera mount to allow it to charge while mounted on a tripod. The added metal in close proximity to the camera confuses the compass every time.

When you do the figure of 8’s is the camera horizontal to the ground or vertical?

More or less held it vertical, though I think I moved it somewhat, was not trying to be perfectly vertical or horizontal.

1 Like

Thank you appreciate the answer

1 Like

@Leon_Herbert1 Did you try it? Did it work for you?

I have been trying the above described movement but it is not working for me. Could somebody make a video on how exactly the movement is? or some photos? Thank you in advanced.

1 Like

Tried it and it did not work, then connected Z1 to my phone, started the app, and tried it again, and Voila


It worked for me. Moving the camera in 8’s figure. with the camera turned on, and conected to the app-


Thanks for the success report. It helps other people. Do you think you need to be connected to the app for the compass reset to work? I wonder if the app and the camera exchange some type of info for the compass reset or display of the calibration icon??

and how do you do a factory reset with the z1??? no where to find this in the manuals

is this the reason why you can have stitching issues…? i have Always a blurred space on my photos on the stitching borders…?

You can reset the compass on the Z1 using the figure 8 motion described on this thread.

You can reset the Wi-Fi by pressing and holding down the Wi-Fi button on the physical camera for longer than 8 seconds (might be a bit longer)

The stitching might be related to Adobe Camera RAW.

Also, see this thread:

Stitching Theta Z1 HDR Rendered Pictures

There is an API to reset the camera settings. However, it is not available in the official mobile app.

We can build a simple utility app with only a few features if it is useful for people.


If you calibrate using the app, then close the app, does the compass remain calibrated? I’m not using the app very much, because it isn’t functional when shooting with the dual fisheye plugin (on iOS, at least). Also, it’s unclear to me how much impact an uncalibrated compass might have on my workflow, if any. I calibrate my drone compass regularly, because it flies. My Theta Z1 doesn’t fly. And it’s images aren’t connected until I connect them in the virtual tour. I use Ricoh 360Tours, but will likely move to Kuula due to the cost. Have never had an issue in either platform and my compass has never been in calibration since I began using the Z1! Figure eights only make my shoulders stronger - the compass cares not… Anyway, just checking to see if there’s any new knowledge out there, regarding this topic. Cheers.

If you calibrate the compass once, it should stay calibrated for a while. I’m not sure what makes it require calibration. I also used the camera with an uncalibrated compass and the pictures were fine. This may have more of an impact if you use auto-placement for a tour or Google Streetview where the application you are using to view the images may care about the camera orientation.