SD card slot modification


#26

Any time… Happy to help.


#27

#28

Thanks it’s already referenced at the top of the thread.


#29

What allocation unit size did you use to format FAT 32? if any?

I just completed the replacement with a SanDisk 64GB Ultra Class 10 and it’s only showing 57MB when connecting the camera. I’m wondering if it’s a:

  1. SD Card Brand Issue (SanDisk)
  2. SD Size Issue (64GB)
  3. Formatting Issue (Allocation Unit Size: 16MB)

Any info would be greatly appreciated. Thanks!


#30

Does anyone know if there are any walkthroughs for opening the side? MrTheta, what equipment did you use to cut the opening? Dremel?


#31

@Alvin_Desuasido did you read through this thread?

I haven’t heard of anyone installing a card above 32GB and getting it work. You’re the first.


#32

@codetricity, thanks for the reply. I did see that link and used it to replace my micro sd card; I was looking to see if there was a walkthrough for the mod that @mrtheta did to create an actual slot that can be used to swap out cards easily (cut a hole through the side of the theta).

I thought I saw someone mention on a FB post that 64GB was possible: https://www.facebook.com/groups/RicohTHETAUsers/search/?query=64gb

From the comments, the author, Dave Ng W S, did not have the specifics of the card, but it was said to be a Transcend brand micro SD 64GB. Does anyone have confirmation of a 64GB card working, and if so, the specific brand/model? I already bought the orange Samsung 32GB, but would love to upgrade it to 64GB if possible.

Thanks!


#33

I had read somewhere that the “type” of SD card may play a role in compatibility (but now I can’t find that post). I noticed that the SanDisk 64GB card i had put in was “SDXC”; and most of the posts I have read had mentioned SDHC and MLC as a type to look for.

I thought that may be a reason why certain cards don’t work, but I just read @mrtheta 's post that the SanDisks he tried that DIDN’T work were also “HC”, which may throw my theory out the window;

Just food for thought to see which cards will/won’t work and perhaps to further the quest of finding the largest capacity card that can work in these Thetas. I mean, if we’re going to be cracking these things open, we should be getting the most bang for our buck, right?


#34

In scouring shopping sites, i found a few images of >=64GB cards that showed “SDHC” on the images, but some look doctored, so not sure if it is truly SDHC. I even found one that was 512GB SDHC ?!

Here’s an ebay link to a 128GB “SDHC” - Again, not sure if the image is authentic, but it does show it as “SDHC” : http://www.ebay.com/itm/Quality-128GB-Micro-SD-Card-Class-10-TF-Flash-Memory-SDHC-128G-NEW-UK-/182377320248?hash=item2a76890f38:g:9LAAAOSwopRYYtsJ


#35

it is confusing
Capacity (SD/SDHC/SDXC)
SD Standard Capacity up to 2GB
SDHC Standard Capacity more than 2GB up to 32GB
SDXC Standard Capacity more than 32GB up to 2TB

https://www.sdcard.org/developers/overview/capacity

it is all right and normal, take a look in the Disk Manager on our PC or Mac and check your hard drives there.

Regards Svendus


#36

Isn’t the FAT32 max volume size 32gb? Can the THETA actually read a volume greater than 32gb? The original author Dave Ng indicated that he was using a Transcend high speed. If I were trying this, I would try the Transcend


#37

Yes on Windows
but it seems to be possible to format greater volumes with this GUI
http://www.ridgecrop.demon.co.uk/index.htm?guiformat.htm


#38

So the 32GB volume size is a limitation of the Windows formatting utility and may not be a limit of the RICOH THETA?

@TechRocks, what are you using the 64GB storage for? Do you need it for video storage? Did you see this article that describes how to save the 1080 video stream to disk using OBS and then upload it to YouTube?

http://lists.theta360.guide/t/theta-usb-live-streaming-now-in-full-1080-hd-free-upgrade/639?u=codetricity


#39

UPDATE: All, I just retried again with Samsung Orange (EVO mircoSDHC UHS-I) card (https://www.google.com/express/u/3/product/11210768920829180850_336654991217493402_6136318)

I formatted it with FAT32Formatter (guiloader.exe) and used 16KB as the allocation unit size and replaced my 64GB SanDisk (which I had taken 6-7 pics/videos)

FINDINGS: Still did not work (Red light above shutter flashing, memory still ~50MB).

NOTE: One weird thing I noticed is that the pictures I had taken while the 64GB card was in WERE STILL IN “Camera Images” on app - My theory is that there is an “onboard” memory of ~50MB that is currently being used by the camera and it is not even recognizing either card’s add’l memory. As more evidence, the 64GB that I pulled out (and thought I took pictures on) is empty when viewed on computer.

Is there something that I am not doing correctly that the camera is not recognizing the “known to work” Samsung Orange? Is it a wrong Samsung Orange? Am I not formatting it properly? Do we have to copy the same folder structure onto the new card (I did not and assumed the first picture would create the folders needed)? Has anyone tried to run the Theta with no card?

Thanks in advance and I hope this helps anyone else out…

I’m going to have to try to reload my original 8GB to eliminate the possibility that other factors are affecting the memory readability.


#40

@codetricity, no, the Fat32Formatter in Windows that I used was able to format my 64GB SD card, but I noticed it said something about “2 partitions” in the log.

I need the additional storage so I can keep recording without having to “move to phone” so often. With the 8GB, I filled it up in a week, and I found myself at events wanting to record, but had to go through images/videos and move/delete them when I could have been recording.

Thanks!!


#41

UPDATE: Based on some previous posts, I did the following:

  1. Reformatted 32GB Samsung Orange using Windows built-in formatter (Default allocation size of 16KB)
  2. I copied the 2 folders from my 8GB to my Desktop and copied them to the newly formatted Samsung Orange

After inserting card into Theta, still only have the ~50MB space AND the images from the “onboard memory”; not able to access the additional memory from the new card. Also, initial multiple beeps still on power on and red light above shutter button blinking.

At this point, I will have to go back to my original 8GB card to be sure that it isn’t anything else that could have been caused during opening/closing of the camera.

I’ll keep it posted here, if you guys don’t mind…

UPDATE: Before (admitting defeat and) going back to the original 8GB SD, I thought I would erase the current pics on the camera (~50MB) and see if that was the reason why the camera wasn’t seeing the SD card. Even after erasing all pics on camera, still get the red flashing light, and beeps - I’m thinking that taking pics with a non-readable card (SanDisk 64GB) forced the camera to use another location to save. I’m also having issues with plugging it into USB of computer - it seems to shut down whenever I plug it in, even when I try to power it up. I was thinking of doing a factory reset to re-initialize the camera, but can’t find the Reset button that Ricoh says is above the Serial number.


#42

Back to factory 8GB - All systems normal. Still have some computer connection issues, but will try different cables/computers to see. Based on this, there was probably something wrong with the SD cards I was using? If anyone has experienced anything similar, would love some guidance.

Is the Samsung Orange 32GB I got not correct? Did I format it properly? Maybe I didn’t push it in “all the way” ? Through this whole exercise, I have disassembled and assembled this Theta at least 5 times now… Now that I know my camera can still read SD cards, I will have to find the energy/motivation to try again; but I’d feel more comfortable if I knew what wasn’t working with the SD cards that I’ve tried, and to know that the next card I try will work.

Hope this helps someone someday…


#43

OT: if we run out of memory on the THETA S we just change the settings from Copy to Move
the iPhone has plenty with storage and it automatically uploads to i Cloud and Dropbox with full Warranty :flushed:


#44

@Svendus has a good point. It’s not recommended to hack the THETA to change the SD card. If @TechRocks wants to pursue it for technical challenge, I suggest he gets the exact same card and format settings from @mrtheta. At least he’ll get to 32GB. It seems that he went back down to 8GB.


#45

@Svendus:

“Your iphone” may have plenty of memory… :wink:

Mine is running on fumes =)

Maybe it’s time for an iphone upgrade as well with this new Theta. I did recently spring for the iCloud upgrade which did free up tons of space.