External USB Storage With THETA V Firmware 2.10.1


#1

New firmware is out for the Theta V and it is supposed to allow transfer of files to USB device. (!)

https://theta360.com/en/support/manual/v/content/usb/usb_01.html


#2

I’m going to purchase this: https://www.amazon.com/gp/product/B01M127X8F/ref=ox_sc_act_title_1?smid=ATVPDKIKX0DER&psc=1
I have no idea what a OTG flash drive is but it is supposed to allow backing up of Android phones etc. I guess it should work. I will report back!
I’m actually so excited that I might have to drop by local Microcenter store and pick one up today, since they have a reasonable selection and pricing. Search OTG+Flash


#3

So I just tried it out with both a 32gb and 64gb flash drive with an OTG microUSB adapter. The flash drive should be formatted as MSDOS FAT32.
You only need your iPhone - Mobile device to initially select the USB data transfer mode in the plugins in the camera settings (not the shooting settings). This setting is retained on the Theta.(It appears)

After you are done filming and want to do the transfer. Insert the OTG Flash drive. Hold the mode button until the camera status light turns white. Hold and release the shutter button and then the camera icon will flash while it transfers the files to the USB Flash drive. This takes a while,
Once the transfer is done, the camera returns back to regular shooting mode. (The white camera status light returns returns to blue.)

The files should now be on the flash drive and the original files deleted from the camera.

Excellent job, Ricoh!


Here is a quick YouTube video:


#4

@ZZChu, nice sleuthing! I need to get an OTG (On The Go) Micro USB-to-USB adapter cable or a flash drive with an OTG micro USB adapter like you got to fully test this. I’m going to Best Buy tonight!

Super small detail, as I was upgrading to the Version 2.10.1 firmware that supports this, to be thorough I made sure to upgrade my RICOH THETA desktop app first. I thought there was a newer 3.3.1 version. I was at 3.3.0. After doing it 2-3 times and it seemingly wouldn’t work, I released the new 3.3.1 version is just for Windows. Mac is still at 3.3.0.


#5

I might try it with 2.5" SSD drive but I don’t have an empty one right now( via a SATA to USB adapter), I am not sure if it will draw too much power from the camera though.

In terms of price per gig of a SSD versus a flash drive, it is probably the same price.

I’m curious how long it takes to transfer a completely full Theta to a flash drive.

Also, what happens if there isn’t enough space in the destination drive?

A full theta is about 19gigs–so one could transfer maybe 3x full Theta into a 64gig Drive?


#6

This is a great report. Thanks for sharing it. There’s a lot of valuable information in your experience.


#7

Sony ‘s USM32SA1 is good to show its writing status by embedded LED. https://theta360.com/en/support/faq/c_06_v/6136/


#8

For people that don’t normally update the firmware, here’s the process.

It’s a 663MB file to go from 2.00.2 to 2.11.1.

Start the THETA desktop software.

Go to Firmware Update
image

Plug in camera with USB cable when asked.

image

During this long process, the upper right will show a moving circle to indicate that the upgrade is progressing. This may take more than 5 minutes.

image

After the firmware update completes, you can check the version you have by attempting to upgrade again. If it is the newest version, you will see this:

image

You can also right-click on the THETA V icon in Windows and see the version number in the properties:

image


#9

Few more notes:

A 2.5” SSD (formatted as FAT32) will work. I was concerned the SSD would draw too much power.

If the Theta V has an assortment of movie clips and one of them exceeds 4gigs in size, it will not transfer ANY of the files. The transfer process will not start and it exits the USB transfer mode.

I might have to reenable the 5 minute recording limit if I really want to use the Theta’s offloading functionality in the field.


#10

@ZZChu Thanks again for all this great info.

We’ve posted full guide with all the info summarized and easy-to-use format here:

http://theta360.guide/usbstorageplugin/ [edited, new URL]

47%20PM


#11

It took 22 minutes to transfer 3.8 gigs worth of files from the Theta V to a USB 2.0 flash drive. There wasn’t much power left on the Theta after the transfer. (Since I was recording first)

I also had problems troubleshooting why the initial USB transfer would not engage, but fixed it by freshly reformating the flash drive.


#12

I just found out that I made an error in thinking that if one file is larger than 4 gigs that the smaller files will not transfer. It seems to transfer the small files and leave the larger >4gig file on the camera.

My flash thumb drive, which worked fined before, needed a reformat. (The Theta V would return to ready after attempting to transfer immediately before the drive was reformatted).


#13

I think that FAT32 doesn’t allow transfer over 4GB.


#14

Updated the guide with this new info @ZZChu and @codetricity, down in the Notes section:

http://theta360.guide/usbstorageplugin/