SOLVED: Ricoh Theta SC problem - 2 beeps and red light blinking (faulty camera motheboard)


#1

Hi there,

Would like to ask if anyone have the same issue as me. I bought the Theta SC few weeks ago and it was working fine all the while and until 2 nights ago when I wanted to charge it, the moment I plugged it into my laptop and there’s 2 beeps and the red light kept blinking. I thought it was memory full but according to my phone’s gallery, I’ve only took like 67 photos and a few short videos and it’s impossible to be full. When I checked on my app, the max number of shots I can take is only 11 shots and I can’t access the older photos and videos that I took earlier which is stored in the camera. After a round of panic and randomly press which ever buttons available, it went back to normal.
A night later, I tried plugging it into my laptop again and the same issue happened again and again somehow managed to get it back to normal by randomly pressing the buttons.

And just moments ago, I tried to turn on and snap some photos and it the blinking happened again. I turned it off and I on it back and it seems to be normal again.
Anyone else face the same problem that I’m facing? Is there anything wrong with the hardware or the software?

Would like to hear from you guys out there.

Many thanks!
Alistair

Moderator Note: Scroll down to the end of this thread and check Alistair’s experience with replacing the camera under warranty. The beeping and flashing correspond to a faulty camera motherboard.


#2

hi @Alistair
did you any time format the inbuild Micro SD card ?
when you say Laptop you are on PC right ?

Regards Svendus


#3

Hi @Svendus

I have no idea how to format the inbuild Micro SD though. Oh btw, Im using Macbook.

Thanks
Alistair. :slight_smile:


#4

Alistair,

It could just be a hardware malfunction, and in that case you’ll need to contact RICOH support directly. https://theta360.com/en/support/contact/

Couple ideas, though, depending on how much you like trying to fix things yourself.

I believe you can hold down the WiFi and shutter buttons while you plug in the USB cable to enter Mass Storage mode. You can then look at what files are on your camera. I can do this on my THETA S. I don’t have an SC, though, so I’m not 100% sure it’s the same. This isn’t a fix for your problem, but it might be reassuring to see what files are on the camera.

Another possibility is firmware. You might need to upgrade. It shouldn’t be hard or scary. This is old information and a completely different model, so definitely take it with a grain of salt. But it might give you some ideas for making sure you’re using the most recent versions of the Mac app and the camera firmware:

http://theta360.guide/blog/camera/2016/01/20/fixing-bricked-theta.html

Hope it helps,
Jesse


#5

hold down the WiFi and shutter buttons while you plug in the USB cable to enter Mass Storage mode.
acrobatic gesture :slight_smile:

On mac you docent see hidden folders type .Trash but with a application called MacPilot you can access
hidden folders

in this mode You can also reach the storage in theDisk Utility app

and in Disk Utility app you can erase or format the storage when in Mass Storage mode
But when You stand in the RICOHDCX katalog or folder try to press cmd+shift+G

and go to the .trash folder if it exists and erase its content
You should use the in build Image Capture app on a Mac to import and erase images from a THETA
not the IMAGE or i Photo application

Regards Svendus

@jcasman may be we should ask for a Erase or a Format button on the THETA itself
to clean up the storage in the right way on OSX
this troubles for mac users are not clear on the RICOH THETAuser Guide

PS i think the .trash folder are created by i Photo or Images app on OSX


#6

@Svendus Agree that an Erase or Format button might be useful


#7

it should make it easy when you are away and did forget to clean the storage while connected your computer last time :grinning: happens more often in old age.


#8

If that doesn’t work, I’d try to fully charge the THETA SC from a wall outlet, then attempt to upgrade the firmware with the desktop app.

You can see the battery charge with the mobile app.

https://theta360.com/en/support/faq/c_02/24/

You can also try to press and hold the power button for longer than 8 seconds prior to plugging the THETA SC into the USB cable.

https://theta360.com/en/support/faq/c_01_s/8/


#9

is it not storage full indication
i think the hidden folder .trash are full do to the use of i Photo or images on OSX


#10

Thanks for all your feedbacks guys! Really appreciate it! :slight_smile:

I’ve tried contacting the RICOH support via their online form but it seems like it’s only available for USA and Canada and I’m living outside the State. I’m from Malaysia but I’ve managed to contact the local support here. Probably will drop by and give it a check on my SC.

I hope it’s not the hardware malfunction and it’s only the software. I’ve updated the firmware to the latest once as per on their support page. So hopefully it’s one of the bug from the firmware. fingers crossed

I’ll give it a try to get into the Mass Storage mode and format it when I get home from work later. :slight_smile:

@codetricity, we can charge it using a wall plug? Based on the manual given, I dare not to charge it via wall plug, I afraid I will burn it. Haha… :disappointed_relieved:

Once again, thanks all for your help! I’ve been searching all over the internet for solutions and no one seems to have this issue yet! Probably I’m the “lucky” one! haha :sweat_smile:

Will keep this threat updated if there’s any other issues pop out!

Many thanks!
Alistair


#11

I think you’re right.

https://developers.theta360.com/en/forums/viewtopic.php?f=5&t=713

The first thing to try is to get rid of the .trash folder and then stop using iPhoto with the THETA.

I was thinking his storage might be full and his camera could be low on battery. He may have multiple issues he needs to overcome.


#12

Hi all,

I’m back again! The Theta been behaving quite well recently and today, it went cuckoo again!
Tried entering the Mass Storage mode and this is what I got.

Is it in safe mode or something? my storage capacity went from big to small! So not impressed by it! :disappointed_relieved:


#13

Hi first of all
how do you transfer images from the THETA to your mac ?


#14

Hi, I usually transfer it from my phone.
I took photos with the app and then I back up from phone to my mac. I hardly plug my Theta into my Mac other than charging it.

The storage went low when it comes to the red light beeping. Once the Red Light beep is gone, it went back to normal 8GB. However I tried formatting it and seems like it’s still the same. I managed to get it back to normal and also formatted it and it works just awhile and then it beeps with red light again.

From what I discovered from plugging in and out, possible to have 2 partitions or 2 modes:

  1. Normal mode, White Light:
  • 8GB storage.
  • Works like normal Theta.
  • Couldn’t access photos taken when the Red Light appears.
  1. Backup or Safe mode?
  • About 60MB storage.
  • Red Light and it beeps.
  • Couldn’t access the photos that previously taken while the Theta was in ‘Normal Mode’.

Am I the only one who encounter this problem? :confused:


#15

all right do you move or copy from the THETA to the iPhone ?

standard on mac when you plug in a camera i Photo or Images opens

Am I the only one who encounter this problem?

Answer is no you have normally one partition on the inbuilt SD memory card
but you have a hidden folder .trash (i Photo created) that you do not see
hate to say it, but this problem is a bad apple :cry:

here is how it looks when you connect the THETA to a Linux machine

the .trash folder are not seen on Mac but on Linux you just click Ctrl+h
Show hidden files and folders


#16

My settings are Copy to Phone and everytime I plugged in to my Mac, both iPhoto and Image Capture will open by itself.

Worse still now after formatting it last night, I couldn’t even get it working. I’m stuck with the Red light beep now.
I guess I need to send back to the shop and claim warranty. :disappointed_relieved:


#17

To bad i think this is a problem RICOH must look into
one has to have the import in I Photo or Images unchecked to make image capture take over the import
Rather strange that i Photo can write to the SD card on the THETA
you cannot do this manually
I am sure that a script run in the Terminal
could format restore the file structure on the THETA to make it run again
but it is as said something for RICOH to look into
We actuarially never use I Photo :rage: more than to see images on iCloud


#18

Im more curious on why there are 2 different capacity storage when ther Red Light is blinking tho…
I think RICOH must seriously look into this issue. :unamused:


#19

@Alistair
could you please take a screenshot of the

Thank You

Edit : there are only a little talk about THETA on the Apple forum
May be We should take this subjeckt up there
to prewent others from this problem ?


#20

If you noticed from the photo I shared earlier,

The storage capacity dropped down to 57.3MB with the Red Light beep.

Meanwhile if it works normally,
Storage capacity is back to 8GB. Sorry didnt managed to screenshot mine and I can only upload 1 photo per post.

Anyway, I’ve sent my SC back to the distributors and waiting for them to get back to me. But I was told that most likely they will do 1 to 1 exchange. :slight_smile: