Did 2.00.1 just brick by Z1?

Hi guys,

I’ve just updated my Z1 to 2.00.1 … I usually don’t update things that work well, as it did… but… I felt like it.
Now the camera won’t allow me to delete images, shuts down with a red triangle and error or even lets me take a picture.
Is there a way I can completely wipe it, format the storage and reset it to factory defaults?



To add… I’ve manage to delete all images from storage using image capture on my mac… hoping that would help. But it didn’t.
If I take a picture, I hear the sound, then the blue light starts flashing… keeps flashing for a while and is then followed by the error and shutdown.
It’s frustrating as I’ve been using it often and it’s been very reliable …
Any help would be appreciated as I would need to use it tomorrow agian…

Here’s a video to the problem: Ricoh Z1 firmware 2.00.1 ERROR. - YouTube


hi! I would try to reinstall firmware. I was able to initiate this, but you need to have some technical knowledge to do so and I cant promise it will work for you…

  1. register at ricoh developer and put your camera in “developing mode”. This will work only after you register, fill out a form , adding your serial number of the caemra, etc.
    RICOH THETA Plug-in Partner Program
    at the top the link to click: https://www8.webcas.net/db/pub/ricoh/thetaplugin/create/input
  2. you fill out form, etc. including your Z1 serial number and you wait, once they approve, you should be notified by mail.
  3. on PC, use Ricoh desktop application to turn ON developer mode of camera.
  4. Install a software called Vysor, once camera is connected to your PC, run Vysor, in theory you should be able to see and control your camera like a mobile phone through your PC. here you will find an older andorid running.
  5. inside Z1 android using Vysor, go to SETTING-> BACKUP & RESET and initiate a “FACTORY RESET” through vysor.

MAke sure that before you proceed you copy images, etc. to your pc, all data will be lost on Z1 after reset. Also I was able to see “FIRMWARE UPDATE…” message after I initiated this in past.

I really hope that this may help you… Good luck!



I’ll give it a go!

1 Like

Hmm… didn’t get a reply/ approval. How long would that normally take?

You can send them a note here:


RICOH THETA Plug-in Partner Program|RICOH

Are you using the desktop app to attempt to the firmware upgrade?

Read this article below, especially the note about the process deleting all your images and settings on the camera. The process is the same with the Z1.

This is exactly the same process i also took for z1,without being aware of that article.thanks for sharing!

It takes some time to get developer mode for sure…


So I got confirmation that I should be able to get into dev mode, verified it on their website (SN matched) but am unable to activate it… I’m using the Theta app on my mac but and then it’ll say dev not registered… anything I’m missing?


Hi! Try please to plug in cable into Z1, connect it with PC and turn off Z1, by holding down power button for short time. Now try to start again Theta app on PC/Mac and turn on DEVELOPER MODE. I will retry this process on my existing camera to confirm.

@craig ,
I’m having the same issue as reported by @squarepxl , I can’t change DEVELOPER mode anymore. I tried to turn off to test the process and I got the same error MSG:

“DEveloper is not registered”, but I used this, turned on and off several times in past and it worked so far. I’m on latest firmware and using Ricoh Theta desktop application on windows, seems the same issue as on Mac, this may be related to ricoh site, probably there is a request going from app toward ricoh site to verify registration, but it doesn’t work anymore.

Could you help please what to do? This me be an overall/global issue? I tried using 2 Z1 cams and verified the serial number for both is there on ricoh profile visible for me…


Desktop app version is 3.16.0 for me… Actually I tried to turn off developer mode a few weeks back and it failed, but I thought there was another temporary reason behind, but seems its failing every time now.

Thanks for verifying this. Hope it gets fixed soon!


Can you open up a support ticket here:

RICOH THETA Plug-in Partner Program|RICOH

Hi, Craig!

I just did so right after I commented yesterday, form your earlier comment, it’s the same URL. I wasn’t sure if the same should be used…


I have the same problem on my camera, it may be a global issue. The desktop app is now saying that my camera is not registered as a developer even though it is registered.



The support ticket goes into Zendesk and is tracked. You should have received a confirmation from zendesk by email.

I emailed them about this quite a while ago, have not heard anything yet.

Cheers, Ton

Update February 24, 2022

Please Try it Now






Did you get an automated support ticket from ZenDesk?

please resend the request and reference the ticket number. Just ask for the status of the ticket and ask them to confirm that they got your request.

Ideally, the person that received your request delayed a response because they are waiting for a solution from another group. However, if you just ask them to confirm that they got the request, then it will be easy for the person to answer.

hi @craig, @squarepxl ,
I tried and it worked for me too today!

squatepxl, please try and let us know, also if you were able to correct cam by vysor reset somehow…



I was able to get into dev mode and do a full reset. Sadly it didn’t solve the issue that started after updating to the latest firmware. It’s still shuts down after a while (not doing anything) with 3 beeps, a red light and error.
I’d love to roll back the firmware but from what I was able to google that’s not possible.


Thanks for the help!

Is this normal? It should be empty… or does the Theta reserve that for images?